Can't locate files in Sketchbook


(Daniel Tran) #1

In my Arduboy IDE application, I have set my Sketchbook to C:\Users(Name)\Documents\Arduino. However in the application, no results come up when I try to upload a sketch using File -> Sketchbook . I have included an image that shows my Arduino folder in case I have configured something incorrectly. Please provide your opinions/assistance, thank you!


(Ross) #2

Hmm… quick post, maybe not an answer to your question yet, but here it goes! :smiley:

Codebender, of Course.

Well… before I think too much about what might be going on, and if you want to try some games out ASAP, then check out Codebender.

https://codebender.cc/user/ArduboyGames

Using their IDE at least gives you a chance to start loading games and learning the process. Maybe work with source before you figure out the Arduino environment. The Arduino IDE and the corresponding environment is a pretty interesting setup unto itself, and has some “gotchas”. It will all make sense pretty quick.

Arduino Documentation

Then I would also make sure you know about the pretty decent Arduino Documention, and in particular the Sketchbook section.

Try the File System

I would also try opening the sketch using the .ino file found in the folder for the sketch. I actually don’t use the sketchbook very often, I almost always use the file system for the OS to open the sketch file.

An example sketch location on disk might look like the following filepath.

/home/ekem/projects/mySketch/mySketch.ino

The sketch file for the sketch named mySketch is named mySketch.ino and can be opened by finding the file on disk and double clicking it, or opening the file with the IDE using file > open from the same location.

Random

For your question I will have to open up the IDE and goof around to give a set of instructions for resolving your setup.

Also, I’ll provide a link to the editor I use for editing the plain text found in the text file that is a sketch’s main file. In the above example it was mySketch.ino. It’s more of a joke, but it’s worth reading perhaps.

Why I use Vim. Pascal Precht.


pascalprecht.github.io


(Scott) #3

Although opening files outside of the Sketchbook mostly works, it’s not really the way the Arduino environment is intended to be used. This technique goes against recommendations in the Adding sketches guide and may be confusing for beginners.


(Scott) #4

@dtran99, Your screenshot and what you’ve described looks OK. Was the Arduino IDE closed when you added the sketches? The IDE only indexes new sketches when it first starts up.

Something you could try is to save a new sketch. When you start the IDE, the editing window should contain a template sketch with empty setup() and loop() functions. Try saving this sketch unchanged using File > Save and just save using the name and folder presented. Does this new sketch’s folder appear in the same folder alongside the CascadePath and ECOMD_AB_v10 folders that you added?


(Kevin) #5

If you still have arduino open when you load stuff in it won’t show up make sure you restart all instances of the application when you make changes there.


(Daniel Tran) #6

I eventually figured out how to refresh the sketchbook list, thank you! You wouldn’t know by any chance if the Arduboy is able to hold more than one sketch, would you?


(Scott) #7

Only one sketch at a time. There isn’t an actual operating system that would allow you to select between multiple games. However, a sketch can be written that contains multiples games, provided there’s enough program memory to fit them. The Atomic Puzzle Pack is an example.


(Ross) #8

Is the solution something other users might be able to use if they run into this problem? If so, it would be great if you could post that. I’m not even sure what you did here ; )

Glad you got it going.


(Daniel Tran) #9

SOLUTION I double checked that my sketches were in the correct folder, double checked in preferences that Arduino has the right folder, and I restarted the Arduino application.


(Ross) #10