Can't upload games

when using the arduboy uploader, I get this image
when using the project manager, it starts to freeze my computer and I’m forced to exit.

my arduboy came loaded with a game called Sirene. I’m not sure if it’s supposed to come with anything already loaded. the included cable also didn’t work. could I have received a used, faulty unit?

the drivers are installed.

Although I can’t help with the technicalities, it is supposed to come installed with Sirene.

If you are on windows, open device manager. When you first plug in the turned on arduboy do any leds on it flash? Does the device manager automatically window refresh? Under the COM port drop down does something along the lines of “arduino leonardo” pop up? I’m gonna guess your computer doesn’t have the correct drivers installed and thus doesn’t see the arduboy. If you don’t have the arduino IDE installed then install it, and if you do try reinstalling it and make sure to allow it to install usb drivers (a pop up should appear during installation asking for permission to install usb drivers).

is it switched on or off when it’s connected to pc?

leftmost yellow light flashes, PC makes the “device plugged in” sound, device manager refreshes. arduino leonardo COM11 shows up. I allowed it to install everything it asked but I’ll try it again.

That all sounds correct to me. I haven’t played Sirene myself, does anyone know if there are any special considerations to get the arduboy into bootloader mode with this game loaded? Barring that you might have to play with timing pressing the tiny reset button on the bottom of the arduboy and clicking the upload button on the computer to get it to successfully upload a game. I’ve never had much trouble uploading games and it is usually plug and play so to speak with the exception of games like arduventure which require you to enter an upload mode on the arduboy itself before allowing you to download a new game.

You can try flashlight mode (can’t remember if it’s in Sirene.)
Hold up whilst powering on
the led will be white with a white screen.
Then try upload a hex with it in this mode.

doesn’t work for some reason. holding up does nothing

I should also note that the arduboy reboots during the transfer, disconnecting and then reconnecting to the PC.

Just to clarify hold up with the Arduboy off whilst still holding up switch it on.
It’s normal to hear it reconnect after upload as it does a reboot.

Sounds like the Sirene version with the magic boot key problem.

Try this:

where do I find the IDE?

Flashlight worked here
There’s also another thread using the reset method that was successful.

ProjectABE should work well with reset as it will upload every time an Arduboy is detected.

@BookCrate you can find it here:

yeah like I said, turning it on while holding the up button does nothing. I’ll try this IDE thing now.

followed the instructions. still getting the red screen error with arduboy uploader, and proejct manager keeps hanging. I seem to be able to upload using the IDE, but not the other sofware, and I’m not exactly sure how to upload from a hex with the IDE.

tried arduboy game loader and it doesn’t get past this point. maybe it doesn’t have a bootloader?

I’ll have to edit this post to respond for the next 22 hours due to limitations on new users.

Thanks @Mr.Blinky, that worked a charm for me. I also had an Arduboy shipped with Siren installed and couldn’t upload and couldn’t get the device into Flashlight mode. Uploading Blink after the reset worked great. My device now goes into flashlight mode and I can upload other sketches. :tada:

1 Like