Can't upload sketch


(Scott) #12

Make sure your Arduboy is turned on when you try to connect it to your computer. It may also be a problem with the USB cable that you’re using. If possible, try a different cable.


(Ross) #13

This is where I usually suggest you start with www.codebender.cc, and use the Arduboy Games account.

https://codebender.cc/user/ArduboyGames

This should work every time, and will let you start playing while you get the Arduino IDE in order.


#14

Very strange, I tried codebender, I get to the point where I can chose the board and port and there is no port detected even though the Arduiboy is plugged and switched on… I am 100% sure of my port and cable as I use them for my telephone :frowning:


(Scott) #15

If that is truly the case, then the USB port on your Arduboy may be bad. But note that other people have had cables that worked with their phone but not with the Arduboy.


(Tomi) #16

On Linux it’s easy to see if the computer has even tried to connect the USB device (dmesg listing), but I don’t know how to do that on Windows.


#17

Oh. Then I should start here I guess.


(Ross) #18

This actually isn’t necessarily true. A cable can be used to send data to a phone just fine, like a file transfer, but still not work with an Arduboy. Cables get kinked and damaged, or may be made of inferior materials. These types of connector issues can cause a disparity in signals, and a loss of sync when when uploading information to an Arduino product, like the Leonardo (Arduboy).

I really do recommend getting a brank spankin new cable, a decentish one and giving it a go. You can find quite a few issues like this, resolved with new cables in the #arduboy:issues category. It might be enough of a thing, where it would be worth bundling a cable with the units.

Here is some more information, that is related to cable quality, and difference in performance. Not related to data-sync, but it demonstrates a common problem in cables.


(Phil Graham) #19

I’m getting the error message error status 1.

Error compiling board Arduboy.

What I’m I doing wrong?

When it says library is that where the ino file should be or does it mean library board

That’s the only thing I can’t do upload a sketch.

Tia!


(Scott) #20

@phil8715 Tell us what the output line containing fatal error: says.


(Phil Graham) #21

That’s the only error message I’m getting.

I’m new to all this and have no idea about the process I’ve looked in the guide on how to run sketches but I’m none of the wiser.


(Scott) #22

When you get the error messages, click on the Copy error messages button and paste it here so I can see all of it.


(Phil Graham) #23

Arduino: 1.8.1 (Windows 10), Board: “Arduboy”

C:\Users\philg\AppData\Local\Temp\untitled324021367.tmp\sketch_jan28a\ChickenX.ino:14:24: fatal error: ArduboyDev.h: No such file or directory

#include “ArduboyDev.h”

                    ^

compilation terminated.

exit status 1
Error compiling for board Arduboy.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.


(Scott) #24

Chicken Cross was written for the Arduboy DevKit and the author hasn’t modified it for use on a production Arduboy. Please use my updated version:
http://community.arduboy.com/t/chicken-cross-my-first-arduboy-game-video-github-inside/134/24


(Phil Graham) #25

Tbh I don’t understand. I’ve downloaded Arduboy2 and tones, I think I installed them but it’s not showing up in the list of boards.


(Scott) #26

Arduboy2 and ArduboyTones are libraries not boards. Please follow step 2 of the Quick Start Guide to install them using the Arduino Library Manager.

Then, follow the Adding Programs Guide to install sketches. Pay close attention to the parts about using a folder named after the main .ino file, and adding all the .c .cpp and .h files that are part of a sketch.


(Phil Graham) #27

What’s happening is I select the game but it doesn’t open when I click it.

I’m not sure if the files are in the correct place I put them in the same section as the library but not in the library folder.


(Scott) #28

What do you mean by this? Are you using:
File > Sketchbook
in the Arduino IDE?


(Phil Graham) #29

Can you simplfy the whole proces?

My background isn’t in programming or understanding how any of this stuff works.

I need a step by step guide rather than the guide which assumes you have knowledge of Arduino which I have not.

I’ve looked at videos which makes the process look easy but I’ve followed the videos but I still can’t get it to work.

My biggest problem is getting Arduboy 2 to show up in the boards.


(Scott) #30

I’ve already told you, Arduboy2 is a library, not a board. It will not show up as a board.

The Arduboy2 library is installed using the Arduino IDE’s Library Manager:
Sketch > Include Library > Manage Libraries...

Sketches will then automatically use the Arduboy2 library if they require it.

When you use menu
Tools > Board:
you should always select Arduboy. If you haven’t installed board support for the Arduboy and DevKit, you can select Arduino Leonardo instead. Selecting either Arduboy or Arduino Leonardo will both work the same.


(Phil Graham) #31

I’ve only gone and successfully uploaded a game via sketch.

Thanks for your help,!