Clueless and lost

Just got my Arduboy (Kickstarter) today and was excited to start it up, download games, and get playing…

I am so lost. I have a Macbook Pro (El Capitan), downloaded the main Arduino program. Downloaded some games through github and tried Sketch>Include Library>Add .zip library>and then added my games that I had downloaded.

I only figured all that out through different tutorials and walkthroughs that still left me confused with no additional games to play. I have little/no programing experience except some HTML in a HS web design class 10 years ago.
Please help!

We do need a first time walkthru probably. You want to add the main Arduboy code as a library, you don’t add individual games as libraries - you just open them up in the IDE and click the compile button.

The readme has instructions since I’m not sure we’re in the official Arduino library tool yet:

1 Like

@ekem Probably need instructions for downloading and installing the library from Github from a zip file also in the README - shouldn’t assume people re using git.

1 Like

Thank you for your help. Still lost, but clicking around, reading what I can, and trying stuff. Hoping it works. I think I already downloaded the Main Arduboy code, tried to compile them (asks me to save it?), and then it comes up with an error

“Not used: /Users/orangeshoeskid/Documents/Arduino/libraries/Arduboy-master
exit status 1 Error compiling.”

Rename it to just “Arduboy” no “-master” and see if that helps you.

I feel like it might have helped? Maybe? I think I may have even added a game? or two?
I only have the Blob Attack game on it now though, and can’t find any others… (not sure how I’d change games anyway).

Yeah. Not working still. I actually think I’m doing it correctly this time too.

I open the sketch for a game (snakeling, pang, mega man, tried the chrome dino but it worked even less), and choose upload. It continues to come up with an error with compiling. I go double check that the board is “Arduino Leonardo” and that the port is correct (I think it is, only one to choose from). Still comes up with the compiling errors each time.

Side note questions…

  • Should i have the arduboy turned on or off?
  • Once i do get more games, how do I change between them on the arduboy?
  • If by chance my problem is that I’m using charging cable instead of data cable… how would I know, and would it actually make a difference? (feel like an idiot for even asking that last one)

Yes you need a data cable, programs are data. Can’t help if you don’t share the EXACT errors. You can’t program it if it’s turned off.

I figured as much about the cable. Not sure if mine are data or not, got loads of them everywhere. May need to try some others just in case.

When trying to upload snakeling, this compiling error pops up…
“Not used: /Users/orangeshoeskid/Documents/Arduino/libraries/Arduboy-master
exit status 1
Error compiling.”

There are times where it says “uploading” and gives me information about how much space it is taking up,
“Sketch uses 3,916 bytes (13%) of program storage space. Maximum is 28,672 bytes.
Global variables use 148 bytes (5%) of dynamic memory, leaving 2,412 bytes for local variables. Maximum is 2,560 bytes.”

but the “uploading” never goes away so I’m never sure if it actually is uploading, or can’t, or who knows what…

The library folder should be named “Arduboy” not “Arduboy-master” as I said earlier.

If you’re getting to uploading that’s pretty good… sounds like you just need to find a good cable (and maybe pick the correct port in the Arduino IDE).

Ah, library folder, I tried renaming the file “arduboy” without the “-master”. I’ll go try that. I think I found a better cable, and it is only giving me two options for the port.

I’ll try renaming the folder… doesn’t work, then I’ll try the other port. Fingers crossed…

To be clear:

It should be:

Should I remove -master from all of them? snakeling and pang have them at the end as well.

Wouldn’t hurt… sometimes IDE insists the folder name match the *.ino filenames.

Yikes. Changed the folder and this error came up.
	at javax.swing.AbstractButton.fireActionPerformed(
	at javax.swing.AbstractButton$Handler.actionPerformed(
	at javax.swing.DefaultButtonModel.fireActionPerformed(
	at javax.swing.DefaultButtonModel.setPressed(
	at javax.swing.AbstractButton.doClick(
	at java.awt.MenuItem.processActionEvent(
	at java.awt.MenuItem.processEvent(
	at java.awt.MenuComponent.dispatchEventImpl(
	at java.awt.MenuComponent.dispatchEvent(
	at java.awt.EventQueue.dispatchEventImpl(
	at java.awt.EventQueue.access$500(
	at java.awt.EventQueue$
	at java.awt.EventQueue$
	at Method)
	at java.awt.EventQueue$
	at java.awt.EventQueue$
	at Method)
	at java.awt.EventQueue.dispatchEvent(
	at java.awt.EventDispatchThread.pumpOneEventForFilters(
	at java.awt.EventDispatchThread.pumpEventsForFilter(
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(
	at java.awt.EventDispatchThread.pumpEvents(
	at java.awt.EventDispatchThread.pumpEvents(

and then, just because I hadn't tried yet, I tried switching the port, and this error came up
"In file included from /Users/orangeshoeskid/Documents/Arduino/sketch_feb20e/sketch_feb20e.ino:5:0:
/Users/orangeshoeskid/Documents/Arduino/libraries/Pang-master/sound.h:12:1: warning: narrowing conversion of '300' from 'int' to 'const byte {aka const unsigned char}' inside { } [-Wnarrowing]
/Users/orangeshoeskid/Documents/Arduino/libraries/Pang-master/sound.h:12:1: warning: large integer implicitly truncated to unsigned type [-Woverflow]
Multiple libraries were found for "Arduboy.h"
 Used: /Users/orangeshoeskid/Documents/Arduino/libraries/Arduboy
 Not used: /Users/orangeshoeskid/Documents/Arduino/libraries/Mega-Man-Scrolling-Demo-master
 Not used: /Users/orangeshoeskid/Documents/Arduino/libraries/Arduboy1

Sketch uses 7,382 bytes (25%) of program storage space. Maximum is 28,672 bytes.
Global variables use 1,242 bytes (48%) of dynamic memory, leaving 1,318 bytes for local variables. Maximum is 2,560 bytes.
	at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(
	at cc.arduino.UploaderUtils.upload(
Caused by: Error touching serial port '/dev/cu.MegsMacbookPro-Bluetoot'.
	at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(
	... 6 more
Caused by: jssc.SerialPortException: Port name - /dev/cu.MegsMacbookPro-Bluetoot; Method name - openPort(); Exception type - Port busy.
	at jssc.SerialPort.openPort(
	... 7 more"

Warnings are technically ok. It sounds like you have it working except for the upload part.

Get a good cable and make sure the right port is selected and your device is on - then try the upload.

And that is the wrong port… you’re looking for a USB serial port. It should show up when you have it plugge in with the proper cable.

Hmm, I wonder if both of my usb ports are messed up, or maybe it isn’t recognizing the usb port because I might be using a charging cable instead of a data cable.
The other port is /dev/cu.Bluetooth-Incoming-Port .

You need to be 100% sure you have a data cable or no use wasting time checking anything else.

Checked past monoprice orders and found this cable way back in a drawer. Hoping and thinking the “charge & SYNC” means it will transfer data.

Should uploading a game take 15 seconds? 2 minutes? 15 minutes?