Dark&Under - A Dungeon Crawler

@filmote, should we move the code into a subfolder instead of root?

This is at least the 3rd time we’ve had someone bring up this issue and to be honest I often end up forgetting to take the -master off of games that are dumped in root until I’ve already clicked the .ino.

I mis-guessed, only one other case of this being the issue.
Though I’ve seen it crop up a lot elsewhere.

I think this issue is a little different as I think the folder structure between the INOs and the /src/ subdirectory was broken. He has correctly placed it in a directory with the same name as the INO according to the error message.

Having said that, it would not hurt for future downloaders.


I think that it would be realy helpful for newbies like me if all files that are needed were already in a Dark-And-Under folder in the zip.
Just like CastleBoy did handle that.


I’ve made an issue out of it.

Probably easier for you to handle it since I’ll be disappearing for the night shortly.
(Also I’d have to dig out my copy of portable git to handle the moving since the UI isn’t very good at handling moves.)


I’ve just finished retroactively adding .hex and .arduboy files to the releases page of Dark & Under.

From now on if we have any more release we’ll strive to make the .hex files available alongside the releases to make downloading the games easier for people who don’t know how to compile the source or don’t want to download the whole source just to get a .hex file.

We’re also in the process of moving the source code into a separate folder to adhere to the Arduino IDE’s rule for .ino files so people won’t have to rename the file they extract from the .zip/.tar.gz every time they download a fresh copy of the code.


Dark and Under is now available on the Microgamer!


IMO Purple is the official colour for D&U


I realised we hadn’t added anything since the file reshuffle and we had 8 commits pending, so me and @filmote (yes I did that just to annoy him) agreed to make a new release:

(By which I mean I prepared it without asking and then asked if it was alright :P.)

By the way, we weren’t the ones who ported it to Micro Gamer,
that was the work of Fabian Chouteau the guy who makes the Micro Gamer.

You can see the fork here.
(It’s a few commits behind.)


The .arduboy file doesn’t work for me. Hex file works tho.

Doesn’t work how?
Which program are you using to read/upload it?

I had a quick look and I think I might have found the problem.
I uploaded a new version which should work if I found the problem.


I‘m using the Arduboy Mate App (Android) for all uploads. As i said, the hex works correct. I‘m at the 2nd floor right now. Will test the arduboy file as soon as i‘m dead :sweat_smile:


Still not working for me. Arduboy screen stays black although the app says flashing was a success. Weird.

I tested with two different json validators and they said the info.json was fine, and both the hex files in the .arduboy are the same as the ones released bare.

No idea what’s going on there.
Could be a bug in Arduboy Mate.

There was a bug before I reuploaded though - a missing comma.
Presumably it was never found before because nobody bothers with the .arduboy files, or one of the other tools can read improperly formatted json or something.

Just out of curiosity i did try to upload the .arduboy file with team args uploader and found the following:

Maybe the android app doesn’t provide this decision?

1 Like

Thanks for taking the time to check.

If those upload correctly then I’m going to guess that Arduboy Mate isn’t behaving as it should, even with the issue fixed.

I’m guessing either most people have been either compiling their own or using the .hex instead of the .arduboy, since I’m 99% sure the comma issue has existed ever since devkit support was added and nobody noticed until now.

I just retroactively edited the ones on the release page to include it just in case someone wants to use an old version in .arduboy format.
(Though there’s no need to use the older versions.)

1 Like

I DID try the old .arduboy file with craits uploader, with no problems.
Some files and loaders seem not to like each other in general though.
If i upload the .hex from jetpac for example with team arg‘s uploader the arduboy isn’t found anymore until you restart your pc, with craits uploader it works fine…

1 Like

I would guess that the ones the old .arduboy files worked with either weren’t too strict about their json, or were just picking out the .hex files without reading the .json.


Is it possible to save in this game?

Not by default.

It’s possible to compile in saving as a feature but it eats up 900+ bytes of progmem. (I.e. the functionality is there in the code, but it has to be conditionally enabled.)

For the regular campaign, to allow saving we’d have to remove at least one of the levels and split the levels across multiple hexes so people would have to re-flash their Arduboy to reach the next level.

1 Like

Thank you! I’ll do the long run then :smirk:

1 Like