Dark&Under - A Dungeon Crawler


(Scott) #241

(Dylan ) #242

Yes i can double click on the D&U file and it will open up on the IDE
But nothing happened when I extracted the D&N and opened it on to the IDE, the error
Arduino: 1.8.7 (Windows 10), Board: “Arduino Leonardo”

Dark-And-Under:2:19: error: Enums.h: No such file or directory

compilation terminated.

exit status 1
Enums.h: No such file or directory

This report would have more information with
“Show verbose output during compilation”
option enabled in File -> Preferences.

showed up


(Pharap) #243

See my comment above:


(Dylan ) #244

Hold on i will try that right know


(Dylan ) #245


D&N master highlighted is the one i opened up then tried the thing you told me to do.
Nothing happened besides the same error
Thats why im posting this pic to see if im doing anything wrong.


(Simon) #246

The highlighted file is still the .zip file.

Follow @pharap’s advice …

  • Extract the contents of the .zip file into a proper directory.
  • Then make sure that the folder the file Dark-And-Under.ino is called Dark-And-Under.
  • Make sure that all of the other files are in the correct locations.
    • eg Enums.h is in the same directory as Dark-And-Under.ino.
    • eg there is a src subdirectory in this same folder and that all of the other files are there.
  • Then open the .ino file in the Arduino IDE.
  • Then upload to the Arduboy.
  • Then play the game.