Dark&Under - A Dungeon Crawler


(cyril guichard) #81

out of curiosity, aside @Keyboard_Camper and I, anybody beat the game yet?


(Scott R) #82

Looking forward to seeing some end of game screenshots.


(Simon) #83

With all of the suggestions so far, we have been able to save a lot of memory and incorporate some of the changes people are asking for, including moving backwards instead of about-facing when pressing the down button and a directional indicator on the player within the map.

Look for the upgrade V1.1.0 coming soon.

Thanks to: @Mr.Blinky, @dxb and anyone else who commented.


(Pharap) #84

v2.0.0 has been released.

Backwards compatibility is broken due to the space saving changes.
As per @dxb’s suggested edit the game now relies upon a modified local version of Arduboy2.

The down button moves the player backwards and the map icon has been changed to option D to reflect the player’s rotation.


(Charlie) #85

I dont know much about arduino but I haven’t had a hard time uploading games to the arduboy I keep getting this error when trying to upload this game.

**C:\Users\charl\Downloads\Dark-And-Under-2.0.0\Dark-And-Under-2.0.0\Dark-And-Under\Dark-And-Under.ino:1:35: fatal error: src/utils/Arduboy2Ext.h: No such file or directory

#include “src/utils/Arduboy2Ext.h”

                               ^

compilation terminated.

exit status 1
Error compiling for board Arduboy.
**
Also I tried to upload through .arduboy and that didn’t seem to work for me either, I made sure other games worked and they did so I dont know what I’m doing wrong.


(Simon) #86

I have just pulled down the code from GitHub and compiled and it seems to run fine. I can also see the Arduboy2Ext.h / .cpp file in the src/utils/ subdirectory within GitHub.

The path in your error message looks interesting and I am not sure why you have ‘Dark-And-Under-2.0.0’ repeated a number of times. Have you downloaded the .zip file and extracted the files to a proper folder?

Can you see the Arduboy2Ext.h file in the extracted files? Is it in a subdirectory /src/utils/ relative to the main .ino file?


(Charlie) #87

Everything you said I can see I think my main problem is I don’t know which .ino file the game is.


(Simon) #88

Dark-And-Under.ino is the main file.

So did you extract it out to a directory? Is it C:\Users\charl\Downloads\Dark-And-Under-2.0.0\Dark-And-Under-2.0.0\Dark-And-Under\ on purpose?


(Charlie) #89

No the first two was when I extracted it but the third was because Dark-And-Under.ino says it need to be inside a sketch folder named “Dark-And-Under”


(Simon) #90

What version of the Arduino IDE are you using?


(Charlie) #91

It says im using 1.8.3


(Simon) #92

Hang on … the main ino file got moved. is the src directory under the final ‘Dark-And-Under’ directory?


(Charlie) #93


(Simon) #94

The title bar says ‘Dark-And_under-2.0.0’ whereas your error says

**C:\Users\charl\Downloads\Dark-And-Under-2.0.0\Dark-And-Under-2.0.0\Dark-And-Under\Dark-And-Under.ino:1:35: fatal error: src/utils/Arduboy2Ext.h: No such file or directory

What happened to the \Dark-And-Under\ directory? Have you changed things since compiling the code originally?

Anyhow, why don’t you rename the directory that you have shown in the screen shot to ‘Dark-And-Under’. Close the IDE and open the IDE again by right-clicking on the ‘Dark-And-Under.ino’ file and selecting ‘Open with Arduino’.

Version 1.8.3 should be fine however I was using the latest, Version 1.8.4.


(Charlie) #95

Awesome got it to upload thanks for the help! :smiley:


(Simon) #96

Good stuff. What was the issue?


(Charlie) #97

I don’t really know I did what you said and renamed the file and also updated my IDE to 1.8.5


(Simon) #98

Pretty sure it wasn’t the IDE version. Anyhow, enjoy the game.


(Charlie) #99

Yeah thanks again for helping me out! :smiley:


(Pharap) #100

For future reference:

The problem here is that the Arduino IDE requires the parent directory to have the same name as the main .ino file, but when you get a copy of source code from github the parent directory will always be suffixed with the branch or version you took it from (in this case -2.0.0).

To try to rectify this the Arduino IDE asks to move the .ino file into a new folder, but doing so breaks the paths when there’s more than one file, which is why the compiler couldn’t find that file.

If you take a game from github in future, make sure to rename the parent folder after unzipping so it matches the name of the main into. (In this case, renaming the folder Dark-And-Under-2.0.0 to Dark-And-Under so it matches Dark-And-Under.ino.)

This is why some people decide to put the game files into their own folder, like I did with Easter Panic and like @Dreamer2345 did with Rogue Boy.

So now you know for the next time you get some source code from github.