Dark&Under - A Dungeon Crawler


(Scott R) #141

IMO Purple is the official colour for D&U


(Pharap) #142

I realised we hadn’t added anything since the file reshuffle and we had 8 commits pending, so me and @filmote (yes I did that just to annoy him) agreed to make a new release:

(By which I mean I prepared it without asking and then asked if it was alright :P.)


By the way, we weren’t the ones who ported it to Micro Gamer,
that was the work of Fabian Chouteau the guy who makes the Micro Gamer.

You can see the fork here.
(It’s a few commits behind.)


#143

The .arduboy file doesn’t work for me. Hex file works tho.


(Pharap) #144

Doesn’t work how?
Which program are you using to read/upload it?


I had a quick look and I think I might have found the problem.
I uploaded a new version which should work if I found the problem.


#145

I‘m using the Arduboy Mate App (Android) for all uploads. As i said, the hex works correct. I‘m at the 2nd floor right now. Will test the arduboy file as soon as i‘m dead :sweat_smile:


#146

Still not working for me. Arduboy screen stays black although the app says flashing was a success. Weird.


(Pharap) #147

I tested with two different json validators and they said the info.json was fine, and both the hex files in the .arduboy are the same as the ones released bare.

No idea what’s going on there.
Could be a bug in Arduboy Mate.

There was a bug before I reuploaded though - a missing comma.
Presumably it was never found before because nobody bothers with the .arduboy files, or one of the other tools can read improperly formatted json or something.


(Nicole Birgel) #148

Just out of curiosity i did try to upload the .arduboy file with team args uploader and found the following:


Maybe the android app doesn’t provide this decision?


(Pharap) #149

Thanks for taking the time to check.

If those upload correctly then I’m going to guess that Arduboy Mate isn’t behaving as it should, even with the issue fixed.


I’m guessing either most people have been either compiling their own or using the .hex instead of the .arduboy, since I’m 99% sure the comma issue has existed ever since devkit support was added and nobody noticed until now.

I just retroactively edited the ones on the release page to include it just in case someone wants to use an old version in .arduboy format.
(Though there’s no need to use the older versions.)


(Nicole Birgel) #150

I DID try the old .arduboy file with craits uploader, with no problems.
Some files and loaders seem not to like each other in general though.
If i upload the .hex from jetpac for example with team arg‘s uploader the arduboy isn’t found anymore until you restart your pc, with craits uploader it works fine…


(Pharap) #151

I would guess that the ones the old .arduboy files worked with either weren’t too strict about their json, or were just picking out the .hex files without reading the .json.


(Jul) #152

Is it possible to save in this game?


(Pharap) #153

Not by default.

It’s possible to compile in saving as a feature but it eats up 900+ bytes of progmem. (I.e. the functionality is there in the code, but it has to be conditionally enabled.)

For the regular campaign, to allow saving we’d have to remove at least one of the levels and split the levels across multiple hexes so people would have to re-flash their Arduboy to reach the next level.


(Jul) #154

Thank you! I’ll do the long run then :smirk:


(Scott R) #155

Alternatively you can flash your bootloader with @Mr.Blinky’s custom bootloader and gain enough space to have all the features enabled plus include audio.


(Pharap) #156

The code would have to be modified to accomodate that, but it could indeed be done.


@Jul

Although it might seem a tad harsh to not have saving on the main campaign, remember where D&U takes its origins from. It’s essentially a pseudo-3D roguelike, and roguelikes are known for their permadeaths.

Also remember, there’s no time limit - it’s all about strategy and tactics. Making note of the map with a pencil and paper (like they did in ye olden days) isn’t cheating - it’s being resourceful.


(Scott R) #157

It certainly can I added sound effects title audio and enabled everything. I found that after awhile the pitter patter of tiny footsteps drove me mad and gave up on it :joy: realising the extra space is best used for more levels and monsters and as usual far too many distractions to complete anything.


#158

apart from using my custom bootloader for another 1K extra space. You can also use my homemade board package to save more or less another 250 bytes using the included Arduboy optimized core


(Pharap) #159

We’re already using a custom version of the Arduboy2 library so we’d have to check for overlap.


(Scott) #160

One other option is to eliminate the USB stack to allow saving. You would have to warn people about the extra inconvenience of needing to manually reset to upload a new sketch, and it would be good to add a menu to facilitate this.

You could have #define to do this. Without the define, the sketch would compile without the ability to save. With the define, you could save but there would be no USB code to handle automatic reset for a new upload.