Defective Arduboy? [Solved]

I posted this on Adafruit’s forums and they suggested I ask here, so here goes:

I just received an Arduboy from Adafruit. It powers up and plays the default game it shipped with quite nicely. But when trying to load new software onto it, it will not show up.

I’ve tried two different computers (linux and win10), and two different USB cables (the one it shipped with, and another one I had for my Android device). I’ve put the latest version of the Arduino IDE software on both computers, added the necessary account permissions to myself for accessing serial devices, followed the FAQ from the Arduboy website, but nothing shows up when plugging the Arduboy in. In the Arduino software, with Arduino Leonardo selected, the “port” menu remains grayed out. On the linux machine, there is no dmesg output when plugging the Arduboy in, which tells me the Arduboy itself is probably defective. I do get dmesg output when plugging the Android in. The cables both seem to work fine when plugging in the Android device I have. Of the LEDs on the Arduboy, only the red light lights up when the unit is plugged in. The green and yellow(?) LEDs never light up.

For comparison, I have an Arduino Nano as well, which shows up fine on both machines (albeit with a different USB connector).

If there’s anything else to try, or any other information I should post, please let me know, otherwise I think I’ve got a bad unit, stuck playing Sirene and nothing else :frowning:

At the risk of asking the obvious; Is your Arduboy powered ON when you connect it via USB? (It should be.)

4 Likes

Are you using the stock cable or another one? Also, is the red light on when you plug it in (by the micro USB port)? If it’s on, is it on bright or dim?

2 Likes

Your micro USB connector is not plugged in all the way. Push it in firmly. The white plastic will be flush against the bottom of the case.

Negative on the cable, it was plugged in all the way, and was the stock cable. But sometimes the obvious answer is the correct one. Cheers, mate. It does help if you turn it on. Mea derpa.

5 Likes

Omg :rofl:. You didn’t turn it on? :rofl::rofl:

3 Likes

Now, now… be nice.

Most Arduino boards don’t have a power switch and will be powered up when USB power is applied. Plus, the red “charging” LED comes on when the USB is plugged in (unless the battery is fully charged), making the Arduboy appear to be powered up even when it’s switched off.

4 Likes

I didn’t mean to be a jerk. I am laughing because I did the same thing my first go around with the Arduboy :rofl:

3 Likes

The heck?


That was lucky. If one of the legs broke I might never be able to see it running again. The PCB was somehow unscathed, too. It just seems like all of the solder joints came loose. How come?

Possibly a bad solder joint.

Did this happen while you had the case on or did you remove your Arduboy’s case for something?