Develop for Arduboy on a Pocket CHIP

I’ve just received my Pocket CHIP mobile linux computer,
Wondering if anyone knows of a way I can develop for an Arduboy on the Pocket CHIP.
And maybe even deploy from the Pocket CHIP directly on to the Arduboy.
So I can do all development and testing on the go, without a laptop.


1 Like

Might be possible, though you woudn’t use Arduino IDE… not sure if there’s an XWindow manager on there or not…

The USB port looks like it could work…

I think with a combination of “bring your own editor” + Makefile

you can use ARDUBOY with as gamepad(leonardo can be a keyboard) with this. (works on FCEUX & PICO8)

and if you want arduino ide on POCKET CHIP

Yes you can! It would be a matter of mapping functions across API’s. Think of it like what you do when translating from one language to a next, the meaning will be the same but the words you use different.

Do you have both a Pocket Chip and an Arduboy?

Not quite what I meant ekem.
I don’t want the programs I write to run on both platforms.
I want to use the Pocket CHIP as a development machine to make Arduboy games.

And yes, my Pocket CHIP arrived today, and the Arduboy arrived a few weeks back.

Ah ok, interesting concept. Are you imagining writing values and variables to a program running on the Arduboy? Or are you imaging writing source code in the Pocket Chip? Excuse my ignorance, I haven’t had the pleasure of trying out a Pocket Chip yet.

It might help you can sort of outline how a session in this programming “environment” might go. :smiley:

It’s a bad habit of mine (speaking for other people), but if I’m reading this correctly, then yes, @quangdx is looking to write C++ code on his Pocket CHIP to run on the Arduboy.

The Pocket CHIP runs a variant of Debian Linux, so if there is a development suite available, then one should be install-able. You could try to see if there is an Arduino development system available for the Raspberry Pi, as that uses a very similar Linux OS and is somewhat cross compatible.

My Pocket CHIP arrived at home today, sadly I’m interstate for another 48 hours, so I can’t play with it.

Edit: Here are two links for the Raspberry Pi that might help with the Pocket CHIP. Follow the install instructions and see how you get on.

1 Like

Looks like there’s been an advancement


Wow! That’s amazing! I might have to get a CHIP, now… :open_mouth: I just wish they had nicer enclosures.

community is working on stuff… nice stuff.

1 Like

WOW!! I like that! I am getting my 3D printer in soon, so I’d definitely be up for making a case, but the modular idea is nice. I hate to derail the conversation away from IDE, but if the Pocket Chip can do Arduboy development, along with having a nice enclosure, I might as well have to go ahead and get one!

1 Like

Still waiting for a video of someone programming the Arduboy with a pocket chip! We have them in the same office in china but never got around to doing it ourselves!


I’ve been trying to install a newer arm version of arduino on the chip… I got the older one on but I don’t like the way it looks on the screen, the chip blog photo is nicer.

I’ll make a video programming an arduboy if I get this working the way I want.

With that said if anyone else gets a newer version of arduino working please give us some pointers on where to put the file or how to “install” it.

1 Like

Follow this:

It worked for me, and I’ve got the new IDE installed.

Edit: I’ve not been able to actually upload a sketch. I’ve changed the board type and the USB/Serial port to the correct one, but, no go. And unfortunately I can’t install any libraries, the screen goes black. So that may well be the issue.

And sadly you can’t see the bottom of the IDE so no compile errors etc show up.

Edit 2: I got it working.

I installed Iceweasel (web browser based on Firefox), used that to download both the Arduino IDE and the Arduboy library, installed the Arduboy library from the zip I downloaded and uploaded the sketch, and it works.

That’s pretty cool, I gotta admit.


Lol beat me to it. I’m currently trying to remove the first one and get all the terminal code right to install the newer one.

Oh no! Worse than not being able to see the bottom, you can’t see the last few lines of code!?!?:scream: Lol had to blindly keep hitting enter;)

I’ve given up for now on actually installing this. Just extracted the folder, navigate to it and open ./arduino pretty cool

Yeah, I noticed that too ! It’s a bit crazy. Hopefully someone will figure out a way to make it display properly. I have a feeling that the main window will be too squashed if the debug window is available.

I didn’t actually get it to display on the main window with an icon. I just run it via the shell as well. I did run the install script first though, and like you run it via ./arduino.

The lib was the biggest pain in the arse, and has to be installed manually via the IDE.

Well I got some progress on the display of the screen…


Modified that. Changed full screen to true, window height default to 450 -still working on this one, I don’t need the debug tool at the bottom but would like to see all the code when I scroll.

Anyway this is still just me experimenting. I did set it all to the screen resolution of 480x272, bad idea, it looked no different than the older version. (Which I also was changing preference file to).

I hope this helps alittle.


Well I can’t get things working cause of some text library issues… But here is a video of a chip programming an arduboy;) (examples in library works)

Now it works. I had the older library for the arduboy zip. I had to remove that one and install the latest. Now it works just like on my other computers.