Wouldn't it be better to have the "device" field as a field in each "hexes" object, along with "title" and "hex"?
As it is, I have to create a separate .arduboy file for a production Arduboy and a Devkit. This means that in addition to creating new .hex files, I have to identically change at least the "date" and "verson" in two different files when I make a new release. If I decide to add or change screenshots or any other field, that's more redundant changes I have to make.
If I could include the .hex files for both a production Arduboy and a DevKit in the same file, it would mean less work and reduce the possibility of mismatch errors.