[Discuss] Arduboy Quick Start Guide

I’m pretty sure I’m using the wrong cable, because I only use this one to charge my phone. Is the included cable the only one that will work? If not, where can I get a working one?

Any other Micro-usb cable will work, so long that it has a data connection. If it’s one you use to charge your phone, if you plug your phone into the PC, are you able to browse the files on the phone? (Assuming it’s Android) If doing this and nothing shows up on your computer for your phone either, it’s a charge only cable…

You might ask to borrow your friends cable he used. Bug him for some help, he figured it out before he sold it to you by all means. :slight_smile:

1 Like

I called my friend and he said he’d get me the cable tommorow. I’ll message you back if i have any more problems. Thanks!

2 Likes

So I got the cable, but I have a question. Since Squario is already on the Arduboy, do I need to manually remove it in order to put another game on there, or is that done automatically?

Just perform the upload, the game will be overwritten automatically!

Ok, thanks!

Ok, yep, still not working. When I plug this cable in, a green light comes on, but that’s it. “Port” is still greyed out, so I don’t really know what to do now

When you plug it in, do you hear a USB connected sound? Do you know how to get into device manager? It should show up in com ports:

image

Of you don’t see it in com port, check to see if there are any yellow exclamation marks on anything.

No exclamation points, no USB noise. There’s also no ports section in my Device Manager

Can you write to me at arduboy.com/contact please?

I would be curious to know how your friend got this game on there, what method he used and if it failed after the upload and that’s why he sold it. It can be fixed, hopefully by you but if you need to send it for repairs I can also help with that.

He said he used an instruction video because this guide didn’t work for him. I’ll have a look at the video and if that doesn’t work, I’ll contact you through that link

Ok, that’s weird would be interested to know what video that is!

Ok, so I plugged the Arduboy in again and I got the noise. No yellow light but it appeared in device manager. However, I got this error message when uploading

Arduino: 1.8.9 (Windows Store 1.8.21.0) (Windows 10), Board: “Arduino Leonardo”

Sketch uses 14954 bytes (52%) of program storage space. Maximum is 28672 bytes.
Global variables use 1421 bytes (55%) of dynamic memory, leaving 1139 bytes for local variables. Maximum is 2560 bytes.
avrdude: ser_open(): can’t set com-state for “\.\COM5”
An error occurred while uploading the sketch

Send me a note on the contact page, you need some more help than what the forum can provide :slight_smile:

So I did a little more tinkering and actually managed to get ArduBreakout on it! I’m not sure what I did wrong last time, but it’s working now. If I cant get it to do it again, I’ll send you a message on the contact page. :slightly_smiling_face:

I’ll count it as a success!

Maybe your USB Port is filled with lint? Try to clean out the connectors on both the Arduboy and your PC.

:slight_smile:

So, I’ve managed to upload ArduBreakout, Music Demo, and Hello World, but every upload takes about 6 tries, fidgeting with the cable. Other than that, everything seems to be in order. Thanks so much for all your help, and I’ll contact you if I have any more problems.

It shouldn’t do.
That implies there’s still something not right.

With a bit of searching I found this:

Perhaps this will solve your problem properly?

Basically the idea is to uninstall the IDE and the device driver(s) and then reinstall them.

This sounds like there is a problem with either the cable, or the usb port. If you’ve gone and tried to clean out the usb port of the Arduboy (can of air is best, blowing on it is OK).

Hello all, newbie here so sorry if this post is unnecessary.

Following Crait’s Make Your Own Arduboy Game: Part 1 guide and MLXXXp’s Quick Start Guide I ran into an issue when trying to compile and upload.

cc1.exe: error: -fno-fat-lto-objects are supported only with linker plugin

Searching on the forum I came across this post from early last year. My situation was different since I was using the stock Arduino IDE, not VS Code, but the fix of including the json link to the Arduboy homemade package in the Additional boards manger URLs and adding/using the Arduboy homemade package board instead of the standard Arduboy board fixed my issue. With that I was able to upload the example sketches successfully.

While searching the forums extra I also came across this other post from when the Arduino 2.0 IDE was not supporting Arduboy. To be honest most of that thread is over my head, but the latest Arduino IDE advertised on their site does not appear to be beta version on first glance. I’m not sure if this is relevant or not to the issue, but including it here to be thorough.

I’m wondering if other newbies are also running into this issue and if the Quick Start Guide should maybe be amended with updated guidance about the board selection or IDE versions. I’ve been setting things up on a fairly new/clean laptop with fresh installs of things, so was surprised to run into this issue. (I’m running Windows 11, version 2.0.3 of the Arduino IDE with CLI Version 0.29.0, and an Arduboy that was purchased in late 2017.)