[Discuss] Arduboy Quick Start Guide

I have next to no experience with programming - the only thing that comes close is MaxScript for 3D Studio Max which I use occasionally for my job. I hope to be able to help and learn, but certainly have no idea where to start. I did discover how to fix the Game of Life game that was posted, although I have no clue how to work with Github.

1 Like

You will hear people say “Github and Git are actually pretty simple”. I thought that was a complete lie when started learning Git. I figured that they were just being elitist jerks in saying that : P.

So, Git offers a lot commands, and that is terribly confusing when just starting. But, it did turn out that, to do the basics with Git and work on projects, it really does just take a few commands to use Git.

The basic commands are: clone, add, commit, pull and push. But, you do have to use all of them more than 3 or 4 times to get how they all work.

A pretty good guide covering each topic can be found here, https://guides.github.com/activities/hello-world/.

1 Like

I think I just figured it out on the website anyway:

2 Likes

Plugging my Arduboy into a Macbook Pro results in the Mac thinking that I’ve plugged in a new keyboard and my trackpad turning off. I have to use my bluetooth mouse while this device is connected to my USB

2 Likes

Thanks @owendismuke, I opened an issue for you for this problem.

http://community.arduboy.com/t/usb-conflict-on-macbok-pro/743/1

It’s probably going to get seen by more people in it’s own topic and resolved quicker.

I am getting really discouraged. I have been trying to get a game on my arduboy for hours now and I have no idea what I am doing wrong. I have followed the directions exactly several times starting over from scratch at least 5 different times.

I finally got something uploaded to my arduboy…a blank sketch so now it literally does nothing. Can someone please help me because right now, I just have a nice paperweight.

Sure!

Would you mind creating a new thread in the development section and posting your source? The best way to do so inside the forum is to put ``` above and below your source.
Like this,

```
int main(int argc, char** argv) {
  ...
}
```

Or open a github, or put in a zip. Let us look at the source and it shouldn’t be a problem at all to get you up and running.

What game did you try to upload ? Possibly you uploaded a game meant for the DEV kit.

1 Like

We should be encouraging people to upload one of the sketches from the library examples folder, as a first step, instead of asking what sketch they’re trying to load. If the library is properly installed, the user just has to do:
File -> Examples -> Arduboy -> <sketch_name>
to open a sketch ready for uploading.

Once that is successful, we can deal with helping with problems installing and uploading other sketches.

2 Likes

Yeah, I got a little ahead of the problem there, thanks MLXXXp!

If anyone following the thread does have an issue getting going, don’t hesitate to post a new thread in the development section.

Perhaps the kickstarter guide posts needs an update about games/sketches and info about compatibility with old sketches.

Hey Guys and Gals, I’m trying to upload one of the Arduboy examples, unsuccessfully. I am new to linux and to Arduino, but I figured this would be a nice learning experience for myself. I have successfully installed Arduino, and I (thought I) have successfully installed the Arduboy library. But, I keep getting an error which is leads me to believe that the library is not installed correctly:

ArduBreakout.ino:12:21: fatal error: Arduboy.h: No such file or directory
compilation terminated.

If I go to Sketch --> Import Library, I see Arduboy at the bottom.

It must be noted:
I have selected Arduino Leonardo, and I am running Arduino as root. Any help is much appreciated!

1 Like

Don’t run the IDE as root.

Well, don’t run anything as root. Only system binaries, like apt-get should be executed as root, and system services can be run as root, but everything else should be run as a user with limited authority.

The problem you are having is that root is a user as well. And when you run the program as root, it looks in root's home folder for the libraries, /root. And of course, you installed the Arduboy library to your user’s home folder (most likely) /home/username/. Most programs user environment variables to control what happens, and when you run things as different users, the environment, and the variables going along with it, change.

First of all, thank you for your quick reply. I start Arduino under a regular user, ensured the Arduboy library was installed - It is listed in the ‘Import Library’ menu. I opened up the ArduBreakout example and clicked upload. I seem to get the same error:

ArduBreakout.ino:12:21: fatal error: Arduboy.h: No such file or directory
compilation terminated.

Any other ideas?

Kind of a strange thing, maybe someone with more linux experience can jump in but I’ve never used the library import tool. So I think the first step would be to confirm that the library ended up in the right location.

As @ekem indicates the user you are logged in as will effect where things are installed, and theoretically you should be logged in as the same user as you where when you installed it.

If you are actually logged in as root this may cause this problem perhaps? But if you are just running arduino with sudo then it shouldn’t necessarily exhibit this issue. The weird thing is, that you are able to navigate to the example code through the drop down menu so clearly the library is there, but has something to do with how its compiled.

Hey Kevin, I wasn’t logged in as root. I was running sudo Arduino, as you mentioned. Yes, the example code was in my drop down as well. I’ll restart the computer and give it another go. I’ll try some other things as well.

Restarted the computer, ran Arduino as a normal user, received the same error… hmmmm. It will be a piece of cake when I have a PC in my hands. Not sure why I can’t get it to work on this linux machine.

Hey P0ng,

Nice, you are on the right track. Watch o

So, log into your normal user.

Install the library to /home/username/Documents/Arduino/libraries/. To accomplish this, I would download a zip file from the Github account and install the library via the zip option in the Arduino IDE.

If you already have the folder /home/username/Documents/Arduino/libraries/Arduboy then I would check, is that you have the permissions set correctly.
type,

username@home ~/Documents/Arduino/libraries/ $ ls -al

I bet you find everything is owned by root. to fix this do,

username@home ~/Documents/Arduino/libraries/ $ chown -r username:username Arduboy/*

Now try compiling again. If a user doesn’t own a file or isn’t part of a group with access to read or write, it will tell the user a file doesn’t exist.

Also remember, if you install anything, you might have to log out and log back in in order to reload the environment variables.

Note running something as sudo will still run the process as root. The reason I mentioned applications in linux not running in root is not as a security warning, but to let you know that’s now how any of them are designed, so if you are running something as root, it will probably go way wrong.

Well, I got my Arduboy today and got everything installed just fine.
However after swapping a couple games, the device has seemingly “bricked”?

Whenever I try to compile-upload a new program, nothing happens, the green progress bar will complete, but it continues to say Uploading and nothing appears on the device.

I noticed there is a reset hole/pin next to the USB slot but don’t know how to use it properly as nothing seems to happen.

You probably ended up on a game that hasn’t been upgraded to the new library yet. Try using a game from the “Official” list. If those don’t work, please open up an issue : )

1 Like