Error compiling for board Arduino/Genuino Uno [Solved]

I recently got an Arduboy and tried to download Mystic Balloon it. but when i went to verify/upload it, this message appeared;
Arduino: 1.8.5 (Windows 10), Board: “Arduino/Genuino Uno”

Build options changed, rebuilding all
In file included from C:\Users\Brysonivitch\Documents\Arduino\ID-34-Mystic-Balloon-1.6.1\MYBL_AB\MYBL_AB.ino:17:0:

sketch\globals.h:15:22: fatal error: Arduboy2.h: No such file or directory

#include <Arduboy2.h>


compilation terminated.

exit status 1
Error compiling for board Arduino/Genuino Uno.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

1 Like

The Arduboy is based on the Arduino Lenoardo so you have to select that board type from the drop down menu.

I run into this error all the time when I install Arduino fresh and forget to switch the board type (or have been using other Arduino stuff).

Give that a try and let us know!


In addition to selecting the correct board type, please follow Step 2 in the Quick Start Guide to install the Arduboy related libraries. The error you’re getting is because you haven’t installed the Arduboy2 library.


Thanks for the help, unfortunately there seems to be a bigger problem than the wrong settings. I switched the board type from Arduino/Genuino Uno to Leanardo, but now i’m getting the same error only this time with Arduino Leonardo. As well i downloaded the Arduboy-2 master, but i am lost on what to do from there. As well i noticed that my Arduboy didnt seem to be making a data connection at all with my pc, the flashing yellow light would only a pear for about a second when i went to upload something. Does this mean it could be a problem with my hardware? I sure hope not…

You haven’t properly followed the instructions in Step 2 of the Quick Start Guide, as I requested above. You don’t download the Arduboy2 library. You install it using IDE’s Library Manager, as instructed in the guide.

I just now got the Arduboy2 library and included it into the program ‘blink’ and it seemed to upload but nothing happened to my Arduboy, its now just a blank black screen. one thing i noticed was that as it was uploading the disconnect sound played from my PC twice in a row as it was uploading.

The standard Arduino blink sketch won’t do anything on an Arduboy. The LED it uses isn’t connected.

Try uploading one of the Arduboy2 library’s example sketches, as Step 3 in the Quick Start Guide suggests, such as the Buttons sketch.

From the IDE menu bar select:
File > Examples > Arduboy2 > Buttons

Thanks, i was able to get the breakout example onto my Arduboy but i’m not sure on how i would be able to upload other games.

Thanks a lot, i was able to get Mystic Balloon onto my Arduboy.