Error while uploading


(Mathias Zillmann) #1

I have been playing around with Visual Studio, Sublime Text 3 and Arduino today, in order to see if I can get use a different interface and/or a virtual Arduboy, when I’m not having the cable close by.

However, now when I try to upload my code to the arduboy via Arduino, I get the below error. Does anybody know why? I tried different USB ports, uninstall Arduino, library and install everything again, but no results. Also reset button, didn’t show any difference.

Sketch uses 10040 bytes (35%) of program storage space. Maximum is 28672 bytes.
Global variables use 1246 bytes (48%) of dynamic memory, leaving 1314 bytes for local variables. Maximum is 2560 bytes.
processing.app.debug.RunnerException
	at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:160)
	at cc.arduino.UploaderUtils.upload(UploaderUtils.java:78)
	at processing.app.SketchController.upload(SketchController.java:709)
	at processing.app.SketchController.exportApplet(SketchController.java:682)
	at processing.app.Editor$DefaultExportHandler.run(Editor.java:2190)
	at java.lang.Thread.run(Thread.java:745)
Caused by: processing.app.SerialException: Error touching serial port 'COM10'.
	at processing.app.Serial.touchForCDCReset(Serial.java:87)
	at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:144)
	... 5 more
Caused by: jssc.SerialPortException: Port name - COM10; Method name - openPort(); Exception type - Port busy.
	at jssc.SerialPort.openPort(SerialPort.java:164)
	at processing.app.Serial.touchForCDCReset(Serial.java:81)
	... 6 more

(Mike McRoberts) #2

It looks like another app is trying to access the port at the same time. Make sure you have Sublime and Visual Studio closed when trying to upload from the Arduino IDE.


(Mathias Zillmann) #3

Thanks.
Is there a way to remove all traces from visual studio / sublime / Arduino and reinstall it?

I ask as I get the same error even after a fresh restart, with no software running beside Arduino.


(Mike McRoberts) #4

Are you also running the Processing app?

There seem to be mentions of that in your error code. if so, close it.

Use Task Manager (if using Windows) to ensure all the above apps are killed.