Errors when compiling a sketch [Solved]

Hy everyone! I wanted to download the game so I entered GitHub and downloaded the game, but when I tried to uploaded it send me error, with everything it says me the same, "No such file or directory. It even says that with the examples!

Did you follow Step 2 in the Quick Start Guide and installed all the recommended libraries?

yes, I installed all that they said.

I’ve moved this discussion to a new topic. It’s not specific to the Hopper game since you’ve said the same thing happens with other sketches.


Have you been able to get any sketch compiled and uploaded?

In the IDE select:
File > Examples > Arduboy > HelloWorld
Try to compile it by clicking on the Verify check mark icon verify

What are the results?

Yes, when I first downloaded it

This looks like you don’t have the Arduboy library installed.
(Note: Arduboy and Arduboy2 are different libraries.)

Does it work if you change //#define USE_ARDUBOY2_LIB to #define USE_ARDUBOY2_LIB?
(I.e. remove the two slashes.)

That’s one of the reasons I asked to try loading and compiling the Arduboy library HelloWorld example. It would tell us if the Arduboy library was indeed installed.

What examples give you errors?

for now only the arduboy 2 RGBled example worked.

Now I think I see where´s the error, when I had installed the library it didn´t actually installed it, at first it looks good but when I pass the mous again on the block it shows again the option of installing it, over and over again.

If you get it installed correctly, it should say:

Arduboy
by Chris J. Martinez, Kevin Bates, Josh Goebel, Scott Allen, Ross O. Shoger Version 1.1.1 INSTALLED

and like I said, you should be able to load the HelloWorld example
File > Examples > Arduboy > HelloWorld

No, it doesn´t work either.

What do you mean by "it doesn’t work? You can’t load it or you get errors when you try to compile it?

When you look at the Arduboy library in the library manager, does it show

Version 1.1.1 INSTALLED

as I indicated above?

no, it doesn´t show like that it looks like when you haven´t installed the library, also, the error is when compiling.

At this point it may be best to uninstall the entire Arduino IDE, then reinstall it and add all the Arduboy libraries, making sure that each one installs properly.

I don’t think your sketchbook will be erased but if you’ve installed many sketches you want to keep, you could back it up, just in case.

ok. I´ll try it

It worked!! horray

2 Likes

Thank´s a lot for the help

1 Like