Failed Battery Charger [Solved]

Pretty much what the title says. It worked when i first got it now it wont program and reset doesnt work.

What kind of reset are you talking about? The reset button or turning it on and off?

Here’s the steps that I would use to test things:

  1. Try Flashlight mode.
  2. Try the reset button method

Here’s some other questions that may help if neither of those work:

  1. What game were you flashing over to the Arduboy?
  2. Are you using the same cable as before? Only data cables are able to flash the Arduboy.
  3. What kind of computer are you using?
  4. Does your computer recognize that the Arduboy is connected?
  5. What program are you using to flash the Arduboy? Arduino IDE? AVRDude? Arduboy Manager? Etc…
  6. Does your Arduboy charge when plugged in?

The battery doesnt charge so the flashlight method wont work. I tried pushing the recessed reset button when it is plugged into a PC but that doesnt work either.

Have you checked the battery connections?

You mean have i taken it apart? No, its new. I just got it yesterday.

Fortunately, taking it apart is as simple as unscrewing a few screws on the back. If it’s not holding a charge, I think it’s the battery issue.

The terminals look ok. Soldering isnt great, but is ok. The battery has a charge. 3.7V

So, the battery is probably not the problem… Mind answering those 6 questions above?

It kind of sounds like the battery charging circuit is toast. If the battery is at 3.7 that is below the low voltage threshold of the battery protection circuit.

If you can please send us a note at we can work with you to get it fixed.

Pictures would also be helpful! :open_mouth: :frowning:

I was loading the game that comes in it when it died. I’m using a pc. I’m using the arguing ide. The pc does not recognize that it’s connected. I don’t think it’s charging. I’m using the cable it came with.

It’s likley beyond basic repair, please do contact us using the form and we will help you get it fixed.

1 Like

OK. If it costs money to fix I’m going to run it over with my Jeep instead. I’ve had it less than a day.You guys n3ed some quality control on this product. I see a lot of issues in here on this. I used to design kits at Ramsey. I know how it goes sometimes but seriously. It won’t reset after less than a day.

Arduboys are designed to be a bit durable. With the thousands shipped, I’m very surprised that there are so few physical defects being reported. I’m not affiliated with their company at all, but I would say that they seem to be doing their best in keeping defects to a minimum, which I think they’ve been doing a good job at.

No it’s not. The battery has a nominal voltage of 3.6V. A close to fully charged battery would be at 3.7V

Did it work OK when you got it?
Have you ever been able to load a new game into it?
Is the power switch on when you try to program it?
What does the red LED (the charge indicator) do when connected to USB? Never comes on? Always on? Comes on but then goes out after minutes or hours?

It worked briefly when I got it. The red led stays on while it’s plugged in. I’ve tried programming with the switch in both positions.

I’m offering to replace it free of charge and if you can please use the contact form at and let us know your order details we can try to help.

Also, if you do this, please film it, it might actually survive… (as long as you placed it flat)

Ok, fair enough but if it is charging it should be higher than that. If you can test it while its plugged in and it is not going above 3.6v then for sure it’s not charging.

In addition to @bateske’s suggestion of measuring the battery voltage while charging, you could try this:

At the lower right corner of the back of the circuit board are pads marked GND and VCC. With the unit powered ON, if you measure the voltage between these two pads it should be almost the same as the battery voltage. If not, then possibly the power switch is bad or has a broken connection.

Are you sure?
I’m too concerned to put it in my purse, because I don’t want to sit on it (and I am pretty light). :smiley:

I got the replacement unit from China and its working! I now have a working Arduboy and a hosed Arduboy.