Failing to compile. No such file or directory? [Solved]

Please help me figure out why I can’t compile my game.

https://github.com/JoeRagu/First-Game/blob/master/first-game.ino

I don’t get the bitmaps.h error but you can’t use ArduboyPlaytune and ArduboyTones in the same sketch. They both use the same interrupt, so you can only use one or the other.

If I remove the ArdudoyTones related code, the sketch compiles.

You should also remove the semicolons at the end of #endif in bitmaps.h and score.h

1 Like

Hmm… I removed the tones related code and the semicolon and I still get the error. Code is updated on github

The sketch now compiles fine, without errors or warnings, for me.

The error indicates the compiler can’t find the file bitmaps.h in the same directory as the first-game.ino file. Does bitmaps.h and score.h appear in the file tabs in the IDE?

I noticed that you have your sketch in a folder on the Desktop. You should put your sketches in your Arduino Sketchbook.

It was the capitalization mismatch between the INO and the directory name

1 Like

Still, you’re better off putting sketches in your Sketchbook.

1 Like

Changed that also. it’s now in my documents folder like in settings. Also the capitalization didn’t do anything I just realized after testing it again. it was moving it to my sketch folder that made it work

3 Likes