FX Mod Chip and Flash Chip Not Found

I tried installing the hardware-only FX chip, but both the Mod chip and the Flash chip were not found when I ran the activator. I have tried resoldering the VCC and GND ports (as instructed in the troubleshooting guide), to no avail.

A few things to note:

  • My Arduboy is quite old (it is actually a blue one from 2016) and, unlike new ones, has some rubber pads around the screw sockets in the lower left and upper right. The SDA and SCL connections, as a result, were quite difficult to solder in, but it appears that they look okay. This might still be an issue.
  • I ordered a second standard Arduboy (since it was on sale) and another FX chip which just arrived today, and I was able to install it and get the FX loader to fully function, showing that my soldering technique should have worked when I installed the chip in the original Arduboy.

Let me know if a picture or the diagnostic info would be helpful in troubleshooting this issue.

Thanks,
Jackson

Those pads were put on some models that the aluminum back cover didn’t fit quite tight enough. Or maybe it was the plastics fault, but those discs help prevent it from wobbling around too much.

You can move them to the opposite corners if that might help? Not sure.

Really, if all the connections are made, the software should detect it. I’d try to resolder all the connections. MISO and MOSI not being connected could also have this effect.

Sometimes you really gotta get in there and kinda “scratch” and “stir” the pool of solder because there is a microscopic layer of oxides on the surface of the pad or contact that is preventing a good bond. The flux is supposed to help burn this off but due to the nature of this joint, the pad you are trying to connect to being under it… I think unfortunately this kind of joint is a little bit prone to getting contaminated with solder.

Give it another shot, if you’re still having issues go ahead and send some pictures or update us on the progress.

If you’re really stuck you can always write into arduboy.com/contact

2 Likes

So, I was finally able get the Arduboy to detect the mod and flash chips. The first ones I resoldered were the MISO and MOSI connections, per your suggestion, and both of the chips worked after that. I ran into another issue where “Flashing bootloader failed!”, but I was able to fix that by resoldering the RST connection. It all works great now, so I can finally get back to making more programs for this thing.

Thanks again for your advice,
Jackson

5 Likes