FX Mod Kit Preprogrammed

Just installed my new FX mod kit pre programmed. Held the reset for 5 seconds. Game went to original game. No FX screen. Any suggestions? If this has already been addressed, my apologies and please direct me to the thread. Any help is appreciated.

If it doesn’t update the bootloader it means there are one or more bad connections. Push down the mod chip while reheating/resoldering the pads.

Just made some updates to the instructions, it has a troubleshooting section at the bottom:

  • FX activator uploads but cannot detect Mod chip or Flash chip: VCC & GND connections
  • Mod detected but not Flash chip: SDA connection
  • Flash chip detected but not Mod: SCL connection
  • Mod chip fails to verify: MISO, MOSI, CLK connections
  • Stuck in boot loop after attempting bootload: RST connection

As a test, if you don’t want to open your Arduboy straight away is to install the activator and see what it says about the mod chip that’s installed and see if it’s communicating correctly.

Ok, thanks. Ill try that.

Did that help you @ckorney? I got mine and have reflowed the solder about 3 times with no luck. I got the python app however it keeps saying that it can’t detect the Arduboy. Are there special drivers or anything that I have to do on a linux machine for the board to be detected? I would attach an image of the solder points but it won’t let me.

I used to use a Mac for Arduino stuff but had to stop since the macOS from last year Arduino boards aren’t supported and you have to install some drivers that I don’t fully trust.

@DarkLord What is the problem that you are experiencing?

You said you installed the mod chip, what is it doing … or not doing? When you attempt the bootload by holding the reset button down, what happens? Does it reset, or does it throw garbage on the screen?

Are you new to your Arduboy or have you used it previously, were you previously able to load games onto your Arduboy using Arudino or other software?

If you have been able to load games on your Arduboy before, you should be able to load the .ino sketch for the activator the same way. This will help tell you which connections may be the issue.

I’m also not sure what issue you are having with uploading images to the forum, I’m not sure what “it” is that is “not letting you”.

It is not really possible to help if you say general things like “its not working” or “it wont let me”. Please be specific in your descriptions of what happened, write out detailed error messages, steps you took, and what the result is.

It’s impossible for us to know how to help you if you cannot describe the situation to us like we were also there.

Sorry @bateske, I wrote this like the end users write tickets for software bugs lolz.

After installing the mod chip and doing the reset for 5 seconds the screen remains blank for a couple more seconds but then the last game that I have installed loads up.

I have had my arduboy for several years. The recent issues are with an update to macOS so the Arduino IDE doesn’t recognize the board, or any Arduino board for that matter. I got a cheap Lenovo and put linux on it hoping that I could get the Arduino IDE to recognize the board. However after trying to connect it since the Arduboy FX Mod Chip was stating that it couldn’t detect an Arduboy. I attempted to use the Arduino IDE but I’m having struggles with it also. I uninstalled and attempted to re-install the IDE and it is now failing to install (nothing to do with Arduboy)

Also sorry about the image not uploading when I attempt to add the image to this / last post. The editor said that it couldn’t upload because it couldn’t calculate the size of the image. I have exported the image and have attached it below.

So, the Arduboy still works, and the game runs fine, but you can’t get it to detect on the pc any more?

When you plug it in, do you get the green light to blink on the Arduboy?

It could be possible that maybe the connection wasn’t 100% when the first bootload was attempted, and partially corrupted the bootloader? But not likely, because it sounds like the game still boots fine and the chances of burning a bootloader that only kind of works is somewhat small.

I’m kind of wondering if we shouldn’t recommend the software upgrade method using the activator as it might catch communication errors before going for the bootload. @Mr.Blinky thoughts?

It could also potentially be a problem with a solder joint from the attiny to the flex pcb. These were all tested and programmed… ( I suppose there is a very small chance that it never got programmed, but I doubt this, it wouldn’t explain why you can’t connect to it).

If you can take a close look at the solder joints on the the ATtiny:
image

And make sure they all have nice shiny fillets on them.

Best thing to do probably is to try and solve or isolate the problem with the PC/Linux. Do you have any other Arduino boards? Do you have a friend or family you can use their PC to test it?

Theoretically any windows 10 pc can recognize the arduboy even without arduino being installed, they include the drivers with windows.

If you have another arduino it’s possible to bootload it manually.

And if all else fails you can send it to me and I can fix it but let’s see if you can sort it out first.

I finally got it going. Took about 5 times, holing down and desoldering but it works now. Sorry for not responding sooner, had to work this weekend. Thanks to everyone for their help.

@bateske I do in fact have other boards and I did plug in an Arduino Nano and the Arudino IDE detected it and was able to install the board. The port did show up in the IDE, the port is grayed out when I plug in the Arduino.

No green light when I plug in the Arduboy, the charge light does light up. If I reset the Arduboy while it’s plugged in the green and amber lights blink 2 times. Then the game title screen loads up. The only windows computer we have in our house is my wife’s work laptop (not admin can’t install apps) I could plug it in and see if the computer recognizes it. With the human malware that is going around we don’t see other family and what not to try not to spread the malware so I can’t use their windows machines.

Is there a schematic for the PCB? I wanted to try and get my multimeter to do some continuity (might be hard with how small the chips are though).

Also I have tried multiple cables, and am now using the one that I got with my Arduboy and that is also what I used for the nano board.

If the nano works and you want to try bootloading it you can follow the instructions here:

On the second half of that post, although the wiring is shown for the uno you can use the different pins on the nano.

Schematic is here:

Yeah I don’t know maybe something is wrong with the bootloader.

Did you buy a blank modchip or pre-programmed one?

Pressing 5 seconds with a blank modchip won’t do a thing. you need to program it using the Activator.

This is normal behaviour for Arduboy when you press reset. After releasing reset a normal arduboy will be in bootloader mode for 8 seconds and then starts up the game.

I think that’s unlikely. The process starts with a chip erase. So if the sketch still starts up the erase didn’t happen and when the erase fails it is very unlikely any programming
will happen too.

For preprogrammed modchips. I don’t recommend to use the flash mod chip option until bad connections are ruled out.

I recommend to use the activator sketches diagnostic info:

  • The Arduboy Details will give you a BootCRC. This CRC will tell you if your bootloader is unchanged or upgraded correctly or not.

  • Pressing right button will show the mod chip details. This will give you a firmware CRC and help tell if the modchip is unprogrammed, programmed or if there is a communication error due to bad connections.

But @DarkLord must solve his upload problem first before he can upload the activator sketch.

There was an older OSX update that broke Arduino Leonardo support (Arduboys stock bootloader) but was fixed in later updates.

Going back to the simplest Arduboy trouble shooting. Are you sure the USB cable is a data cable and not just a charger cable? Have you tried another one?

You could also try to make a bootable Windows 10 USB on you Linux machine and install windows on and try that.


Some CRCs for trouble shooting:

  • BootCRC for Arduboy with original Catarina bootloader: B0F1
  • BootCRC after bootloader update: D62C (Bootloader version 1.9)
  • unprogrammed mod chip firmware CRC: 87F0
  • Mod chip firmware CRC: 9096 (Activator version 1.1 - 1.5)

@bateske something to add to your troubleshooting guide.

Those are good to know but only useful for if you can upload code.

Should we make a separate app for troubleshooting, it can just spit out the state of the GPIO and give the crc of the various components?

@bateske @Mr.Blinky I was able to plug my Arduboy into a Windows machine and it was not recognized as a USB devise :cry: . The last game I uploaded was over a year ago and I did have troubles getting the Arduino IDE to upload it. It took several tries.

I will try and make a bootable Windows 10 stick and try it again. I will also try my MacBook again, I haven’t tried it on there for a while because I was having the issue and all the online posts said that Arduino boards stopped working with macOS so I went to the linux machine.

I wish that my 2 boys’s Arduboy’s were here so I could test with them, but they are at their mothers house. I did test multiple cables and the one that I am using an Arduino Nano was recognized in the Arduino IDE.

What game is on the Arduboy currently? That will probably help us.

If you tell us it’s Arduventure I’m gonna have a fit.

There is this guide:

Can you confirm the little envelop you got says that it is pre-programmed, and that I didn’t mail you the wrong thing? If it has the correct label, I also think it may be possible that unit didn’t actually get programmed, or failed and I shipped it by accident. The reset button should handle it, but if it’s not then that’s my guess.

I think the USB connection is totally different. I think you need to use one of the methods to re-program the Arduboy.

If you use Arduino to upload a sketch, you can start the upload, and once it says “attempting to upload” you can press the reset button and it will work no matter what. The timing is a little funny, but once you get a different sketch on there than a game without the USB, it will be able to be reprogrammed easier and the port will show up.

What was the game you’ve uploaded and is now on your Arduboy?

open device manager on the Windows PC and when you press reset shortly does a new COM port pop-up under ports briefly?


@bateske beat me to it

The game that I have on it currently is Arduventure, I will get a bootable thumb drive with windows and try that tonight. I’ll let ya know, thanks for the help.

@bateske you are going to have a fit it is in fact Arduventure, I checked and the envelope does say Pre-Programmed. I will attempt the reset dance. The problem I am having with the Arduino IDE is that there is no port to select when I have the Arduboy plugged in. It does provide a port when I plug in my Arduino Nano.

For Arduventure you have to go into the menu and select “upload”.

Depending on what version of the game you have, it will tell you to hold up or down.

Check this video:

While you are holding the button you should get the USB chime as the device continually resets in bootloader mode. Get a normal sketch, like hello world, or even a blank sketch and attempt the upload during one of these cycles.

It may take a few attempts to get the timing right, but guarantee this will work.

Once you have something else on the Arduboy, try to load the Activator sketch. This will help us figure out what’s up with the mod chip.

If you still cant manage to get it sorted write me at arduboy.com/contact and I’ll help you send it to me so I can repair it for you.

Any luck @DarkLord?