FX Mod Kit Preprogrammed

:cricket: :cricket:

Ahh thanks for this video. I will try this tonight.

lol sorry been busy with work deadlines. I will try the video you posted above. Thanks

@bateske i was able to get the hello world sketch, i tried the the activator but it has been stuck on this for about 30+ minutes

It should find the bootloader within a (few) seconds. Try closing the app and opening it again.

@mr.blinky is the .ino of the Activator available somewhere that it could be flashed using Arduino?

@DarkLord are you using this through a usb-c interface? or a hub?

download https://github.com/MrBlinky/Arduboy-FX-mod-chip then open the ino in the mod-chip-arduboy folder

@bateske no just regular USB port on my Lenovo, it looks like @Mr.Blinky posted a link to the github repo with the .ino file. i will give that a try, thank you both for helping on this

this is what arduino ide prints out when trying to upload the .ino file

Preformatted text avrdude: initialization failed, rc=-1
             Double check connections and try again, or use -F to override
             this check.

avrdude: butterfly_recv(): programmer is not responding
avrdude: error: programmer did not respond to command: leave prog mode
avrdude: butterfly_recv(): programmer is not responding
avrdude: error: programmer did not respond to command: exit bootloader

this screen shot has all of it, this linux distro isn’t copying all the error message.

What. Weren’t you just able to upload the hello world sketch?

You sure you got the right port and board selected?

Can you email me? I think at this point I’d like to fix it to figure out what’s going on. :grin:

Its great you redacted your name in the image but its there in beside your avatar, Curtis Ovard!

Stop hacking @filmote!

I could add anything else to the conversation … so I went off topic!

hahahaha that’s awesome

you betcha, you want me to just send an email to this http://arduboy.com/contact/ ?

the best part is that it doesn’t say curtisovard under that blur it says c… :wink:

More seriously, if you (or anyone else) ever needs to cover up your (or their) name in a screen shot, don’t use the spray can, use a rectangle of solid colour (e.g. black or white).

It might look like you’ve covered it up from a distance, but when you zoom in it’s just about legible and with the right filter it’s really easy to make it readable.

covard

This was done in GIMP by adding a layer of pure white set to use the ‘grain extract’ filter.
With more sophisticated techniques it could be cleared up further.

Covering the text with a rectangle of solid colour is the best way to actually remove the text properly because it effectively overwrites the colour data in the image file.

2 Likes

Yo @DarkLord fixed your Arduboy! It seems like maybe the source of the problem might have been a partially corrupted mod-chip?

Or maybe also something else on your system…?

It was strange, when I got it… it did have hello world on it, but the h was actually an ascii character so that shows signs of corruption somewhere. I wonder if that could have happened because of bad usb cable?

Do you by any chance have like an ancient version of Arduino installed or something? It might be worthwhile to go ahead and update all that stuff.

So here is what I was able to do to recover it:

  1. I had to re-flash it again with another sketch, but I had to use the reset button, the auto-reset over serial wasn’t working despite the port being detected.

  2. I actually went in and re-soldered all the connection and also this could have potentially been a cause of the problem… it seems like the soldering iron was at a too low temperature. When I put my iron on it, a lot of rosin still boiled off and the joint flowed much better.

  3. I still was not able to get the auto-reset program to work so I flashed the activator sketch, which uploaded on the first try now.

  4. The activator reported both the mod chip and flash chip ok, so I went ahead and reflashed the mod-chip just to make sure. Then I flashed the bootloader, then everything worked!

  5. Hooray!

I’ll send it back to you tomorrow. Glad I could figure it out for you, it for sure was something a bit weird!

3 Likes