Glove - A lighter, softer, cozier gauntlet!

Yeah I think it should be fine. I was using a friend’s computer and that’s what wasn’t working. the older version compiles fine on my laptop. But I have a question, do you need to install a driver for the pro micro? It seems to work on my laptop but not on others

I’m not sure what you mean by a driver. If you want to add the definitions so that you can select SparkFun Pro Micro as a board type, you can use the instructions here.

1 Like

It’s all good! I have it working now! Thanks for all the help you’ve given me!

1 Like

How do I get this working on my production Arduboy?
here’s the errors I get.

Arduino: 1.6.9 (Windows 10), Board: "Arduino Leonardo"

C:\Program Files (x86)\Arduino\arduino-builder -dump-prefs -logger=machine -hardware "C:\Program Files (x86)\Arduino\hardware" -tools "C:\Program Files (x86)\Arduino\tools-builder" -tools "C:\Program Files (x86)\Arduino\hardware\tools\avr" -built-in-libraries "C:\Program Files (x86)\Arduino\libraries" -libraries "C:\Users\rholliday\Documents\Arduino\Sketchbook\libraries" -fqbn=arduino:avr:leonardo -vid-pid=0X2341_0X8036 -ide-version=10609 -build-path "C:\Users\RHOLLI~1\AppData\Local\Temp\build9f3be1c6f55f3f7105b7e002aff3c277.tmp" -warnings=none -prefs=build.warn_data_percentage=75 -verbose "C:\Users\rholliday\Documents\Arduino\Sketchbook\glove\glove.ino"
C:\Program Files (x86)\Arduino\arduino-builder -compile -logger=machine -hardware "C:\Program Files (x86)\Arduino\hardware" -tools "C:\Program Files (x86)\Arduino\tools-builder" -tools "C:\Program Files (x86)\Arduino\hardware\tools\avr" -built-in-libraries "C:\Program Files (x86)\Arduino\libraries" -libraries "C:\Users\rholliday\Documents\Arduino\Sketchbook\libraries" -fqbn=arduino:avr:leonardo -vid-pid=0X2341_0X8036 -ide-version=10609 -build-path "C:\Users\RHOLLI~1\AppData\Local\Temp\build9f3be1c6f55f3f7105b7e002aff3c277.tmp" -warnings=none -prefs=build.warn_data_percentage=75 -verbose "C:\Users\rholliday\Documents\Arduino\Sketchbook\glove\glove.ino"
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -w -x c++ -E -CC -mmcu=atmega32u4 -DF_CPU=16000000L -DARDUINO=10609 -DARDUINO_AVR_LEONARDO -DARDUINO_ARCH_AVR  -DUSB_VID=0x2341 -DUSB_PID=0x8036 '-DUSB_MANUFACTURER="Unknown"' '-DUSB_PRODUCT="Arduino Leonardo"' "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\leonardo" "C:\Users\RHOLLI~1\AppData\Local\Temp\build9f3be1c6f55f3f7105b7e002aff3c277.tmp\sketch\glove.ino.cpp" -o "nul"
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -w -x c++ -E -CC -mmcu=atmega32u4 -DF_CPU=16000000L -DARDUINO=10609 -DARDUINO_AVR_LEONARDO -DARDUINO_ARCH_AVR  -DUSB_VID=0x2341 -DUSB_PID=0x8036 '-DUSB_MANUFACTURER="Unknown"' '-DUSB_PRODUCT="Arduino Leonardo"' "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\leonardo" "C:\Users\RHOLLI~1\AppData\Local\Temp\build9f3be1c6f55f3f7105b7e002aff3c277.tmp\sketch\glove.ino.cpp" -o "C:\Users\RHOLLI~1\AppData\Local\Temp\build9f3be1c6f55f3f7105b7e002aff3c277.tmp\preproc\ctags_target_for_gcc_minus_e.cpp"
In file included from C:\Users\rholliday\Documents\Arduino\Sketchbook\glove\glove.ino:1:0:

C:\Users\RHOLLI~1\AppData\Local\Temp\build9f3be1c6f55f3f7105b7e002aff3c277.tmp\sketch\globals.h:4:21: fatal error: Arduboy.h: No such file or directory

 #include "Arduboy.h"

                     ^

compilation terminated.

exit status 1
Error compiling for board Arduino Leonardo.

Can someone please post install instructions?

Did you install the Arduboy library, as instructed in Step 2 of the Quick Start Guide?

1 Like

Yeah,
I did the exact way the guide said…
Hmm.
I’ll uninstall reinstall and try again.

Thanks for trying out Glove! The error looks like a library installation problem. Have you gotten it to work?

Can’t get the game to load

Arduino: 1.6.9 (Windows 10), Board: “Arduino/Genuino Uno”

In file included from C:\Users\Brent\Documents\glove\glove.ino:1:0:

sketch\globals.h:4:21: fatal error: Arduboy.h: No such file or directory

#include “Arduboy.h”

                 ^

compilation terminated.

exit status 1
Error compiling for board Arduino/Genuino Uno.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Make sure you target is the Leonardo and that you have installed the Arduboy Library, per the Arduboy Quick Start Guide. Sounds like you are almost there :slight_smile:

It looks like you’ve loaded the file into the IDE using Open or just double clicked on the file after extracting the archive. You shouldn’t do this. You should install the game into your Sketchbook. Use the Adding programs (sketches) to the Arduino IDE guide to do this.

Or Arduboy if you installed Arduboy and DevKit board support as per the second part of Step 2 in the Quick Start Guide.

1 Like

does anyone know how to remove the sound ? thx

##Update News!

  • Added new options menu!

  • Added the ability to sound on and off. This setting uses the reserved EEPROM_AUDIO_ON_OFF bit as defined in Arduboy.h. Any other games that read this bit to determine whether to play sound will be affected by this setting.

  • Added an easy way to delete the save file.

Check the commits on Github for more detailed information.

1 Like

##Update News!

  • Added a little treat for those who 100% clear Glove!

If you’ve full cleared Glove already, just load up the game to check it out!

1 Like

Great Game!!!
Thank you for developing this awsome game.

1 thing I would like to ask…

Could you make “MUTE: Sound ON/OFF” option while playing game…

I try to finish this game but I could not play at all while taking Train or at Office.

Thank you.

2 Likes

Hey, thank you!

The game has an auto save feature at the end of each level. Once you enter the next level, turn the Arduboy off and on again to gain access to the main menu, where you can mute the game.

Right now, the B button has no function mapped to it, however I’m right at the memory limit so I’m not sure if I can do anything at this point. I’ll look into it next time I refactor.

1 Like

HiI For some reason I’m getting the following error:

Arduino: 1.6.9 (Mac OS X), Board: “Arduboy”

sketch/badguy.cpp: In function ‘void destroy_badguy(BadGuy&)’:
badguy.cpp:125: error: ‘class Arduboy’ has no member named ‘tunes’
arduboy.tunes.tone(TONE_BADGUY_DESTROY, 20);
^
exit status 1
’class Arduboy’ has no member named ‘tunes’

Any suggestions?

How did you install the Arduboy library? I’m guessing you used the master branch from GitHub. You should install the library using the IDE Library Manager as instructed in Step 2 of the Quick Start Guide.

1 Like

That fixed it!

Thanks.

1 Like

Another great game, really shows what can be done within the limits of the Arduboy. I will admit I find the game very tough, that health seems to fly down real fast ! Is there any chance of maybe using the B button to fire in a fixed direction? (I know that’s not how it was done in Gauntlet though!)

1 Like

I’m getting this error message when I try and load Glove (and I really want to play this game!) I’m pretty helpless when it comes to this kind of stuff, but I was able to get epic crates, virus lqp, and magic balloon to work just fine. Can someone point out where I’m making a mistake? I’m using Arduino 1.6.12 and I renamed to the folder to just “glove” but it still says this…

Arduino: 1.6.12 (Windows 10), Board: “Arduboy”

In file included from C:\Users\Ryan\Documents\Arduino\glove\glove.ino:1:0:

sketch\globals.h:4:21: fatal error: Arduboy.h: No such file or directory

#include “Arduboy.h”

                 ^

compilation terminated.

exit status 1
Error compiling for board Arduboy.