Has anyone been able to get Project ABE working on MacOS?

As far as I know, only Windows, Linux, and Android binaries exist. The description for the latest version says that the MacOS build has been fixed, is there something I’m missing? I’ve tried NWJS in the past, but opening the App.js file (in NWJS) doesn’t do anything.


Edit: After learning a bit more about NWJS, I was able to cd into the source code directory and run it, but I got an error that it could not find a background electron.js script?

I run Project ABE on a Mac. I didn’t have to do anything special to get it going.

What did you do initially and what errors did you see? I just took the Mac version and ran it :slight_smile:

I must admit I am using the online version nowadays - you can drag and rop a .hex file and a .bin file to it ProjectABE - Arduboy Emulator

The version I have does not allow me to do that.

1 Like

I installed NW.js and in the terminal opened Project ABE’s App.js with NW.js but got an error that it couldn’t find electron.js?


I couldn’t find the Mac version anywhere, as far as I know there are only Linux, Android, and Windows binaries available.

Edit: Oh, I found one in one of the pre-releases. I was looking in all the stable releases, my bad!

Edit 2: It says there’s something wrong with a profile because it’s from a newer version of NW.js, but after clicking all the prompts (which disappear quite quickly) it seems to work fine!

Edit 3: It’s just crashing randomly now. I think I’ll stick with the online version.