Having trouble trying to replace Arduventure [Solved] (Unrelated Port issue)

Thanks for a refresher on the guide. Got it to work. Can’t get Arduventure off though.Tried what all the forums say. Doesn’t go into flashlight mode either. Thanks for the help though.

1 Like

Its dose not work on arduventure.

The video will show you how.


If you have V 1.1 you will need to press the down.

1 Like

Idk why im not getting it. Holding up resets Arduventure after the 6sec and i have tried different timing many times to upload but it says something about port issue. Port busy or something. I had no problem with port before. There is only com3 & com4 in ports and leonardo is the board i have always had selected.

Can you copy the error.

I just went through this to get nineteen43 back on my daily driver arduboy after uploading arduventure onto it. After I send the code in the IDE I hit the reset button with a paperclip. It loaded nineteen43 instantly. I guess it was timing.

What are you trying to upload. Try Hello Word.

That’s what I have been trying. sometimes t will also get all the way to uploading… then it just stays there with no error but the arduboy disconnects from the PC after the 6 seconds. I have tried afew different games that have worked before as well but of course hello world is the quickest.

1 Like

Try pressing the reset button (if you are ok with that).

I had the same problem until i exactly pressed the load button for the sketch when the white light flashes (and not releasing the up button), it was all about timing.

2 Likes

Don’t know what happened, but I finally got it! Thanks everyone for helping. Can’t wait to play this game!

3 Likes

Good idea to make a new topic @Pharap.

3 Likes

To try and make sense of what was happening in my situation, I was in fact having an issue with port. Not sure what issue (I’m not the greatest with tech) but port was not reading correctly. Usually it would say port: com5 leonardo for me, and it wasn’t. It just had com3 & com4 as an option (did not say leonardo).

I uninstalled Arduino IDE from PC and removed all files in Arduino then reinstalled and replaced game files. Then switched on flashlight mode before plugging in Arduboy (my mac put it into flashlight mode when I attempted to upload something, I’m not sure how). Plugged it into PC and opened program and port showed up ‘com5 leonardo’ (like normal). Then I uploaded a game without issue. And I do not need to go into flashlight mode to flash more games which I have read can be an issue.

In conclusion, I am sure the help I was given would have worked to flash another game from Arduventure if port was reading correctly (somehow I messed port up). Thank you everyone for your help!

1 Like

I did have this once, but i installed new drivers for windows and after a rebbot of my PC it worked ever since. I did it in the system settings.

2 Likes

I think I also had the same problem once.
My arduboy used to use Ports 3 and 4 but now uses 4 and 5.
I’ve got a feeling I also might have wiped the driver and reinstalled it like @Nicole_Birgel did .

It is possible to reinstall the driver without deleting the whole IDE though.
If you get the “Windows ZIP file for non admin install”, it has the driver installers packaged in it because those need to be installed separately if you choose to go down the .zip unpacking route (as I often do - I’ve never really liked installers).
Arduino has a guide on how to do that.


Anyway, I’ve marked this as solved.
I also put the reasoning in brackets to show that it’s more of an edge case issue.

2 Likes

A post was split to a new topic: USB disconnected sound