Help with DIY Aduboy

So the ATmega32U4 that you put on your board came from a working Pro Micro? If that’s the case, its bootloader would be compatible with your board and you shouldn’t have to burn a new one. You should be able to connect the USB port to a PC, connect the battery, switch it on and upload a sketch using the Arduino IDE (with the board type set as Pro Micro).

If you can’t then you have a bad component(s), incorrect wiring, or shorts or opens.

Again, if the 32U4 came from a working Pro Micro, then the fuses will be set for using a crystal as the clock generator. You shouldn’t need an external clock.

If you think the 32U4 is set to use a crystal, it might not be a good idea to feed the chip an external clock.

It depends how far you want go with electronics and whether that justifies the cost. If you had a capable one, you could probably use it to see if your crystal circuit is oscillating properly and thus generating the required clock for the processor. That would rule out one of the biggest possible problems.

Well it will fit on a board the size of a Pro Micro and it appears you have a fair amount of space around the 32U4 on your board.

Unforunately, no success on that part. I still got the Device signature = 0x000000 error


It measured 0 ohms when connected to power, and 0.874kOhms when not connected to power. That is when I probed the ICSP pads on the Arduboy. A search suggests that there should be a resistance difference when it’s not short circuited.

I measured 4.2v across the Nano, working Pro Micro, and Arduboy.

RESET seems to be very odd, I GND it directly from the ATMega and I’ve connected a wire to the RESET on the Nano but shorting them doesn’t make the Nano Reset. I was able to illuminate the RX, TX, and Red (but it might’ve needed to been green) LEDs when I probed the ATMega directly and connected it to GND.

I’ve just tested and something very strange is happening. I can probe the Red LED pin on the ATMega and it still lights, even using 1 probe for some reason (I’m using a sewing needle too). It might be a bit of scratched PCB GNDing it though. If it wasn’t, what could it mean?

I’ll try this and see what I can find.

SCK/CLK - I was unable to probe the ATMega directly but using the ICSP Pads on the Arduboy I can measure 4.2v. no readings on other pins
MISO - Same as CLK.
MOSI - Same as CLK.
RESET - Same as CLK.

The only next solution I can think of is desoldering the ATMega, finding another one and soldering it on.


Doing a resistance check on all the ICSP connections to GND when not powered shows:
CLK - 18 MOhms
MISO - 18 MOhms
MOSI - 18 MOhms
VCC - 0.846 kOhms
RESET - 10.8 kOhms


A bit of internet browsing does suggest I might have a bad oscillator, even the error message says Oscillator: Off so perhaps I should replace that first.

You should never measure resistance when a circuit is powered up.

What voltage do you get between the Nano’s GND and VCC (5V) pins when connected to USB but not connected to your board? It should be 5V. If it drops to 4.2V when you connect the Nano to your board then something is wrong. It should remain close to 5V.

If you’re measuring resistance between 32U4 pins and GND, I never asked you to do that (except GND on the board to the 32U4 GND pins). Any LEDs that are lighting when probing for resistance are probably being powered by the current that the meter uses to measure resistance. Again, you should never measure resistance (ohms) when the circuit is powered up.

The first thing to figure out is why you’re only getting 4.2V instead of 5V (+/- 2.5%). It’s no use doing anything else until that is solved.

1 Like

I have the basic understanding of electricity but never knew about this, so I’ll avoid doing it again. I wouldn’t be surprised if I managed to fry something important doing that.

It sits at 4.65v.

I did have the Nano left on for a lengthy amount of time with a previous project that drew a fair amount of current but less than what its rated for. But I don’t know if that would change anything. If I need to I could solder the bare minimum (That would be the MCU, crystal, and 2 22pF capacitors, correct?) to a spare PCB with another set of pro micro parts.

If that’s without being connected to your board, then either the PC is providing less than 5V on its USB port or you have a high resistance USB cable. Can you try a different cable and/or a different PC USB port or use a USB charging supply/adapter?

1 Like

I tried a pro micro and connecting it to a USB charging supply and I still got 4.65v. I did however try a usb power supply for breadboards (they usually have a usb port and a 9v jack port which changeable voltages) and I was able to get 5v out of that connected to my laptop.

4.65V is OK but it has to be solid. If it drops to 4.2V on both the ICSP and your board when the board is connected, it indicates that your board is drawing heavy current. If the ISCP remains at 4.65V when the board is at 4.2V either the board is drawing heavy current or the VCC and/or GND wires connecting them have a high resistance.

1 Like

It’s no longer showing a large drop, I measured it connected to a pro micro (sitting at 4.65v) and got the same voltage. I think my best bet is to try and solder up another one with bare minimum and see if that changes anything, if not then it might be the PCB. If it is the PCB then I’ll change up the design (there was some previous changes needed anyway), order them, wait a bit (I don’t mind since I have another working Arduboy, just not an FX one), and try it again. I’ll definitely move those pads outwards a lot since that would provide a better look at the connection.

1 Like

@MLXXXp So the bare minimum for one is 2x 22pF capacitors, the oscillator, and MCU? Currently I’m just tweaking my PCB design (Do note that I use Auto Route on EasyEDA so the routing is questionable, I might spend the time to route it myself so it’s neater and better)

Yes.

If you’re updating the board, I would add at least one decoupling capacitor for the 32U4. Also, move the crystal and 22pF capacitors closer to the XTAL1 and XTAL2 pins to make the traces as short as possible.

1 Like

I might get to it then, if I can find another oscillator.

What values would you recommend?


I have KiCad installed for viewing Gerber files when I need to check connections, so there is a possibility I could switch to that (Though I’d have to do a lot of work to move it over). Also would you recommend using a 4 layer PCB or does a 2 layer PCB work just fine?

A 0.1uF or 1uF close to pins 14 and 15, and another close to pins 34 and 35.

Use whatever you like. KiCad is quite popular.

With the size of your board and the number of components, there should be no need for a 4 layer board. 2 layers should be easy to route (you’ve already done it). The production Arduboy and Arduboy FX are both 2 layers.

1 Like

Well I soldered up another one, I had no expectations of it working since I was so frustrated that the solder wasn’t connecting properly. My first attempt it almost worked but had a few bridges so I desoldered and cleaned it up, my second attempt a lot of the pins weren’t connected so by that point I tried to burn the bootloader and got Expected signature for ATmega32U4 is 1E 95 87. I’ll order the new PCBs once I’m done tweaking them, otherwise my ATMega32u4 will turn into 2 pieces :P. I could try the AU style ATMega but there’s not much stock and they’re quite pricey. I’ll order some new parts from Digikey (Though shipping will probably cost the most) and give it another go in about 12-25 days. With some new ATMega’s as well it’ll keep any solder away from the pads which will help. I might buy a stencil too to help out.

@MLXXXp Is this the correct wiring for the decoupling capacitors (C14 and C15)?

Yes. On the schematic you could draw them like C4 except with VCC on one lead instead of UVCC. Then, add a note that C14 is for decoupling pins 14 and 15, and C15 is for decoupling pins 35 and 35, as a hint that they should be placed close to those pins. Likewise, it should be noted that C4 should be placed close to 32U4 pins 2 and 5.

You probably don’t need C5 and C6 (as numbered on the schematic you previously posted). Just having C7 is sufficient for the purpose.

C13, which is for decoupling the W25Q128 could be changed to 1uF. Then you wouldn’t need any 0.1uF capacitors.

If you change C12 from 2.2uF to 4.7uF then you would only need 1uF and 4.7uF capacitors on the board.

Am I your little testing guinea pig? :P

I’ll get around to changing those and I’ll check how many of the capacitors I have for a new board. The shipping cost from Digikey will be expensive so if I spend about $60 on parts I can apply for free shipping and have some extra parts here and there, I might order some through-hole ATTiny85 for a teacher to try out making a simple LED driver for some students (Though I’ll only supply 1 test piece).

I could even switch to a different style of crystal oscillator with built-in capacitors so that’s less components. I can’t seem to find many options for a 3-pin SMD 16MHz resonator, would you know if I still need the 22pF capacitors or are those built into it? If you know any parts I could switch out then please let me know.

Also thank you for your help with this.

I would add a 1uF decoupling capacitor close to VSS pin 8 and Vdd pin 9 of the display.

Does that mean connecting a capacitor to those pins and placing it nearby?

A standard crystal has only 2 pins. If there are more than 2 then the rest are usually just 1 or more grounds for the metal case.

You have to look at specifications or datasheet for the part to know if it has built it capacitors.