Homemade Arduboy disappearing from Port

That’s happened to me before, check your wiring.

Very strange - 1944 just uses the standard libraries so if ArduBreakout works I would expect this to work.

What screen are you using? How are you compiling it?

The 1944 game removes the USB stack to make room for extra code. From the splash screen (which you cannot see!) hold the down arrow for a few seconds to return the Arduboy to the bootloader. You can then upload a new game.

Because you cannot see the screen, you may have to try this a number of times to get it to work.

1 Like

I don’t remember but I remember there was nothing happening on my screen but the noise was fine.

Okay so I have tried the down button trick but its not working. Should returning it to bootloader stop the music from the 1944 game? As it continues to play as I hold down button, also my bootloader was set to Cathy 3K starts with game when I first flashed 1944. Thanks!

Yes, it should cut the music.

With Cathy3K, I think you can hold the up and down for an extended period and it will restart in bootloader.

1 Like

Holding up and down cuts the music yet still no port available to select.


Mmmmm … that is the Cathy3K doing that I assume. It should return to bootloader at that point.

1 Like

Okay so I’m going to keep trying with that. Basically I have the Port tab open and as I hold up and down I’m waiting for the device to hopefully appear allowing me to upload a different sketch.
Is there anything else I can do? Is there a way to wipe the arduino and start from scratch? Potentially using another Arduino as ISP or something?


I am not sure why its not appearing as a USB key when it drops to the bootloader. Maybe @Mr.Blinky can chip in?

Otherwise, yes you can always re-flash it using another Arduino as an ISP.

if you use the Homemade package you should NOT install libraries manually. These manually installed libraries do not support the homemade package display and sound settings. You need to remove them again.

That won’t work. When the port tab is open it is not updated ‘live’. Close the port tab and open it a second after the sound stops when pressing up+down.

For real time diagnostic to see if the USB port gets detected in bootloader mode. Open device manager. as soon as you home made arduboy enters bootloader mode. you should see a COM port pop up under the ports section.

The Cathy3K setting does not affect library settings. Only use this option when you want to flash the bootloader bootloader or if you have burned the Cathy3K bootloader on your homemade Arduboy already. This setting allows your sketches to use 1K extra space.

Holding up+down for two seconds is a feature of the Homemade package’s Arduboy optimized core setting. the (Cathy3K) bootloader setting has no effect on this.

Does your homemade Arduboy have a reset button? Pressing that will enter bootloader mode instantly.


Okay, I have tried that but its not working and have decided I will try and fix it later.
I want to get my process right so I don’t stuff another one up.

I am using a new Arduino Pro Micro now and have installed the Mr.Blinky package in the Additional Boards Manager and have installed Homemade Arduboy package from the board manager.

From here what is the safest and easiest way to download games? Is there a way of telling games that would be incompatible with an ‘SH1106 screen’ setup in ‘Alternate wiring’?


I tried downloading the game fire panic from github, extracting it and placing it in my Arduino folder. I then upload it from Sketchbook, however I am met with this error.

In file included from /Users/mitchwhinnen/Library/Arduino15/packages/arduboy-homemade/hardware/avr/1.2.9/libraries/Arduboy2/src/Arduboy2.h:12:0,
from /Users/mitchwhinnen/Documents/Arduino/FirePanic/src/utils/Arduboy2Ext.h:3,
from /Users/mitchwhinnen/Documents/Arduino/FirePanic/src/utils/GameContext.h:21,
from /Users/mitchwhinnen/Documents/Arduino/FirePanic/src/Game.h:22,
from /Users/mitchwhinnen/Documents/Arduino/FirePanic/FirePanic.ino:1:
/Users/mitchwhinnen/Library/Arduino15/packages/arduboy-homemade/hardware/avr/1.2.9/libraries/Arduboy2/src/Arduboy2Core.h:65:4: error: #error SDA can not be used as flash chip select when using Pro Micro alternate wiring. Use RX instead.
#error SDA can not be used as flash chip select when using Pro Micro alternate wiring. Use RX instead.
exit status 1
Error compiling for board Homemade Arduboy.

This report would have more information with
“Show verbose output during compilation”
option enabled in File → Preferences.

After you select the homemade arduboy (from the package), there are a lot of options for various things. One of them being your screen. Select what screen your Arduboy is using and it should scale the game to your screen.

Selecting the screen type tells the compiler which screen control codes to send to the unit. It does not scale the graphics at all.


The error is generated because SDA is selected for flash chip select. But SDA is also used by the alternate wiring scheme.

To fix this, set the flash select option from the tools menu to ‘Pin0/D2/RX’.

There’s no easy way to tell other then the screen doesn’t display anything or looks garbled. Games that don’t work usually use their own modifued version of Arduboy(2) Library. You’d need to inspect the source code to find out.


I have it with fire panic now; I hold the down button from the menu screen the arduino shows up in the port. I then release the down button and hit upload on a new sketch and it says it “couldn’t find board on the selected port.”

Strange as the arduboy is clearly being put into bootloader mode yet still wont upload. I have tried many different variations, like holding the down button whilst trying to upload or releasing it prior.

What is the easiest way to wipe an arduino clean?


Fire Panic also has removed the USB stack (like 1944 did). I am not sure why you cannot upload something else as it is clearly going back tot he bootloader.

1 Like

I would say burning a new bootloader is the best.

the standard bootloader exits bootloader mode after 8 seconds. So you’ll have to time your upload right.

in Arduino preferences enable the show verbose output on upload then when you see the COM port messages during upload release the down button.

1 Like

I was able to fix all my problems. The trick is to continue to hold down or down and up until the game has finished uploading. MY mistake was releasing these buttons as soon as the Arduino showed up in port but turns out you have to hold them the whole time.

Thanks for everyone’s help!!!

1 Like