How to Add Games to an Arduboy

can some one make a video on how to add games need help


Hey, I replied to your comment on the other thread with a link to a pretty good video… but I thought I would throw out there the steps I follow to add a game to my Arduboy.

Upload a Game to an Arduboy

It should be noted that you should follow the Quick Start Guide and install the Arduino program to your computer as that part is being skipped here… so do that first!


  1. To start, Find a game that you want to try. Search the #arduboy:games category, which is the “Official” list of games for the Arduboy. More content for all of the TeamA.R.G. games and demos on the list can be found at their website.

  2. Download the ZIP file. For github links click on “Clone or Download”, and then “Download ZIP”.

  3. Your computer should ask you if you want to “Open” or “Save” this file, choose “Save”.

  4. It will download to your “Downloads” folder. Now choose “Open Folder” to open that folder.

  5. Click on the ZIP file you have downloaded, and choose to “Extract” it. Then “Extract All”.

  6. Your computer will ask you for the destination, click “Browse”.

  7. Using the “Browse” function, find your “Documents” folder and click on it…more options should pop up underneath that, choose “Arduino”.

  8. Click “OK” to choose the “Arduino” folder to extract your files to. Then click “Extract”.

  9. Once you do that your “Arduino” folder should pop up with your shiny new game folder inside! But this is where it gets a little finicky… specifically, the naming of the folder is important. It needs to be just the name of the game… If it says “-Master” after the name of the game, delete that part, leaving just the name of the game. Some titles are weird, so you might need to tinker a bit. For example, you would need to change “ArduboyLife-master” to just say “ArduboyLife”.

Start to Play

  1. Get your Arduboy and turn it on.

  2. Plug it into your computer.

  3. Open up the Arduino program on your computer… If it was already open, close it and reopen it.

  4. In the Arduino program, go to “File”, then “Sketchbook”.

  5. Find the game you just added and click on it, this should open a new window with all the code for the game in it.

  6. Click on “Tools” and make sure you have the correct “Board” (Leonardo) and “Port” selected.

  7. If the correct board and port are selected, click on the “Upload” button (looks like an arrow pointing to the right) to send the code to your Arduboy.

  8. After several seconds the game should now be on your Arduboy!

  9. You can now unplug your Arduboy and the game will be on it until you hook it up again to change it! And all the games you add to your sketchbook will stay in there so you can build up your own little library of games/programs. Changing games takes just a few seconds!


Disclaimer: I am a noob and was having trouble following that particular portion of the quickstart guide, so I wrote this all out to help people in the same boat… I hope it helps somebody out there!!!

I am certainly no expert!!! But these are the steps I found to work for me. There might be better ways of doing this, but this is how I finally got games onto my Arduboy! Note, some games I couldn’t get to work at all, so you might need to try a different game if it just isn’t working… Good Luck!


Thank You made it seam so simple thanks again


Some of these “weird” situations are covered in the Adding programs (sketches) to the Arduino IDE guide, which is referred to in Step 4 of the Quick Start Guide.

1 Like

It says compiling…, then uploading and it hangs there
And on the bottom line, it says, "Arduino Leonardo on /dev/cu.bluetooth-incoming-Port"
How can I have it go to my Arduboy instead of bluetooth!?!
I havre no idea how it got there, and under the tools -> ports -> serial port is shaded out.

Any help would be appreciated. I am running OS X 10.11.5

If you click on the verify button at the top left of the IDE, does it compile without any errors and you get something like:
Sketch uses xx,xxx bytes (xx%) of program storage space. Maximum is 28,672 bytes. Global variables use x,xxx bytes (… etc.)
in the output window?

If so, it looks like your computer isn’t seeing the Arduboy when you connect it. The usual reasons for this is that the Arduboy isn’t turned on, or you’re using a charge only USB cable, or the USB cable is bad. If possible try using a different USB cable.

1 Like

I turned my Arduboy on, and then a, “fa1221usbmodem” option showed up, so I used that and BAM it is working.

THX for the help.


it tells me that the board is not available

What board and which port do you have selected?

And have you tried following the newer quick-start guide?

It has better images.


Arduino: 1.6.8 (Mac OS X), Board: “Arduino/Genuino Uno”

/Users/21shangenh/Desktop/ELV_GY_v10/ELV_GY_v10.ino:40:19: fatal error: Gamby.h: No such file or directory
#include <Gamby.h>
compilation terminated.
exit status 1
Error compiling for board Arduino/Genuino Uno.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

I tried…

Elventure isn’t an Arduboy game, it’s a Gamby game, which is a different system so it won’t run on the Arduboy.

ok, still thank you.

1 Like

If you’re getting stuff from Team Arg’s site, remember to look at the symbols:

The Arduboy has a special symbol, which is different from ‘Arduino Based’:

You can see here that Elventure is ‘Arduino based’ rather than using the Arduboy:

They’ve partitioned the sections a bit, so most of the Arduboy games are near the top.

Please help! I made it through the whole process and did the steps properly, but when I try to click the upload button, it says “arduboy.2:h no such file or directory”

When you followed the Quickstart guide, did you install all the libraries including Arduboy2?

Also, can you paste the error EXACTLY as it appears? The ‘arduboy.2:h’ appears wrong and I am not sure whether you have transposed it incorrectly or the program you are trying to compile isn’t correct.

1 Like

It worked thank you! Thank you thank you thank you thank you!!! Time to grind on castleboy!!!

Excellent! Don’t worry about that game, there are plenty of Press Play On Taps games to play :slight_smile:

You obviously got your game Arduboy. Where did you end up getting it from?

Got it from ebay! Found a seller selling em brand new and in original packaging, and when I saw that it would take less than a week, I just couldn’t pass up on the offer! Now I’m enjoying my new arduboy! Really surprised by its build quality. The thing is a little credit card sized tank!!!

Yeah they sure are strong.


1 Like

Thanks! :+1:

1 Like