How to Reset Arduboy if it's Bricked

devkit (land side) --- arduino uno (cable pin side)

If the connection is loose, it will result in an error.
it need strong physical power. i used both hands.

1 Like

If you do manage to brick your Arduboy and can’t fix it yourself please let us know via our contact form or direct message and we will do our best to help you out! Amazing to see the hacker spirit in people trying to bring it back to life!

2 Likes

Hello,

My Arduboy no longer recognize the COM port.
I reset it, but a problem is not solved.

There is a need to write the bootloader.
Should I write in it using these 6 points?

Yes.

I haven’t seen the power supply part of the Arduboy schematic, because @bateske still hasn’t published it, but I suspect that you should leave the Arduboy powered off when attaching the programmer, and have the programmer supply power to VCC. To avoid damaging the display, you should probably use a 3.3V programmer.

2 Likes

If you have the original 6pin AVRISPMKII from Atmel like the one that I used then you need to power your Arduboy to flash it. The VCC pin of this programmer is only an input to sense the VCC of the target.
As I said, just for the original AVRISPMKII. There are clones out there that supply the VCC with either 5V or 3.3V.

1 Like

That’s fine, as long as the programmer senses that the Arduboy’s VCC is somewhere between 3.2V and 4.2V (because it comes directly from the battery) and adjusts its output signals to match. I suspect this is true for the AVRISPMKII. It may not be the case with other programmers.

1 Like

I try with 1.6.9. Holding UP key while resetting permits me to upload the sketch. It is working perfectly .

I think the case is often that the programmer output has a buffer (level shifter) that uses the device VCC for the output. At least that is how the USBtinyISP that I have works. It is possible to power the device from USB though, but that’s selected by a jumper.

The popular, cheap USBASP programmers don’t. Some of them have a jumper for 5V or 3.3V operation but they don’t do it properly. The jumper just changes the VCC supply output to 3.3V but the output signals remain at 5V :scream:

I have a USBASP V2.0 clone which I modified to properly work at 3.3V (as well as 5V).

Well, that’s bad. But good to know, thanks.

It’s good that mine is USBtinyISP and it wasn’t expensive. Maybe I should check the levels just to be sure, but I think it’s proper. I’ve yet to use it with anything else than Arduinos or plain AVRs.

I made wiki.
Please edit if there is content that can be added to it. :smiley:
http://community.arduboy.com/t/how-to-burn-bootloader-in-avrisp-mkii-and-atmel-studio-7/1893

1 Like

I wrote a sketch that reads and displays the fuse and lock bit settings. It also reports if the settings properly protect the bootloader from being overwritten.

On my Kickstarter Arduboy, the bootloader is NOT PROTECTED! This means that it would be possible to upload a sketch that is too large, which would corrupt the bootloader, making further uploads impossible. The bootloader would have to be reinstalled using a hardware programmer attached to pads on the back of the Arduboy’s circuit board.

If your Arduboy is the same, I’d be pretty careful about uploading sketches using anything other than the Arduino IDE. (The Arduino IDE checks to make sure the sketch isn’t to large before performing an upload, so the bootloader won’t be overwritten.)

Note that it’s not possible to set the lock bits to the proper value without attaching a hardware programmer. It can’t be done using the USB port.

You can use the following sketch to check if your Arduboy has an unprotected bootloader.
If it reports:

  • “LOCK bits are OK” then the bootloader is safe.
  • “Bootloader UNLOCKED!” then corruption of the bootloader is possible.
  • “LOCK bits INCORRECT!” then the lock bits are set to an unexpected pattern.
/* Arduboy Fuses and Lock Bits display
 *
 * Displays the values set for the fuses and lock bits 
 * then indicates if the lock bits are:
 *
 *  - set correctly so the bootloader can't overwrite itself.
 *
 *  - set to default, which means the bootloader is unlocked and could
 *    overwrite itself.
 *
 *  - set incorrectly, meaning the lock bits are set in an unexpected pattern.
 *    The bootloader may or may not be locked.
 */

#include <Arduboy.h>
#include <avr/boot.h>

Arduboy arduboy;

void setup() {
  uint8_t lowFuse = boot_lock_fuse_bits_get(GET_LOW_FUSE_BITS);
  uint8_t highFuse = boot_lock_fuse_bits_get(GET_HIGH_FUSE_BITS);
  uint8_t extendedFuse = boot_lock_fuse_bits_get(GET_EXTENDED_FUSE_BITS);
  uint8_t lockBits = boot_lock_fuse_bits_get(GET_LOCK_BITS);

  arduboy.begin();
  arduboy.clear();
  arduboy.setCursor(0,0);
  arduboy.print("LOW Fuse:      0x");
  arduboy.println(lowFuse, HEX);
  arduboy.print("HIGH Fuse:     0x");
  arduboy.println(highFuse, HEX);
  arduboy.print("EXTENDED Fuse: 0x");
  arduboy.println(extendedFuse, HEX);
  arduboy.print("LOCK bits:     0x");
  arduboy.println(lockBits, HEX);

  lockBits &= 0x3f;
  if (lockBits == 0x2f) {
    arduboy.println("\nLOCK bits are OK");
  } else if (lockBits == 0x3f) {
    arduboy.println("\nBootloader UNLOCKED!");
  } else {
    arduboy.println("\nLOCK bits INCORRECT!");
  }

  arduboy.display();
}

void loop() {
}
1 Like

Yeah as mentioned before Kickstarter units don’t have lock bits set. I had asked the factory to flash same as Leonardo but the lock fuses were omitted. All the preorder units have the correct and more safe setting. If people have a problem and somehow damage the bootloader we can try to help but the primary cause seems to be using non-recommended tools for uploading.

Other than the Arduino IDE, is there a list of “recommended” tools?

Codebender

and we are evaluating the offline loader, we would love it if that was open source.

Working on getting our own online loader, so you’ll be able to one click upload games.

2 Likes

Not any more
https://codebender.cc/next-chapter

I’d just like to add that USB hubs can cause the reset button method to not work. Plug your arduboy directly into your computer.

I can’t see how a using a USB hub would affect the operation of the reset button. Can you point to more specific details describing the cause of the problem?

My Arduboy was bricked, and plugged into a USB hub. I tried the reset button several times, no luck. I could never get the timing right. I unplugged the hub and plugged the Arduboy directly into my computer. The reset button worked on the first try since my OS recognized the device right away instead of a delay of a few seconds.

Yay!!! I had this issue and I’m so glad this fixed it! Thanks guys!