How to Reset Arduboy if it's Bricked


(Pharap) #63

Erm… reinstall the drivers?
Maybe?..


(Simon) #64

Yeah … did that and even installed it all on a fresh (wifes !) laptop. Same result.


(Erwin) #65

Happened to me and the only way to bring that one back was flashing the firmware using ICSP, but first step is to check another PC to be sure


(Pharap) #66

Well, that’s already been done


So… ICSP time I guess? :(


(Kevin) #67

Was this also done with the ones you sent in? Because it seems the reset button worked on my computer. Maybe its a certain version of drivers?

@filmote or is the one you have left die even harder than these 3?

If you’re using Arduino, I don’t believe it’s possible to corrupt the boot loader other than a interrupted upload from a bad cable or something. With Arduino alone the reset button should always work.


(Scott) #68

@bateske, I hope that for Arduboys you are able to recover using the reset button, like those in the video, you still load the fuse check sketch and then set the bootloader protection fuses using an ICSP, if necessary, before returning them to the customer.


(Simon) #69

Yep … I could not get any of the ones I sent you to even be recognised by the computer at all. The one I have now shows different symptoms to the others -

Soemtimes it will display the Arduboy logo but it flashes the side LED once in green and then display Arduboy logo. The logo doesn’t scroll on anymore it just appears. Sometimes this is relatively quickly, sometimes after 30 seconds or so and sometimes never.

When plugged into the USB the red charge LED comes on. After about 30 seconds to a minute the light goes off if I do nothing else.


(Kevin) #70

@filmote you are for sure running into issues with RAM registers, that is exactly the behavior you would get. So that’s what bricked these other units.

The fact you can’t recover them with the reset button seems to be something unique to your computers. Maybe it’s because you’re on the other side of the equator? Did you try standing on your head and doing it?


(Simon) #71

Of course … you were on the equator when you fixed them in Singapore.

This new one is different to the ones you fixed. This one did work on my computers up to the point when it didn’t!


(Kevin) #72

Maybe if I send you my computer…


(Simon) #73

Mmmm … I am right for computers ATM. Just need a working Arduboy to finish my game.


(Kevin) #74

Your hacking skills are too elite. We will get you sorted, sorry you’re having so many troubles but we will get it figured out eventually!


(Leo) #75

have you been able to fix the arduboy yet? I fear I may have the same issue with windows ten not recognizing the arduboy after pressing the reset button. I’m currently going to try it on a different operating system and see if it works there.

edit: confirmed. Windows 7 starter, (exclusively used for the arduboys a year ago) does not recognize the device after the reset button is pressed. My new windows 10 has the same result.

I just did the same thing with my other arduboy. it works like it should with the reset button pressed. the computer still recognizes it as an arduboy.


(Kevin) #76

There must be some kind of weird state these are putting in which are only reporting like a partial USB-ID or something?

I was able to successfully recover the devices from @filmote with just the reset button, but he says the new one seems to be a bit different

@Ground7 what caused your device to fail?

If you want to send it in to us for repair we can try to fix it for you, if that’s an option for you please let us know at arduboy.com/contact


(Leo) #77

using arduboy uploader, (an unofficial third party uploader)

I have bricked these in the past with no issue using the reset button. so I was at a loss here this time around.

I believe it is a broken bootloader. later this week or next ill get the confidence to go ahead and try reflashing the bootloader like in the other thread.
cant I just use an Arduino to flash it? I think ArduinoISP? I also have a USVtinyISP, would that work?

I’m not against letting you guys repair it, but I do like to learn how to do this kind of thing myself. That’s why I bought them anyway, to learn and have fun:slight_smile: After I read up on the bootloader information ill know if I’d want to try myself or not. Ill let you know.

Thank you Keven!


(Simon) #78

No … not at all. I can start mine in flashlight mode and still it is not recognised - I had tried it now on two Windows and two Macs but none want to know about it.


(Leo) #79

haha flashlight mode is no problem for me either.

Mine just doesn’t have a memory issue like yours. it turns on just fine, (name scrolls and the spinner game demo I installed works). only the reset is an issue both manually and by the programmers.

I am currently only using Arduino IDE on this one till I get it fixed.


(Simon) #80

Right … mine (occasionaly) gets as far as displaying the Arduboy logo - but it doesn’t scroll in, it simply appears which makes me think its already in the screen buffer rather than being rendered. Its a mystery alright.


(Leo) #81

ok I need to sleep. I’ve been on this for a few hours now.

I found that I can use an Arduino to flash it. The info I found in the forum is using the development boards, but it should be the same pin set. Ill have to look into it later this week when I have time.

I’ll let you know @filmote if it is fixed after I do it.


(Simon) #82

Please do! I don’t have an working Arduboy at the moment and are having withdrawals.