I cannot flash my arduboy [Solved]

i’ve recently bought this device and i have several problems , i don’t know why my pc doesn’t detect my arduboy, the screen is black and i cannot flash it although i’ve tried a lot of times too.

so basically my arduboy is dead? wtf

Firstly: did you remember to switch your Arduboy on after plugging it in?

If you didn’t flick the switch at the top of the Arduboy after plugging it in then nothing will happen because the Arduboy will be off.


Failing that:

What operating system are you using?
Which version of the Arduino IDE are you using?

1 Like

Yes , i did it… i think that my arduboy is dead, my pc cannot detect arduboy’s port so …

Which operating system are you using? Windows 7, Windows 10, Mac?
Which version of the Arduino IDE are you using?
(It will say in the title bar.)

Is it fresh out of the box?
When did you buy it?
Where did you buy it?

1 Like

windows 7

arduino 1.8.5

Is it fresh out of the box?
yes, i’ve received it today…
When did you buy it?
14 dias ago
Where did you buy it?
in arduboy store

i’ve uploaded some games but i don’t know why…when i did a simple program like “hello world” it crashed and my pc doesn’t detect arduboy’s port anymore

i think that i have the same problem than this guy, he cannot flash it

Ok, I think I know what might have happened.
I’ve got a feeling you might have tried to upload code for the wrong board type.

Can you send a screenshot of the Arduino IDE?

In case you don’t know: you can take a screenshot of just the active program by doing Alt + Print Screen.
Then paste that into paint and save it somewhere (.png or .jpg is fine) and upload that file here.
You can use the upload button (a little arrow at the top of the text box) or just drag & drop the file.

1 Like

it was the sample code of hello world /file-examples-arduboy 2-hello-world/ , i selected arduboy’s board too, how could i flash it?

Ok, you’ve definitely got the right board type, so it’s not been flashed with the wrong board.

If you hold the up button when switching it on, does the screen go white?

1 Like

No, it’s black and i’ve tried to flash it and nothing happened… maybe you are right i would have uploaded code in the wrong board

Did you have the board on something other than Arduboy before sending the screenshot?


What happens if you:

  • Plug the board in
  • Swtich the board on
  • Press the reset button at the bottom

Reset

1 Like

In the screenshot I see COM1 is selected. I don’t think thats the right port. Usually it would read COMx (Arduino Leonardo)

Can you select another port? In most cases you need to select the port with the highest number available.

(where x can be any number)

1 Like

No , i tried but my pc doesn’t detect the arduboy’s port

Wow, i didn’t know about that reset buttom…but how could i press it if this buttom is inside of arduboy.

Sorry for my English i’am from Argentina

With the arduboy plugged in and turned on click the start bar and type “Device Manager” to search and open it. Under the COM devices listing do you see something that says arduboy, arduino leonardo, bootloader or the like? If you see nothing like that then it is possibly a software issue like corrupted bootloader preventing usb enumeration. I suppose it could also be a hardware issue like a cold solder joint but this is highly unlikely.

2 Likes

it’s my device manager, the arduboy is turned on right now

it’s in Spanish , sorry for that

It’s ok, we have users from all over the world.
Britain, Australia, Canada, France, Germany, Austria, Norway/Chile

A toothpick or a pencil (preferably a mechanical pencil).
Make sure it’s not too sharp though.
An object that is too sharp could damage the buttons (e.g. a pin would be a bad idea).

Fair point, it’s odd that COM1 is showing up…
Perhaps the computer still thinks the Arduboy is connected somehow?
Maybe it never registered the disconnect and still thinks it’s got a connection?

This was going to be my next suggestion.

@tfGamer
It should look something like this:

If it’s not showing up, it’s not connected.

If it’s not showing up, press this:

And it should look like this:

Edit:
In response to the image you posted:
It looks like the drivers haven’t installed properly.

Don’t worry I can understand spanish :-). Yeah I’m not seeing anything like an arduboy enumerating. It should show as two com ports that aren’t com1 with one being for the standard uart serial port and the other the bootloader. I would try Pharap’s suggestion of manually installing the usb drivers to see if it shows up first. Otherwise if you have another arduino you can go about reflashing the bootloader using it as an isp programmer, but this should be a last resort.

I think it’s a bit soon to assume that’s what’s happened.

And if the bootloader has been wiped, it might be safer to fill in the contact form and have Arduboy Inc do it.
Setting it up incorrectly (i.e. wrong voltages) could damage the Arduboy.

1 Like

Yeah I didn’t think about what tfGamers experience might be when I wrote that so changed my suggestion to reflashing as a last resort. Also COM1 is usually the motherboard’s hardware db9 serial port so it definitely just isn’t seeing the arduboy so I think your driver installation issue suggestion is likely.

2 Likes

here is my device manager , i think that first at all i need to reset it…!