I have a problem uploading [Solved]


(Ramiro Diaz) #1

problem has been solved thank you everyone who helped

I am using Arduino IDE to code a new game and I try to upload it to my arduboy and this shows up Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.
please help


(Boti Kis) #2

Did you follow the quick start guide?
If so, please make and post a screenshot of the arduino interface so we can help better.


(Ramiro Diaz) #3

ok here it is


(Boti Kis) #4

Ugh…
I have expected a bit more detailed info by this IDE.
Does your computer recognize the arduboy if you connect it?


(Ramiro Diaz) #5

yes my computer does recognize it


(Kea Oliver) #6

Can you upload one of the examples? Go to file > examples > scroll down to arduboy2 > helloworld. Try and upload that


(Ramiro Diaz) #7

nope shows the same message


(Ramiro Diaz) #8

i know its not the arduboy because i can download games off my phone


(Kevin) #9

Oh boy! Is this another one of those mysterious windows 10 situations? I hope not… First things to check:

Have you set the board type to leonardo?
Do you have the correct COM port selected? (It should also say leonardo)

Maybe… try restarting the PC? I don’t think this will help if it is being recognized by windows.

I think if you turn on verbose mode give us better info?

Can you expand the status bar at the bottom so we can see more of the error?


(Kea Oliver) #10

Double check you did all the stuff in here https://arduboy.com/download-and-learn-arduino/ just to be on the safe side


(Ramiro Diaz) #11

im sorry but what is verbose mode


(Ramiro Diaz) #12

also yea i just checked every thing on the tutorial thing and im doing everything right


(Kevin) #13

Be sure to check these things first:
image

image

Make sure you are selecting the COM port that says Leonardo, it will likely be a different number.

If you can confirm those, then go to File->Preferences and select these two check boxes:
image

Try to upload again, once you get an error make the status window big enough to see all the red text:

Or, alternatively just click the copy error messages button and paste it here.


(Kevin) #14

Also, what windows version are you on? Any chance 8.1?

I also kind of feel like we see this issue on Arduino installs from the windows store or am I crazy?


(Ramiro Diaz) #15

sorry for the delay no im running on windows 10 and yes i did download it off the webstore here is the picture


(Kevin) #16

Ah, ok getting somewhere, is it possible to scroll up some more? It seems like the error is in the compiling stage.

It looks like you’ve actually selected the board type Arduboy using the custom definition. This is something that @MLXXXp and @Mr.Blinky might know more about, I suspect that might be part of the issue?

Are you able to select a leonardo board type instead of Arduboy? Does that give a different result?


(Ramiro Diaz) #17


here it is


(Kea Oliver) #18

Assuming you are on windows, go to device manager, and what shows up under Ports. To get to device manager just search “device manager” in your start menu.


(Ramiro Diaz) #19


here it is


(Kevin) #20

So it should show up in device manager as Arduino Leonardo. It’s kind of looking like the bootloader was overwritten? Or perhaps windows is not correctly recognizing the device?

Have you tried using the reset button or flashlight method to reprogram the device?

You might try using one of the game uploaders for PC as well.

Do you have access to another computer where you can test on?