I must have a screw loose [Solved]


(Tom Stewart) #1

Someone else had reported a while back that they lost a screw. Over time, all 4 of mine have come out (and are lost). So now my cute Arduboy sits in a drawer. @bateske had said these would be replaced, and I sent my address, as he had asked. And I have attempted to follow up via PM a couple of times, but there’s been no response. So I don’t know if I am blocked, or PM isn’t working, or Kevin is too busy, or what. But I would really like some replacement screws. As I said before, I’m happy to pay for the cost of the screws and shipping.

Can/will anything be done? Or will I need to track these down “locally” (I had checked my local Ace earlier, to no avail…)


(Kevin) #2

We are working on replacement screw setup. We are establishing a central warehouse.

Also looking into getting “better” screws that have loctite on them so it won’t come out. I also want to include a little screwdriver as well.

It seems like this is the result of keeping it loose in your pocket and handling it a lot and or dropping it.

Thanks for letting us know we will get you some new screws soon!


(Thorsten Schmid) #3

I would like to get some screws too. :wink:


(Tom Stewart) #4

Thanks! I will own up to all the above, except dropping it.


(Cody) #5

Ummm dont listen to me but you could if you never wanted to open it up again solder😬


(Kevin) #6

We have requested extra screws from our Factory several times, we are still waiting. So very sorry to keep everyone else waiting too. But we will renew our efforts, we certainly haven’t forgot and when we do have them we will let you know!


(Holmes) #7

Is there a way we can get specific details about which screws to use? My girlfriend told me yesterday that my Kickstarter Arduboy is missing 2 screws, now! :cry: I don’t mind paying a few cents to pick up a few screws at Fry’s or something.


(I Don't Even Have An Arduboy.) #8

May I ask what type of screws they are? Like size, and such.


(Kevin) #9

The screws were customized, I requested the specifications from the factory. I’m supposed to be getting 1,000 screws and the data sheet tomorrow so hold as best as you can without screws… for now! Yikes! Sorry everyone!


(Tom Stewart) #10

Woohoo! Sounds like the end is in sight!!


(Kevin) #11

We have the screws! We are going to have to ship them from Thailand, so… bare with us!

If you are waiting for screws, we do have a list, it’s probably not a bad idea to remind us at www.arduboy.com/contact


(Tom Stewart) #12

That’s great news, Kevin, though not great enough that I’d be willing to remove my clothing with y’all. I will, though, “be patient, or forbearing” with you :wink:

I’d like to assume that I am on your list…


(Tom Stewart) #13

Good News/Bad News:

The screws arrived just before Christmas! Yay! Thanks, @bateske!!

I can’t seem to get my Arduboy to work at all, though :frowning: I waited until I had purchased some thread lock, and then screwed the unit back together. It all looks fine, but absolutely the only thing that happens now is that I can get the LED closest to the USB connector to come up by plugging it in and having the switch over to the right. It doesn’t appear to do anything else. Doesn’t hold a charge, as far as I can tell, which is to say that I’ve left it plugged in overnight, both with the switch to the left and to the right (yup, two nights), but if it’s not plugged in, there are no lights, no nuthin’. If I plug it into the computer, it does not show up as a USB device in Device Manager at all.

It’s dead, Jim.

Even though it was working fine prior to the last screw falling out, and it sitting gathering dust in my drawer for months awaiting screws.

I am so sad. :frowning: Since I’ve been on hold, the Arduboy Manager project came to life, and I was really looking forward to using it.

Guess I will await the 2nd generation Arduboy. Sigh…


(Scott) #14

When you left it plugged in and the red LED came on, did the red LED go out eventually (while still plugged in)? Did the red LED behave the same whether the power switch was on or off?

My first guess is that you have a bad power switch or one of the switch connections is broken.

The red LED (closest to the USB connector) is the battery charge indicator. While plugged in to a USB port that provides power, it will stay on solid until the battery is charged, at which point is will go out. This LED should behave the same whether the power switch is on or off.


(Kevin) #15

Sounds like some problem with the battery. If you have the cover off, are you able to carefully inspect the battery contacts? They are very fragile and sometimes peeking under it a few times, folding the contacts, is enough to break them unfortunatly. :slight_frown:

Please reach out to us at www.arduboy.com/contact and we can try to help from there.


(Scott) #16

If it’s a disconnected battery, wouldn’t the unit still run when switched on and powered via USB? The charging circuit should be able to provide power even with no battery.


(Kevin) #17

One would think, looking at the schematic. But in practice, no the battery needs to be in the circuit for the unit to operate under usb power only. It’s likely the charge controller looks downstream for some appropriate resistance? It’s an issue I’ve never been able to fully diagnose but something I want to address in the next version. There are charge controllers that will isolate the system and the battery during charge, and that would solve it. There is also ways to do it with additional transistors or fets, but unfortunately my electrical engineering skills were not that great when I designed the pcb, and still learning to this day.

For me personally the pain point comes in when I was/am doing debugging of factory fresh units, I need to have the battery installed. It’s annoying.


(Tom Stewart) #18

Hmm… My recollection is that the LED never went out, but not 100% certain on that. Definitely goes on/off with power switch.

I’ll take it apart again and look…


(Kevin) #19

Do be sure to ping us at www.arduboy.com/contact we want everyone to have a working Arduboy!


(Tom Stewart) #20

OK, so I took it all apart. And honestly, I have been very careful with it since it lost its last screw. It has simply sat in my drawer, unperturbed since then, with the pieces as together as they could be. Now, I don’t recall exactly what state it was in when I discovered that the final screw had been lost, but it was definitely not really in pieces. It seemed as though mostly the top clear plastic piece was off; the rest had seemed to be together. Only after intentionally taking it apart today did I see the (amazingly slim!) battery for the first time. And one of the tabs, nearest the power switch, was definitely broken. I tried soldering it back. I tried with flux to clean it well. I also tried another trick from my book – using de-soldering braid as a nice, flexible extension for a batter tab. But no luck – I couldn’t get anything to solder to the small remaining bit of battery tab.

So your intuition (educated guess…) was correct, @bateske. I will use the contact form, as requested, and reference this thread.