Installing Arduboy on Ubuntu & Debian


#1

Hello! This is how to get an Arduboy working on Ubuntu.
If you are using Windows or macOS, try “Quick Start Guide” instead.
Just follow the steps and your computer might not catch fire. :wink: Let’s get started!


Step 1: Download the Arduino IDE from Arduino software page.
Unpack the tar.xz file you just got into whatever folder you’d like. Do keep track of where it is, though.
Step 2: Then, install the Arduino stuff by running the following command into a terminal:
sudo apt-get install arduino-core
To open a terminal window, press Control, Alt, and T all at once.
It’ll ask for your password. Be aware, the password won’t show up for security reasons.
Step 3: Next, add yourself to the dialout group with this command, replace “yourname” with your username:
sudo usermod -a -G dialout yourname
This will give you permission to upload stuff to the Arduboy.
Step 4, final: You’re almost done! Just go to that folder you unpacked before, and this time, open a terminal window by right-clicking and selecting “Open in Terminal.” Then, type in ./arduino, press Enter and watch it come up. Try uploading something. If it worked, your Arduboy is set up! Wasn’t that easy? :grinning:
Optional: Run ./install.sh while you’re in the “arduino-1.X.X” terminal. Depending on your system, this might add the Arduino IDE to your application menu. You can also use a tool like alacarte to create a menu item.


(Scott) #2

For Ubuntu (might also work for Debian), I more or less follow this guide:
http://ubuntuhandbook.org/index.php/2015/11/install-arduino-ide-1-6-6-ubuntu/

This installs the Arduino IDE outside of the apt package management system, so don’t install any pre-packaged versions of Arduino using the software manager or apt. It’s best to uninstall the Ubuntu packaged version if you’ve previously installed it.

When any of the sudo commands below is executed, you may be prompted to enter your login password, which you should do.

  1. Download the latest Arduino package, Linux 32-bit or Linux 64-bit, from the official page.

  2. Open terminal from Unity Dash, App Launcher, or via Ctrl+Alt+T keys. Do the following steps in the terminal:

  3. Change to the directory (likely Downloads) where you downloaded the package
    cd ~/Downloads

  4. Decompress the downloaded archive with the tar command. Use the filename of the package you downloaded in place of arduino-1.8.3-linux64.tar.xz
    tar -xvf arduino-1.8.3-linux64.tar.xz

  5. Move the extracted folder to the /opt directory for global use. Use the name of the extracted folder in place of arduino-1.8.3
    sudo mv arduino-1.8.3 /opt

  6. Navigate to the extracted folder in its new location under /opt. Again, use the name of the extracted folder in place of arduino-1.8.3
    cd /opt/arduino-1.8.3

  7. Run the install script to create both a desktop shortcut and launcher icon:
    ./install.sh

  8. If you’re not already a member of the dialout group, add your username to it. Use your username in place of yourname
    sudo usermod -a -G dialout yourname

  9. If you wish, you can delete the downloaded archive file to free up disk space.

You should now be able to double click on the Arduino IDE desktop icon to launch and use the IDE.


If you get an error similar to the following when attempting to upload a sketch into your Arduboy:

avrdude: ser_open(): can't open device "/dev/ttyACM0": Device or resource busy

it’s likely that the ModemManager service is using the serial port. You probably don’t need the modem manager, so the easiest way to fix this is to disable the service:

sudo systemctl disable ModemManager.service

You only need to do this once. It’s best to re-boot your machine after this to make sure it takes effect.


If you want to upgrade to a newer version of the IDE, uninstall the current version then follow the above steps for the new version. To uninstall:

  1. Open a terminal window as above.

  2. Navigate to the folder, under /opt, containing the currently installed version. Use the name of the current version’s folder in place of arduino-1.8.3
    cd /opt/arduino-1.8.3

  3. Run the uninstall script to remove the desktop shortcut and launcher icon:
    ./uninstall.sh

If you wish, you can delete the folder, under /opt containing the previous version. If you don’t delete this folder, you can run this version of the IDE by changing to this folder in terminal and entering ./arduino


#3

Yeah, ./install.sh doesn’t ever actually do anything for me, just prints a bunch of errors, so I use menulibre to manually make a .desktop link to the Arduino IDE. Anyway, I just had a bit of trouble following the Quick Start guide. So, I made my own. :grinning:


(Scott) #4

It could be because you installed arduino-core using apt-get. This may cause conflicts with ./install.sh which is why I said don’t install the Ubuntu package and uninstall it if you have.


#5

Huh, this is strange. I just tried it and it actually worked. It even deleted the old desktop file I manually created. Before, it complained about the name of the program being incorrect.
And I have arduino-core installed. :crazy_face: This is confusing.