Is this thing really bricked? [Solved]

Wow it’s surprising that the application doesn’t filter for only hex files.

What happened with the other Arduboy?

Can you tell us your process you used from the beginning to load new games and where you had the first issue?

And unfortunately there are about 5,000 units in the wild that the correct fuses were not set by the factory to protect the boot loader. So if you use an application other than Arduino to flash it there are some risks they can blow it away because Arduino has some safety checks involved.

here’s my thread for the first one: Can't upload games

I got that same red screen error when trying to upload via PC on my second one. I haven’t tried Blinky’s solution on this new one because I don’t want to mess it up, and I’m afraid to try anything with the IDE on it unless I can get it working on the first one.

If you get the same message when uploading to both Arduboys then I’m guessing the driver isn’t installed properly and you’d be best off reinstalling the IDE.

If you only get that message from the first Arduboy then I think it’s possible the bootloader has been overwritten on the that one.

If you don’t get that message on the second Arduboy but the program still won’t upload, you might have to try using the reset button instead of trying to upload normally, which can be a bit trickier to do because the timing needs to be right.

It successfully runs hello world on the new one. as I understand it, the IDE can’t upload all file types? am I now limited to what I can play? I still wasn’t able to flash a .hex with the android app.

1 Like

Ok, in that case the new one is absolutely fine and your first one most likely has had its bootloader overwritten.

Fixing that is possible, but it’s tricky because you need either another Arduino board or an ISP programmer, as well as some decent clips or another pair of hands to help you hold all the wires.

There’s a thread about how to do this:

If you’re worried that sounds too tricky or you don’t think you could manage it then you’d be best off using the contact form to contact Arduboy Inc and ask if they’d be willing to fix it or replace it for you.

(Depending on where you live, that may take longer because you’ll have to mail your Arduboy to them, but it avoids all the fiddling with wires.)

The contact form is here:
https://www.arduboy.com/contact/

Had I noticed that thread back then I would have recommended using the contact form then.
Somehow I missed that thread entirely.
(I must have been away that day, or it got buried under newer topics and I didn’t notice it.)

Not exactly.

The IDE doesn’t have an option for loading .hex files or .arduboy files,
but you can compile games from their source code,
and as far as I’m aware 99% of Arduboy games have their source code available.

There are other tools that can upload .hex files and .arduboy files.
(Some of which are listed here.)

It’s possibly a problem with the android program then,
in which case you’d have to ask the person who made it.

can’t upload via any of the PC programs. they hang when trying to find the bootloader, same as the first one before I fried it.(this new one is a replacement they sent me free of charge by the way, so it’s no huge loss on the first one)

I was able to flash a new game via source code, following this guide, thanks! How to Add Games to an Arduboy

@BookCrate the hanging in the software, this happened from the very beginning?

You seem to have a heck of a lot of COM ports, do you have a bunch other peripherals connected there?

This reminds me of a similar bug that was occurring to another user year ago which manifested by having a bunch of phantom COM ports generated every time the device was plugged in.

Glad you were able to have some success with the source code!

pretty much all of my USB ports are being used by something.

arduventure is running, but I’m not hearing any sound, and it’s toggled to be on.

I’m kind of guessing the community uploading tools don’t handle so many com ports at the same time and there is some kind of conflict.

For the issue with the speaker have a take a look at this thread:

Really sorry you are having such a tough time with the hardware, it’s not common to have so many issues! For every several hundred units that are good we have a one or two that have some hardware problems, most of them are related to the battery tabs.

We are committed to helping out and making sure you end up with a positive experience and as always you can reach out on arduboy.com/contact with any specific issues.

1 Like

it’s weird because the sound was working initially. hasn’t been dropped or exposed to moisture or anything like that.

It doesn’t always get placed 100% correct by the factory and it can get moved around in shipping. There were some misunderstandings in the production documentation where tape is placed.

But again, if you’ve got a problem that can’t be fixed let us know and I’ll try to help get it resolved.

I can’t see anything obviously wrong with the speaker speaker

Hmm I’m not sure what would cause no sound to come out when there is supposed to be sound and everything is connected right. The piezo speaker is I think kind of impossible to fail, it’s possible there is a bad solder joint on the processor or something?

Do you want to send one of these back for repairs?

I’d like to send the first one back while I play around with the second one some more

just heard a single beep briefly when I went to switch it off, and my finger slipped, causing it to reset, but nothing after that. if I put my ear to the speaker when I turn it on, I can hear a faint click, and while it’s on I can hear a faint buzzing sound, which is not present on the first “bricked” unit. not sure if this is normal or signs of a speaker issue.

It’s possible some kind of transient current event caused it to damage one of the gpio pins on the speaker. It is technically possible for the speaker to get blown out if it happened to you it would probably be the first I’ve heard of it though.

There’s a version of mermaid that only resets instead of starting the bootloader (which is an Arduino glitch) you can try the following to resolve this:

A very general solution Using Arduino IDE:

  • open blink example sketch from File > Examples > basics and go to the newly created window

  • Go to preferences (CTRL+Comma) and at the option Show verbose output during:
    put a checkmark at the options compiler and upload and click OK

  • Press reset button on Arduboy

  • quickly (within 8 seconds) go to tools > port and select com port (usually the highest number)

  • Ensure Leonardo board is selected from Tools > Board menu

  • click upload button (or press CTRL + U)

  • When you see the text PORTS {} appear in the black window press the reset button on Arduboy

  • After the upload is complete you can upload an Arduboy sketch / game again normaly

The reset button on Arduboy is left from the micro USB connector. Use a toothpick, a SIM eject tool or something similar to press it.

When you’re using Arduino IDE 1.8.6 or above then games using ATMlib will have no sound. This problem has been fixed but has not made it in to the public library yet. So you would need to download and replace the library files in the /src folder manually.

1 Like

for some reason my PC is no longer recognizing the Arduboy. it doesn’t show up in the ports, and the yellow light doesn’t flash on the unit when plugged in, though it still charges. I haven’t done anything other than open it up to look at the speaker since the last flash. it doesn’t come up when I connect to Android either.

Note that Arduventure (and some other recent games) disabled USB support in play mode and make Arduboy undetectable. USB will only be available for about 8 seconds when you press the little reset button left of the micro USB port.

1 Like

I edited the file as shown here: https://github.com/TEAMarg/ATMlib/commit/28afb549cc98bd4b2c783a42e6592f943d48f33e

do I need to do anything else?