Issues uploading games to Arduboy FX

Hello, I’ve been using the “Arduboy Uploader” to put new games on it, and while sometimes it works - other times it just comes up with “error” and closes. For example this is what happened when trying to upload the new prince of arabia game. I tried both the hex and arduboy files via the Uploader but it didn’t seem to like either. On the other hand - other new games like “Street Racer” uploaded to my arduboy fx and worked fine, so I am not sure what it is I am doing wrong! p.s. I bought my arduboy fx just for playing everyones amazing games so have very little tech knowledge! Any help would be appreciated as id love to play more of these games.

Please make sure you’re using the latest ‘Uploader’- there may have been changes that fixed your problem.
You should uploaded the .bin data first, then the .hex file.

The version I’m running is Arduboy Uploader v1.4, it says on the page thats the “latest” version, unless I’m missing another version thats elsewhere. The uploader in question only allows .hex and .arduboy file-types, so unable to select the .bin - thanks for taking the time to reply though.

Which uploader are you actually using?

There have been several ‘uploaders’ over the years written by different people, and some are very out of date.

i got it from here : Release Arduboy Uploader v1.4 · eried/ArduboyUploader · GitHub

please, help. I have the same problem. PrinceofArabia.hex won’t load. how to download bin file?

@romkahilton are you trying to use the Arduboy Uploader V1.4 by @eried ?

If so, it was developed before the FX and I am not sure if it will work with a .hex and .bin.

Are you using a genuine Arduboy FX or a home made device?

If it is a genuine device, the easiest way might be to download the cart from here.

When you download the cart (by pressing the ‘download bin’ option in the top left corner), you will see the following instructions. Follow them :slight_smile:

If you have something other than an original FX device, it might be easiest to recompile the game yourself. Assuming you already have the Arduino IDE installed, follow the instructions to installe the HomeMade library and the second set of instructions for installing the plugin that creates and uploads the bin file.

You can then download my code and recompile with your device settings… Easy (maybe)!


FX data uploaded successfully,
But many errors ’ is not a member of ’ FX ’

Looks like your Homemade package is outdated and doesn’t have the most recent Arduboy FX library.

Make sure you have the latest Homemade installed. Go to Tools >board manager, in the search field enter Home and search then update the package to 1.3.8

1 Like

I removed the arduboy libraries from my documents folder. the game loaded, the music played, but the image is incorrect.

Unfortunately, I cannot see the video as ‘This video cannot be rendered because your browser does not support the codec.’

When using the IDE, you need to do two things:

  • upload the FXData (Tools > Build and Upload Arduboy FX data)
  • upload the game itself (Sketch > Upload)

were these both successful?

I am assuming so as you said you had sounds and they only exist in the fxdata. However, did you do them one after the other? The order is not important.

Do not simply ‘Upload existing Arduboy FX Data’ and then recompile the game. I understand that the two are a ‘matched’ pair so not sure this will work.

1 Like

yes, build and upload first, then compile the sketch

Hooray!! I did it!! I re-downloaded the source code. Thank you very much!


I can’t install pillow. please tell me what can i do with it

python pip install pillow or python3 pip install pillow depending on what version of Python you have installed.

Python 3.8(64-bit)

Try using the command python3 instead of python then.

python3 is not an internal or external command, operable program

this problem is also in python3.11.2

try just:

pip install pillow

or run cmd with admin privileges and try

python -m pip install pillow