Just want to play a game [Solved]


(curly) #1

downloaded team args installer , says theres a problem with the program and it needs to close

downloaded arduboy manager says its uploading to a different port than my arduboy is on

arduboy found com6 , then i click a game to transfer, a bit later it says transfer to arduboy at com 7 complete

there is not an arduboy at com 7, there is a flashdrive that i have to run all my programs off of at com 7


(Kevin) #2

Let us know a little more about your setup, are you on Windows?

Have you downloaded and installed Arduino yet? You’ll need to do that step first because the drivers are needed which get installed at that time.


(curly) #3

yes i did that, i am on old windows (vista)

but i run arduino off a flashdrive as this old pc isnt mine

i do appologize for being a … … not nice about issues that are not your fault

within arduino i have installed all libraries for arduboy, i was more so angry beacause the first few i tried to manualy install didnt work, first off the oregon trail like game, was kinda sad about that one but i expected that to take some playing with

the next 2 games also had issues with the code being available but not one or more dependant files

that being said i do have a few games ive goten to work now so i wont die… though i do wish i had the game that came pre installed back :frowning:


Arduboy Manager 2.0 Released!
(Holmes) #4

I’m glad you got some games working on the Arduboy through the Arduino IDE. Because the complexities of the code, I created the Arduboy Manager to help make it easier for people like you. I hate that it didn’t work on your current set-up. It’s great to see that you’re so excited about your Arduboy! :smiley: But can I ask if you can test this on another PC without running the software from your flash drive? I’m curious if you get the same issue with other PC’s.


(Scott) #5

If you give us more details and post the error(s) you’re getting, including what sketch you’re trying to load, we may be able to help.

Have you tried to follow the Adding programs guide?


(curly) #6

Circuit Dude ~ i would like to add that the link i found to this game took me to a web bage containing nothing but the CircuitDude sketch, so i dont know where to fing the ARd.Bitmap.h file for it
Arduino: 1.8.1 (Windows Vista), Board: “Arduboy”

Build options changed, rebuilding all
F:\arduboygames\CircuitDude\CircuitDude.ino:39:23: fatal error: ArdBitmap.h: No such file or directory

#include <ArdBitmap.h>

                   ^

compilation terminated.

exit status 1
Error compiling for board Arduboy.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

CascadePath, the game uploads with “no errors” but when i look at my arduboy the stuff on the screen rolls by faster than can be read, and it appears im seeing double atleast


(Gavin Atkin) #7

@JO3RI have you come across this error before?


(Kevin) #8

This typically happens when you open the .ino file and Arduino complains that it needs to be in a folder that is named the same as the .ino file. Arduino then asks if you would like it to do it for you… but you should never click yes. It will move only the .ino and not any of the required files along with it.


(curly) #9

that is not in this case, i know for a fact that i did not download that file as the only file i could find was the ino

but for the record i never clicked yes anyway beacause i assumed that it would only move the 1 file and i may not want it to be where it is moved to


(Kevin) #11

Can you take a look at the folder contents of the .ino and let us know what’s in there with it? Screenshot can help too if you’re able to.


(Scott) #12

@bateske,
The problem is that the ArdBitmap library hasn’t been installed (as is instructed in the Quick Start Guide). But that was 4 days ago. We haven’t heard back if @curly got it working.. EDIT: Reported fixed in another thread:
http://community.arduboy.com/t/circuit-dude-2-1-awesome-puzzle-game-with-50-levels/2490/100?u=mlxxxp


(curly) #13

all apologies for making more than one thread about basicly the same thing, and for not clarifying that the problem was mostly solved, the game loaders i cant get to work but i an still ise the arduino ide to load them