Mac OS X El Capitan no longer recognizes Arduino Leonardo usb


#1

Just picked up an Arduboy at the Bay Area Maker Faire. My daughter is excited about programming it.

Unfortunately, Apple has recently instated a rootless security system that requires “signed kexts” for all USB drivers. So far I have been unable to get the Arduboy to show up as a serial device. I assume the problem is related to the new requirement for signed drivers.

It appears that the Leonardo/atmega32u4 does not use an ftdi or a prolific usb chip which do have signed usb drivers available for the Mac. The Winchiphead CH34x series of usb interface chips don’t have signed drivers available at this time and as such are now “bricked”.

I am reading that we should not expect the folks over at Winchiphead (www.wch.cn) to release a signed driver for the Mac anytime soon. My suggestion is that the next generation of Arduboy’s keep this in mind and upgrade to a Mac compatible ftdi or prolific usb interface.

I am not familiar with the current usb chip in the Arduboy/atmega32u4. Is it in fact based on the Winchiphead CH34x?

My intermediate solution will be to dig out an old MacBookPro that runs OS 10.5. Not sure if the latest version of Arduino IDE will be compatible.


(Andrew Dent) #2

Also just hit this problem :-/


(Scott) #3

There’s no separate USB chip on the Arduboy. The ATmega32U4 processor has its own built in USB capability, which is what is used.

The Arduboy appears to your computer as an Arduino Leonardo. Here’s some information on using the Arduino Leonardo with a Mac.


(Liam) #4

same just hit this problem :frowning:


#5

Thanks but that is old information. The Leonardo shows up when using iOS 10.9. The new security system In OS 10.10 and 10.11 do not recognize the Leonardo.


#6

@gweep I have no problems at all with OS X 10.11.5 and arduino IDE 10.6.9

I didn’t install any drivers, but I added the board like explained here: Quickly add the Arduboy & Arduboy DevKit to the Arduino IDE

I think you have a different problem:

  • did you put your arduboy on ?
  • are you using a data usb cable and NOT a power usb cable (nokia phone cables are the worse)

take a look at this chart: A flow chart I like to use when things break


#7

Just added the latest security update and rebooted twice. Arduboy now shows up on MacPro with OS 10.11.5 and MacBookPro with OS 10.10.5. Apple must have added some functionality to their internal drivers. Still having problems with other USB devices without signed kexts.

Also had to re-install the Arduino IDE to get the Leonardo code to compile.


(Ross) #8

Leaving this open as this seems like others may run into something like this. Thanks @gweep for the follow up.


(Cabelhigh) #9

Running into this problem right now on El Capitan 10.11.5. Brand new Adruboy works out of the box and even connects to Mac with the red light on (though it eventually goes off) but doesn’t show up as a port in Arduino. Any ideas on what would solve it?


#10

Trying a fresh install on my new MacBook, using Arduino IDE 1.6.12 and macOS 10.12
with USB-C to usb and …

it just works …


#11

Hello,
Is the power of Arduboy is ON?
Does it directly connected to USB cable to the Mac? (not use USB HUB)
Have you tried another USB cable?


(Cabelhigh) #12

Oh it’s gotta be ON? :0


#13

Arduboy Serial port is not visible from the Mac If you do not turn on the power.


(Cabelhigh) #14

Well I sure feel like a big dumb idiot! Thanks everyone!


(Nestor Mata Cuthbert) #15

Hi, did anybody has any other tips for this?
I just got my Arduboy today.
I’m using El Capitan 10.12.1 and the IDE doesn’t finds the port.
I’ve being reading all around about how to fix it.
I disable the SIP completely and nothing yet.
I went to buy a new USB micro cable, a strong one, making sure is not just for charging.
Tried with the Arduboy on and off.
Nada, none, zero.

Help please!


(Holmes) #16

Are you connecting the Arduboy through a USB port in the Mac or in another device like a USB hub or your keyboard?


(Kevin) #17

Have you installed Arduino software yet?


(Nestor Mata Cuthbert) #18

I’m connecting the Arduboy directly into the computer port, no hub.
When you mean the “Arduino software” you mean the IDE?
Yes, I installed the IDE, although it was not actually “installable” it was more like “move the app into applications”, but yes.


(Nestor Mata Cuthbert) #19

Here is more info about what I’ve done so far:

  • I connected the Arduboy to my Mac and followed all the start guide steps. The only port that showed in the IDE was the Bluetooth port.
  • After that I’ve read every possible related information on the community and more general Arduino articles and discussions.
  • FYI I tried with the Arduboy on, then off, then turning it on while the IDE was opened, then setting on before opening the IDE, even tried turning it on before turning the computer on.
  • I connected it to another Windows Laptop and the port shows gray out, disabled.
  • I went to buy a new USB micro cable and repeated all the proceses from scratch on both Mac and windows computer… nothing
  • I set the SPI disable for kexts
  • I set the SPI disabled completely
  • I installed a double booth in my Mac to start as Ubuntu (resized partitions, followed articles on how to install it and modify EFI to double boot and all that)
  • I went to buy another different cable in another store, again asking for a cable not for charging, but for data transmission.
  • I tried again on all 3 OS’s on the 2 computers and nothing.
  • I also tried the “reset” button in the arduboy, and it never changed lights or anything, all the time it was only the red light on, no change or anything.

At this point I’ve tried with about 7 different cables, old and new ones, tried with Mac El Capitan 10.12.1, Windows 10, Ubuntu 16.04 and nothing.

Is there anything else to try? or is just that I got the lucky of getting a non working Arduboy?

Please help.


(Nestor Mata Cuthbert) #20

Please help, I’m really frustrated.
I got my Arduboy yesterday, I’ve wasted money on cables, spent 2 complete days on it, double boot my computer, tried in every possible way, disabling every security thing, tried everything.

I don’t know what else to do, I’ve not even being able to start to use my Arduboy.

Thanks in advance