Made my own slimboy Any suggestion?

I made a slimboy (not so slim) with arduino nano just got into arduino and stuff, stuff arrived about 3 days ago after some troubleshooting i managed to upload breakout that was in the examples but now i cant upload any other games, can you tell what games might be able to run on arduino nano.


Nice clone!

You will have to use this library: GitHub - harbaum/Arduboy2: Arduino Nano port of the Arduboy miniature game system

The Arduboy is designed for an ATmega32u4, not an ATmega328p like on your Arduino Nano.

omg shawn liked my post im a big fan i found your channel randomly one time then i remembered about you when i was watching the retro future and then later i realized you’re actually here :flushed:

1 Like

Have you tried activating ‘flashlight’ mode?

  • Turn the console off
  • Hold the up button down and don’t let go
  • Turn the console on
  • Let go of the up button
  • Try to upload a new program

yeah, that doesnt work, it doesnt go into flashlight mode, i’m using harbaum’s slimboy library i can upload to it anyways, from the examples like hello world and button tester thingy and yes the up button works, whenever i try to upload a code from arduino ide it shows some error LIke COM7 not declared or some power state error, i read on a form that this may be because Atmega328pb doesnt have some sort of analogue controller or something, i was wondering if it would be possible to modify the games’ code to use the existing analogue pins? If not what other games would work on arduino nano

yes, i use that library and i saw game untitled platformer and tried uploading it and it uploads w/o any problem, hope you complete it asap

A few people have been down this path before you. Its just so much easier basing your system on a Leonardo or Pro-Micro rather than a Nano.

to be honest, i ordered nano by mistake :smiling_face_with_tear:

1 Like

Are you sure you’re using the right COM port?
The device will change COM port from time to time.

You can check by going to Tools then Port, and if your board has an active serial connection it will appear on the list.

my bad, it said PortC7 not declared not COM7 :melting_face:

‘PortC7’ or ‘PORTC7’?

That sounds like you might be describing a compiler error, in which case that’s a problem with the code or one of your libraries, not with the device.

I.e. it’s not an upload problem; your code isn’t actually compiling.

yes, i think so but when i compile it for arduino leonardo it says success but when i compile for nano, it spits out 800 lines of error :slightly_smiling_face: the game code is of Virus LQP-79

That game probably won’t work because it was written for the old Arduboy library, not the Arduboy2 library.
It would likely have to be modified to use the Arduboy2 library.

I think the biggest problem with the Nano will be that it has less RAM than a Leonardo. Many of the more complex games will likely use most of the available RAM.

See the Leonardo has more ‘Memmory’!


And… i donno how to code to i’ll just make another arduboy with pro micro. I was wondering how do you figure out which version do we have, the standard wiring or the alternate, and can i flash its bootloader using Arduino Nano?

Not sure what you mean by this. Are you referring to @Mr.Blinky 's homemade package by any chance?

I’ve done it many times with my Uno, no reason it shouldn’t work with a Nano.

1 Like

I had the exact same issue. Even the game was same. Your nano’s bootloader is probably corrupted and only working way I found was using another arduino to re-burn bootloader to nano.

After that it worked fine, I even played ardynia and arduventure on it.

This post has a link to tutorial: