Mini Rogue [Unofficial Game Jam 4]


(Stephane C) #62

I saw that… Ideas are coming already. :wink:


#63

Thanks for counting them for me :slight_smile:


(Stephane C) #64

Latest delve I made on Hell difficulty


#65

Has anyone tested the newest .hex? I’m trying to upload it and after flashing I just get whatever was already flashed.

To be clear I’ve tried crait’s and team args uploader and currently have the breakout demo flashed


(Simon) #66

I am at work at the moment so cannot test it but @vampirics was able to load the latest version late last night so I am confident it is functional. Although not a definitive test, you can play the HEX online so it must be (somewhat) valid.

https://felipemanga.github.io/ProjectABE/?hex=https://raw.githubusercontent.com/Press-Play-On-Tape/MiniRogue/master/distributable/MiniRogue.ino.hex

When you attempt to load it, do you see the TX/RX leds flashing at the bottom of the unit?

Is it possible to compile the source code and upload the HEX using the Arduino IDE?


#67

Trying to upload through the Arduino IDE give me an error for #include "../utils/FadeEffects.h" No such file found.

It’s weird, the led’s light up and the uploaders give a successful message and then the arduboy reboots to what was already flashed.

I just re-downloaded the hex and tried again and it uploaded fine so idk what was up this that :potato:


(Simon) #68

Had you compiled the source code before?

The changes I did last night was to remove the fade effect and change the little ‘press play on tape’ image. If you had compiled the code previously, the compiler may have been linking components from the previous compilation to the changed assemblies in the current one. I have had this issue when refactoring code and often delete the contents of the ‘build’ directory to ensure this doesn’t happen.


#69

No this was a fresh download of the source.

The BaseState.h was last updated 4 days ago. I think there’s a number of files that need to be updated as EventState.h has the same import. I haven’t gone farther than that.


(Simon) #70

Ha! I was a victim of exactly what I said two posts ago. BaseState.h, EventState.h and a number of others had the include but as they had not changed they were not recompiled and the compiler linked older versions of them into the resultant HEX.

I have fixed the source and republished to the repo.

Thanks for pointing this out and I am glad you got the HEX to work.


#71

How do you remove the game? I’m not able to get the game off via flashlight mode. Do you have to use the reset button perhaps? Can’t get the Arduino IDE or the Arduboy Manager to detect the Arduboys port at all.


(Simon) #72

Quoting myself!     


#73

Thanks, I was looking through the comments and didn’t see this part.


(Nicole Birgel) #74

Finally, finally i got time to play it. Just as i feared: It is very addictive, will take my arduboy with me tomorrow and hope for a long break at work😆


(Simon) #75

Thanks @Nicole_Birgel it is quite simple but does the job!


(Nicole Birgel) #76

It reminds me of the card game boss monster which i love very much but no one wants to play with me…


(Stephane C) #77

I have that one too, been a while that we played it.


(Holmes) #78

The graphics look so good and animations are smooth. I have not had the time to sit down and play this for an extended period of time, though, which is why I have not responded to it, yet. Will try to play it, tonight, though.


(Stephane C) #79

Thank you! I am glad some people seem to like it.