My arduboy build


(Scott R) #21

Forgot to add this is the older wiring
What do you have pin 1 (cs) wired to?


(jon yakowec) #22


I ended up wiring wiring up a second chip and took my first attempt out and I’ve still got the same problem. I’m thinking I don’t have my wiring right. I have the chip powered directly off of the micro’s 3.3v


(jon yakowec) #23

I have cs running to rx on the micro


(jon yakowec) #24

I just moved cs from rx to sda but no luck. My problem must be someplace else in my wiring.


(Scott R) #25

Just to be certain your not using an older version of cathy3k you might want to flash the bootloader whilst you have CS on SDA you may want to reflash the bootloader.

bootloader with new wiring scheme


(jon yakowec) #26

Ok thanks, ill try flashing it again. Maybe with a little luck that will work


#27

There’s also a hex file (uses Rx as CS) you could try.

Note that SDA support is currently only in the source files and not yet in the install package so for resolving your issue you’d better stick to Rx for now.

Thats normal. It will show when the flash chip is not detected or not initialized.

At first glance your wiring looks ok in your image. did you check for shorts?
What is the exact part numer? some versions are factory defaulted to DPI / QPI mode.
You could also try and add a .1uF cap between the chips Vcc and GND

I’d try to get the sketch running first though.


(jon yakowec) #28

I got it going. It looks like the first 2 chips i tried were faulty. I wired in a 3rd and was able to load your example bin on it. I added a bunch of games and png’s to the example flashcart folders then opened the .cvs file with notepad++ and typed in the extra games and png’s then saved the file. I then dragged the .cvs file to the flashcart-builder and it made a new bin for me, i loaded the bin with flashcart-writer but when i go into the games on my arduboy the only ones there are the games that loaded with the example bin. The games i added aren’t there. Any ideas on what i did wrong?


(jon yakowec) #29

These are the chips i got. https://www.ebay.ca/itm/5pcs-NEW-W25QFV128FVSSIG-W25Q128FVSIG-25Q128FVSG-25Q128-SOP-8-IC/172109735150?hash=item28128a24ee:g:6KcAAOSwMKpUaYKr:rk:7:pf:0


#30

did you also add a (new) list(group) number in the first column? If you used an existing list number. They games should be under that list. The flash-builder also outputs a list with sizes. Were the games you’ve added listed?

Edit:

25Q128FVSG are fine (If the last symbol was a Q the QPI mode was enabled)


(jon yakowec) #31


This is what i did. I assumed that each list number represented one of the category folders. I didnt get a list from the flash builder all i got was a bin file.


(jon yakowec) #32

I just checked the bin file i made in notepad++ and its blank, i definatly did something wrong.


#33

run the script from a command line (open cmd drag drop script, select cmd window type space, drag drop your csv, press enter) and see what error you get.

Edit:
You left out quite some semicolons " ;" which I doubt the tool doesn’t like (missing empty fields)


(jon yakowec) #34

I got a index error: list out of range. The semicolons i failed to add would they go at the end of each line after the hex?


#35

That’s because of the missing semicolons. Yes on each line including the top. They are used as cell seperators. How many depends on which version of the builder your using. Have a look at the sample csv file that was included. remember that you need an extrqa semicolon on the category/title screen lines

Edit:
A quick and dirty way would be adding 3 semicolons on each line.


(jon yakowec) #36


I added the semicolons at the end of each line and ended up with the same error. Did i put them in the wrong spots? My apologies im really new to all of this.


(jon yakowec) #37

Capture7
This is what the sample cvs file looks like that i downloaded.


#38

which version of the flash-builder do you use?


(jon yakowec) #39

I think its the newest version. I downloaded it a couple weeks ago.


#40

Then there should be a total of 4 semicolons on each line
one after List
one after title(discription)
one after title screen
one after hexfile

If there is no hex file you have two after the title screen (so you get a total of 4 on such a line)