New Maycar Arduboy clone has struggles

Hi- my Mum and I are trying to get my new Maycar arduboy to work- it was one we assembled. To start with it was ok- we followed the guides and got it to recognise the port, and run the example ‘hello world’ Sketch. Then tried to upload a new game, and now nothing is working. We think we have got the sketch correct into the sketchbook, as when we verify the sketch, it looks ok. But it no longer recognises the port when we connect the arduboy. We looked at the how to reset the dev kit instructions, but the photos that demonstrate the places to short won’t load, so we can’t see the pictures. Have tried viewing in various web browsers- chrome, safari etc, but can’t see the pictures. Nothing shows on the arduboy now, just a blank screen no matter what buttons we press. We are depressed by this- have fiddled for hours, so any advice would be great.

Are you in Australia somewhere? This is from Jaycar, right?

Can you share the URL to the dev instructions?

Anyhow, isn’t there a reset button on the top left of the unit? If you press that just as you are about to upload, the unit should go into a reset mode where the IDE can pick it up.

Failing that, have you tried flashlight mode?

1 Like

Hi, thanks for answering. Yes, from Australia and it was from Jaycar. There was no URL provided re dev instructions, sorry. It was literally just instructions to screw the thing together, and no other operating instructions. Is the button to the LHS of the screen a re-set button? When we press it, a light labelled ‘Game’ pulses. We have tried that, but didn’t make any difference as best we can tell. Have now also tried the instructions re flashlight mode, but no lights went white- maybe that mode doesn’t exist on the Maycar one?? The main problem at present is that Arduino won’t recognise the arudboy when we connect with the USB- doesn’t show up on the port options. It DID initially, and that was when we successfully completed the ‘hello world’ task. We then tried to upload a new game- the Arduino program said upload was successfully, but at that point, the handheld arduboy stopped doing anything, and since then port not recognised etc. We have tried a couple of games, tried exiting and rebooting Arduino program, and turning the maycar unit on and off (guide said for a dev kit version it should be off when connected to laptop for the port to connect). No luck…

further to last, in case I misunderstood you- here is the URL for the dev kit reset instructions we were hoping to follow, where we couldn’t see the photos How to Reset the Dev Kit

I am in Aus too (Melb).

I have a very similar looking unit from ‘keyestudio’ - a Chinese manufacturer who probably builds them for Jaycar. Anyhow, on mine, the button seems to reset the device (well the screen goes black and the game button flashes).

For the record, the device needs to be on when flashing the next program to it.

I have plugged mine into my Windows machine (are you using Windows?). It was not recognised in the Port menu. I pressed the reset button and for the next couple of seconds, I left the port menu and then re-entered it (allowing the ports to refresh). After a couple of tries, the port came up and I quickly selected it.

I just flashed a game to mine. It is one that then disables the USB stack and makes the loading of the next game really hard. When I attempted to upload the game it failed. When I then pressed the reset button when the IDE said ‘Uploading’ and it worked fine.

If all else fails, @MLXXXp has investigated the board very thoroughly. He might be able to shed some light on the reset button and why the flashlight mode doesn’t seem to work.

1 Like

Thanks, playing around with the reset button I can get Arduino to recognise the port, and when I upload, the Arduino system says the upload has happened ok, but the actual arduboy console itself still does nothing at all. Screen blank, no response etc.
PS I am using Mac OS. Also, do these Jaycar modules make any sounds? It seems these Arduboys should, but this one didn’t make any sound, even at very start when it was playing the default preloaded game…

@Villager_guy135,

What you have is not a DevKit, so you can disregard anything to do with that.

As @filmote has assumed, the Makerhub DuinoBoy/maycar appears to be a repackaging of the Keyestudio GAMEPI. Note that this item is an Arduboy clone. It’s not sanctioned or supported by the Arduboy company.

The discussion of GAMEPI in this forum is here:

Looking at the photos, it appears there are some differences between the maycar and the original GAMEPI. The GAME and RXD LEDs are swapped and the maycar has a through-hole ICSP header whereas the GAMEPI only has pads on the back. (Although, in the maycar assembly instructions the photos of the circuit board appear identical to the GAMEPI but the photo of the front of the assembled unit is the different one.)

@Villager_guy135, would you be able to take a clear photo of the back of the circuit board so we may be able to see if there are any other differences?

I’ll try to help with your problems and questions in the next post.

1 Like

This is not true. The unit can be either off or on when programming.

If you haven’t, it would be a good idea to set the Arduino IDE to report more detail during upload. The messages may tell you something and it makes it easier to time the pressing of the reset button.

  • From the IDE menus select:
    File > Preferences
  • In the Preferences window, set a check in the box for
    Show verbose output during: ☑ upload
    (You can also check ☑ compilation if you wish to see more info when the sketch is being built.)
  • Click on OK at the bottom right.

Assuming the GAME LED still pulses when you press the reset button, and you can still use it to successfully upload a sketch, please try the following sketch. It should display the ARDUBOY logo, which will remain on the screen, and the TXD LED should flash continuously at 250ms on, 500ms off.

// TX LED blink test

#include <Arduboy2.h>
Arduboy2 arduboy;

void setup() {
  arduboy.begin();
}

void loop() {
  TXLED1;
  arduboy.delayShort(250);
  TXLED0;
  arduboy.delayShort(500);
}

Depending on the result, we’ll go from there.

Yes, there is a speaker on the board but it’s only connected to one of the two pins that the Arduboy uses, so some sounds will play while others won’t, depending on which pin(s) are used. Also, there is a volume control. It’s the small potentiometer marked R28, to the right of the main chip. You can turn it to change the volume using the included screwdriver inserted through the hole in the back panel.

1 Like

Hi, I am trying to get what I think is a dev kit version of Arduboy to work. Bought it from Australian Jaycar company: https://www.jaycar.com.au/makerhub-duinoboy-build-a-game-learning-kit/p/XC3752
(the big square chip is in the middle of the back panel).
When we first assembled and turned on, it worked ok with Castle Boy already loaded (but no sounds)- do these things have sounds??
I followed all the instructions on loading Arduino software, libraries etc etc, and successfully uploaded the Hello World example. Then tried to upload a game (JetPac), and since then the screen is blank, and it does nothing. Also the port wasn’t recognising at that point either. Have fiddled around with what I think is a reset button (top LHS beside the screen). That can get Arduino to recognise the port, and have tried uploading various things including going back to the safe examples, but nothing is working. I found this article, but the photos don’t load properly, so I can’t see what I’m meant to be shorting. Have tried loading this article in chrome, safari etc but the pictures aren’t there. This has been a really rubbish introduction to this whole platform for my young son and I… :frowning:

Moderator’s note:
I have migrated the above comment from the afforementioned devkit topic as it is unrelated to the devkit and it makes more sense to have that information in this topic.

This unfortunately makes the information appear slightly out-of-sequence,
but should help to keep the related information together.

1 Like

Just to check, in the Arduino IDE what board do you have selected?

If you look in the bottom right corner it should say either “Arduboy on <port name>” or “Arduino Leonardo on <port name>”.

This is to rule out the possibility that you might have tried to upload for a different type of board,
which may explain why your board is no longer functioning properly.


Ultimately since this is a 3rd party clone and not an official Arduboy our hands are tied slightly.

Ordinarily if we couldn’t find a solution then we’d advise you to contact Arduboy Inc to either have your Arduboy fixed or replaced,
but since this isn’t an Arduboy Inc product you most likely don’t qualify for that kind of support.

1 Like

https://www.jaycar.com.au/makerhub-duinoboy-build-a-game-learning-kit/p/XC3752

LOL someone had that Chinese company rebrand it for them.

The Arduboy is mutating.

How did you go with this @Villager_guy135 ?

yahh it’s $59.95 (

Or the original is currently $17.99

And that’s $59.95 Australian dollars, which currently is about $38.40 US.

original is currently $39 )

concerning the $17.99 and $59.95 for the same
it reminded me of an old joke: a man walks around the market and looks at the price of chicken. $5, $5, $5, $50!

  • $50 per chicken? Why so expensive?
  • I really need money

It’s sad to see ugly knockoffs retail for the same price as the original, while the company who made it all happen is struggling. Doesn’t seem like the knockoff makers offer any customer support, either. Just how it is I suppose :slightly_frowning_face:

2 Likes

Which is precisely why the original is better value for money.

It’s also easier to get voluntary help for the original because a large number of us know exactly what pitfalls to look out for and what advice to give.


Another sad thing is the thought that some people might take the poor workmanship of a badly-made clone as a reflection on the Arduboy itself.

It cannot be stressed enough that any experience with a 3rd party copy should never be taken as being applicable to the original.

1 Like

Buy more (official) Arduboys

5 Likes

I personally think those (overpriced) clones should drive more official Arduboy sales. If I didnt knew about the Arduboy and buy the shitty clone, after a while, if I actually use it, I will want an official one.

@Villager_guy135 don’t you want know your mom to return that clone and order the genuine one?