Non-responsive Arduboy. Red light charge, but that's it [Solved]

The chinese chargers are so cheap and reliable that I wouldn’t risk anything doing a hack like that.

3 Likes

I think you mis-understood my suggestion. I’m not suggesting I use the super cheap Chinese charger from the quadcopter. I’m saying that maybe I wire up a 3.7V LiOn battery that is charged, in parallel with the Arduboy battery. Effectively giving it a battery backpack.

Then, use the Arduboy circuitry to charge this new ‘twinned battery’ - allowing me to charge the depleted one.

I do this with AA batteries which are “too dead” to recharge in my La Crosse charger. I jumpstart them with a charged battery in parallel - then the charger decides, oh yeah – there is a battery here so I’ll try to charge it.

Yeah - probably not the safest thing to do, but it has let me rescue really dead recharge-ables in the past… and they’ve acted fine for some time after that.

1 Like

oh I see. Yeah that might work :smiley:

1 Like

More like 4.2V

If you try this, you’re almost literally playing with fire. LiPo batteries need their current and voltage limited when being charged. Connecting a charged battery directly in parallel with a discharged one, without any limiting circuitry in between, can cause heavy current to flow from the charged cell the to discharged one. This could cause the discharged cell to overheat and possibly catch fire or explode.

Lithium batteries aren’t as safe as NiCad or NiMH batteries. They have strict charge and discharge requirements. This is why a protection circuit is included on the Arduboy.

1 Like

Batteries are also fun to microwave.

(I am probably supposed to say that you probably shouldn’t try this at home. Probably.)

1 Like

Here’s a simplified version of the idea of bypassing the battery protection.

You can just disable the discharge protection (and keep the overcharge protection active) by temporary shorting pins 1 and 2 of the FTD2017 chip (see image)

  • If you turn on Arduboy and short the pins Arduboy will come to live (unless battery is deep discharged < 2.7V)
  • Now connect the USB cable to charge and short the pins again. Arduboy will power on again.
  • after a while remove the short and see if Arduboy stays on. If it does it’s charging normaly again,
  • if it doesn’t, short the pins again for a while and repeat the process.

To short the pins you can use a test pin, pin from a jumper wire, header pin, etc.

2 Likes

Thanks @Mr.Blinky that’s very cool. However, it only seems to partly work for me.

Turning on the Arudboy and shorting the 2 pins you indicate does cause the Arduboy to power on.

Adding the USB cable to charge, and watching the voltage at the battery connectors - just shows the battery slowly dropping. The red charging led is ‘on’ while this is happening.

Unfortunately at this point, I’m getting very close to ‘deep discharged’ on the battery.

It bothers me that while charging, I’m not seeing a higher voltage at the battery at all.

[Fun fact - it is indeed Mystic Balloon that is on this particular Arduboy]

My other Arduboy is measuring basically 4V when I test the battery. Adding the USB cable bumps it up a tiny bit, but it isn’t clear if this is the charge voltage - or just the battery voltage tweaking up a bit.

I need to run the battery down a bunch, and verify how charging works with the ‘working’ one.

So - I think I can confirm.

Arduboy off.

Working Arduboy - battery test. 3.84V
Working Arduboy - USB charging - battery test. 4.01V
Remove USB cable, battery reads a bit more than 3.86V (it charged a bit?)

Busted Arduboy - battery test. 2.855V
Adding USB changes nothing.

Turning on the busted Arduboy, USB cable attached.
I can jumper the FTDI chip to bypass discharge protection and I see game start up… but voltage drops on battery. Fairly rapidly - a few seconds and I was at 2.6V

Leaving the USB connected to the busted Arduboy… it creeps up to nearly 3V over a long long time (trickle charge is happening?)

Unfortunately I’m still stuck here. I can’t seem to get a ‘charging’ current to flow to the battery on the busted Arduboy - I’m expecting to see ~4V on the battery when it is charging, but that’s not happening.

FWIW - this is sort of fun.

A depleted battery voltage wont just jump up to 4V immediately it will slowly rise.

Did you try bypassing the protection circuit completely and see if the voltage increases? you can also bypass the battery protection by shorting pins 1 and 2 and pins 7 and 8 simultaniously on the FTD chip if connecting the battery minus terminal to the micro usb shield is not easier.

As you said this is kind of fun. I’m kind of playing with the idea to hook up a worn 18650 cell from old laptop battery packs to my Arduboy and see how it behaves.

I’ll have a look on the charge controller datasheet and see if it can be of any help.

Edit:
From page 13 of the Datasheet:

4.4 Preconditioning
If the voltage at the VBAT pin is less than the
preconditioning threshold, the MCP73831/2 enter a
preconditioning or Trickle Charge mode.

The STAT output will be LOW in trickle charge mode. so the LED will light up in trickle charge mode too. So it could be your Arduboys stuck in this mode? Leave it on charger for a week :smile:

1 Like

Here is my concern with the GND <-> Battery (-) connection.

When I did this Non-responsive Arduboy. Red light charge, but that's it I noticed that the battery voltage was dropping.

To recap:

  • Arduboy off
  • Connect GND and Battery (-)
  • Connect USB charge (5V wall wart)

As far as I could tell, this was causing the battery to drain… not charge. I’ll certainly try again.

Not sure how I missed that post. I can understand how the battery would drop when Arduboy was powered on but not when it was switched off.

Have you tried connecting the USB cable to a laptop or powerbank instead of the wall charger?

I’ve used both my desktop machine which seems to provide a nice solid 5V USB output, and a wall wart which seems to give out 4.97V.

I’ll try a slightly beefier wall wart to see if that makes a difference, and repeat the experiment with the GND to Battery (-) hack and give it a solid 5 minutes of charging (with the Arduboy switched off)

I suppose, I could also try the same experiment with my working Arduboy (after I drain it a bit) to see what happens there too.

If your next attempt doesn’t change anything. You can try @bateske idea to connect 5V directly to the battery. But I would suggest using a 4,7 ohm / 5W resistor (one of those ceramic ones if you have one) in series so the charging current is limited.

FYI

I’ve drained my Arduboy in Flashlight mode. When it turned off I switched power off waited for a minute, switched it on again and drained it again in flashlight mode. I repeated this process 3/4 times until Arduboy wouldn’t turn on again. Then I disassembled my Arduboy to meassure the voltage at the battery terminals. I meassured 3.15V. I switched Arduboy on and it wouldn’t turn on as the battery is depleted of course. But as soon as I inserted the USB cable it powered up instantly. Measuring the the voltage again it was at 3.31V

From what I remember (I’m sorry I still havent found time to dig up documentation) but the battery protection should kick in at 3.2v and I think 3.15v is probably within tolerance.

I’ve been doing similar tests and been unable to repeat the problem. I’d really like to get my hands on one of these failed units to do some more test let me know if anyone has this problem I can get a return shipping label sent out.

2 Likes

@bateske - you and the Aruduboy team are really above and beyond expectation. Sure, the price paid for them is a bit ‘premium’ - but this is a low volume product. I’m also old enough to have owned personal computers with far less computing power than the Arduboy.

Now, this is one of the original 1 of 10,000 kickstarter units. I’m also in Canada. If you want to get this failed unit back from me, I’m willing to send it back. However, if the location or age of the unit make it less interesting or valid, that’s cool too.

So - this is probably basically what happened to my “busted” unit. My little guy was playing Mystic Balloon. It probably ran out of juice. He would have left it for a while (because, yeah teaching my kids to recharge stuff… well clearly I’ve failed to do so) and then come back to it hours later, turned it on and played it down to failure again.

This cycle probably repeated itself quite a number of times. Until it would no longer come on, even after a ‘rest’.

I’ve been leaving it plugged in to my PC for a couple of days. Trying to see if I can trickle charge it up to the point where it’ll actually charge again… Or maybe I’ll get around to digging in my box of parts and finding an appropriate resistor and wiring the battery directly to 5V.

1 Like

Also - if you have specific tests you’d like to try, I’m game to see if I can perform them for you. Not quite the same as having it in hand, but it’s a thought.

@Roo Can you open it up and check what is the voltage on the battery?

1 Like

I’ve measured and reported on this a few times in this thread.

Today the battery measured 2.773V. I took the measurement with the case removed, and the battery still installed (probes on the battery tabs).