Non-responsive Arduboy. Red light charge, but that's it [Solved]

I can confirm that Vbat is bad joint.

I measured my ‘good’ Arduboy as a reference. Battery (+) and Vbat have connectivity.

Carefully probing on my ‘bad’ Arduboy, I can test the ‘pad’ under Vbat and have connectivity - but if I only touch the leg of the chip I don’t.

I’m going to dab a tiny bit of flux (yes, I have the right stuff for SMD repair) and maybe tin my iron a little and see if I can reflow that leg (I might do the Vss one too). Here goes nothing - tricky as I’m working basically at the limits of my vision.

I think I’ve done it!

After my (almost embarrassing) solder work, I now measure 4.00V across the battery (+) and battery (-) when it is charging via USB. Disconnect and measure the battery, 3.75V.

I need a much finer tip for my soldering iron for work like this - and a jeweler’s loupe, because at that level I was working pretty much by feel.

I’m going to put things back together and let it charge until the charge light goes out.

2 Likes

image

Yes you noticed it to! it looks like you may have fixed it!

If it works, let us know there is a badge for repairing your own arduboy!

4 Likes

Yup - the charge light went off! It looks like I’ve got a fully functioning arduboy!

Thanks to all that participated in this thread - super friendly and helpful.

5 Likes

So, @Roo if you don’t mind inspecting it a little more, I’d like to try and understand why that solder joint didn’t get made.

Does it look like the chip is sitting flush with the board? If you look at it on level, viewing the edge of the pcb, can you see any space between the chip and the PCB? You might try fitting a feeler gauge under one side to tell.

Or does it look like the foot of the chip is bent?

Or 3rd, was there just not enough solder?

So… It probably wasn’t option 3 because even with no solder, the foot theoretically should be touching the pad, or close enough that any solder what soever will bridge the connection.

I don’t really think that it is option 2 with the bent leg… but it COULD be. I don’t really know, I’ve seen this kind of failure on enough units… if this is the cause… then I wonder how could legs all get bent on a couple dozen units? It could be… but my final guess is…

I think it’s possible since this chip sits on the board edge that the pads are curing at different rates possibly pulling up the chip on one edge?

Anyways… so what I’m curious to know if it looks like all of the legs are the same height from the PCB. If the chip package is tilted or if one of the legs is bent. Or if it may just be the picture doesn’t show it was simply insufficient solder.

Thanks so much and nice work!

1 Like

I found intentionally bridging, adding more flux then dragging a large clean tip or using some wick worked best for me rather than trying to solder individual points.
You can make a crude fine tip by wrapping a paperclip into the tip of your iron.

Congrats on solving and fixing the issue

1 Like

Yay! congrats on fixing your Arduboy! I bet your little guy will be happy too.

1 Like

3 more ‘full’ photos.

1 from the broken (and now fixed) arduboy (yellow)
2 from the working arduboy (blue)

Next post I’ll make some snips from those with commentary

image

Above: Side view of the yellow (broken, now fixed) arduboy. You can see the unfortunate solder blob (my fault) on Vbat. The chip appears to be flush to the board.

Above: Pre-repair picture I took, not sure if I shared this angle. This makes it look like the pin was bent.

Above: Blue, working arduboy - for comparison with the 1st shot in this post that shows a side view of the repaired one. It seems like the chip is similarly flush.

Above: Blue, working arduboy. This is a better side-lit version picture of the Vbat. It looks like there is barely enough solder on the joint. The pins also look well aligned.

Above: Pre-repair, yellow arduboy. Same-ish angle as the blue. Harder to tell if the pins are bent here, but the problem is pretty obvious here.

I welcome others to comment on the photos. I sort of wish I’d been able to take more close pictures of the defect to help with this post-mortem.

Fixing the arduboy was almost as much fun as playing them (or making games for them)

Yeah it does look like the foot is bent. My guess is either a reel of components got stepped on / damaged in shipping or potentially even manufacturing defect.

Next time someone has this issue hopefully they can inspect this with a high resolution camera also.

Thanks so much, you earned the badge Epic Repiar!

3 Likes

Wow I never got that badge for replacing the MCU and neither did @eried for replacing the oled.

I guess were not so epic since we both broke them ourselves first :joy:

Is there an epic oops badge?

3 Likes

Epic Repiar :stuck_out_tongue:

3 Likes

I only just figured out how to make badges. You can have one too

2 Likes