Official Troubleshooting Guide

Having problems with your Arduboy? This guide will help! Click the answer to the questions to navigate you through the troubleshooting guide.

If you still are having issues please make a post in the Issues Category or use the Contact Form to get direct customer service.

Did the Arduboy work when you recieved it?

1 Like

Yes, the Arduboy arrived in working condition. It turns on, charges, and I’m able to play the game.

If for some reason your Arduboy refuses to charge or only displays a black screen under all conditions please use the Contact Form to get a hold of customer support.

Are you able to upload a new game?

No, I was not able to upload a new game.

Make sure you update to the latest version of Arduino software.

Have you installed and are using the latest Arduino software according to the Quick Start Guide?

Yes, an up to date version of Arduino is installed on the system.

Let’s make sure the problem is actually the upload and not the compiling of the code.

Are you able to compile the code you are trying to run, independently of the upload?

Yes, the code compiles correctly. I just can’t upload the game.

Nearly all of the time, Arduboy should re-program just fine but it may need some encouragement.

The first thing to try is the Flashlight Mode by holding the up button while turning on the Arduboy. This will turn the screen all white and leave the device in recovery mode. While in flashlight mode, attempt the upload again.

If flashlight mode doesn’t work, you may need to use the Reset Button method to recover the Arduboy. This method is a little more tricky, requiring you to hold the reset button until you see the Arduino software indicating it is attempting the upload. Let go of the button when you see Arduino say Upload.

Has either the Flashlight Mode or Reset Button worked to enable uploads to your Arduboy?

I’m still having problems trying to upload after trying the Flashlight Mode and Reset Button.

There are some ways to test if the Arduboy is correctly connected to the system. A green LED (It’s next to the red one) indicates that the serial connection is being made over the data channel of the USB connector. A USB connected sound should also play from the PC.

When you plug the Arduboy into your computer with the Arduboy turned on, do you see a green light blink in the lower left corner of the Arduboy?

I’m not getting any green LED light to blink, or any USB sound when I connect the Arduboy to the PC

Let’s make sure the USB cable isn’t the problem. There exist in the wild cables that only have the wires to charge the battery, and don’t have data connection. The included cable is often your best bet.

Try using a different cable, one that you can confirm transfers data on another device like a cell phone or hard drive.

Does using a different cable work?

Yes, when I plug it into the PC a green light flashes and it sounds like the computer has detected a USB device.

This indicates that a successful connection has been made, if this is the case you should be able to upload new Arduboy games.

Check that you have the correct port selected and that Arduboy is being recognized by checking in device manager and comparing the port number to the one you have selected in Arduino.



With the correct port selected, are you still having upload problems?

I’ve checked that I’m using the correct COM port, I get a green light and USB connected sound, the code compiles fine on the most recent version of Arduino.

You’re doing everything right! You’re in the realm of undocumented behavior! From the responses you’ve made the Reset Button method should always work, but the timing can be tricky to nail down.

We are terribly sorry but at this stage it’s probably best for customer support to step in, but before we do help us collect a little more information. Nearly all the time it is some silly problem with Arduino, but rest assured your satisfaction is guaranteed, we’re here to help!

Enable verbose on Arduino to tell you more about the upload failure:


After you have collected the error message that is displayed after enabling this setting, please use the Contact Form and let us know about the steps you took and what went wrong.

I’ve tried different cables and recovery methods and nothing seems to indicate a data connection to the Arduboy.

Hang in there, don’t lose hope! We’re here to help!

Were you ever able to reprogram the Arduboy?

I was able to reprogram the Arduboy before, but after one specific upload I haven’t had any more success.

This would be a good time to double check the Flashlight Mode and Reset Button methods, as some games do away with the USB code, making it seem like it cannot be reprogrammed.

A more pesky problem is that using 3rd party tools, or perhaps even a faulty connection, can cause the bootloader code to be corrupted on the Arduboy.

Any luck after triple checking the Flashlight and Reset Buttons?

I can’t seem to get any evidence that the Arduboy is connecting to the PC.

It sounds like either there is a mechanical problem with the Arduboy or perhaps the bootloader became corrupted at some point. Please use the Contact Form to get some direct assistance from customer support.

The Arduboy has never worked since I opened the package.

Whoah! That’s not right at all! Please let us know via the Contact Form and we can for sure help you with that.

It seems like I’m doing everything right, I just can’t get it to work.

Don’t worry! Just write into the Contact Form with your information and we can help. We’ve never had to retire an Arduboy from service yet due to programming issues. Very occasionally these little game systems can act up and can require a special touch.

Let us know today, we are here to help!

I’m getting errors when trying to compile the game.

Carefully go through the Quick Start Guide again and make sure you have followed each step. Making sure you have the libraries installed is a common gotcha.

Once you’ve revisited the Quick Start Guide then feel free to make a post in the Issues Category with the error you’re getting for specific help.

Whatever the last step was, it worked!

Happy day! You fixed your Arduboy!

Sorry you had some hiccups, please let us know in the Contact Form if there is any suggestion on how we can improve. Thanks for believing in Arduboy!

Play again?

For discussion on the content in this guide please see this thread: