[OLD] Arduboy Manager (PC)


(John Saunders) #14

Thanks. Yep, windows 7. I figured that part out and installed it already. (i dont use thus computer much. Its a 2009 laptop)

The program opens, but my computer doesnt recognize the arduboy when i plug it in. Ive made sure the arduboy is on and ive tried wit 2 different data cables


(Holmes) #15

Check out your Device Manager. It should be under your Ports section as an Arduino Leonardo. Do you see it listed there?

The most common issues people have seem to be either a) wrong type of cable, b) the Arduboy isn’t powered on, or c) the USB port is bad.


(John Saunders) #16

Yep, its there now.


Opening the arduboy manager now shows that arduboy is connected. Weird. I need to get a new computer.

So now i should just be able to select a file and hit transfer correct?


(Holmes) #17

Yep! That’s all you gotta do!

Hahaha! Yeah, it may be time to upgrade. :stuck_out_tongue:


(John Saunders) #18

Awesome man!!! Star honor installed with no problem. Now off to play some new games. Thanks for your help. And good job with the manager. Im sure if my computer and i were both a bit more capable, id have been able to do this without help.

And cant wait to play your rpg/ adventure game. Still pumped about it


(Derek W) #19

Hi there! Just got my Arduboy today and I have downloaded your software. I’ve got the Arduboy connected and turned on, but the Arduboy Manager is not detecting the system at all. Taking a look at your previous advice in this thread, I’ve made sure to look at my connected devices, and here’s what I’m seeing:

Basically, it recognizes that the Arduboy is there, but just shows up as a plain USB serial device under the device manager. Any advice you could give to help the Arduboy Manager recognize my Arduboy?


abSynth FM - FM Synthesizer with step sequencer
(Holmes) #20

That’s odd! It must be a Windows-related issue if Device Manager isn’t showing it properly. I’ve never seen this before.

Here’s a few questions:

  • What version of Windows are you running? A screenshot of this window may help.
  • Can you double-check with another cable? Sometimes cables can be unreliable or break over time.
  • What kind of USB port are you using? 2.0? 3.0? 1.1? I’ve heard of USB ports not having proper drivers installed, leading to USB devices not working properly.

(Derek W) #21

Sure thing! I’m running Windows 10, and here’s a screenshot of the properties window for that:

I’ve tried a couple of different cables, but to no avail. I’ve got a fresh one coming in a day that I will try as well. The cables have been plugged into USB 2.0 and a 3.0 port on this computer, and both are showing the same. The device list is showing Arduino Leonardo, but the Device Manager shows a USB serial device.


(Derek W) #22

Wow, you know…I feel so silly. Crait, I may have been a bit overzealous and neglected to unpack my Arduino software. Thus, I didn’t have the Arduino driver. It’s good to go now, my apologies for this little wild goose chase!


(Nicolas Castellani) #23

Hello, I’m having the same issue you detailed in your posts above but haven’t been able to solve it myself. You mentioned unpacking your Arduino software. Did you mean unzipping the download folder for the Arduboy Manager or is there another driver I need? I appreciate the help!


(Holmes) #24

Hey, thanks for the update, @andawarmgeek! Do you mind explaining how you fixed this problem so we can get @GameLifter and others caught up? :smiley:


(Derek W) #25

Not at all! I had previously downloaded the Arduino software from arduino.cc - make sure you download the Windows executable or ZIP, whichever you prefer - and, without realizing it, I had not installed it yet! So I installed the program. This got me the Arduino Leonardo device driver, so Windows was able to pick up my device in the device manager. After that, the Arduboy Manager works great and I am loving it!


(Holmes) #26

For anyone getting the issues that @GameLifter and @andawarmgeek had, please check out this link on installing drivers for the Arduboy:

http://community.arduboy.com/t/arduboy-driver-installation-windows-os-x/2276


#27

Thanks for this. Easy way to get started with loading games on Arduboy without having to worry about details like ide and library version numbers or any complicated setup process.


(Holmes) #28

The exact reason I created this. :wink:


(Mike Steele) #29

Holy crap! For a self described dummy when it comes to this stuff, I can’t stress enough how much I love this. It makes things as easy as I wanted it to be from the get go. Thanks so much!


(Nicolas Castellani) #30

Adding the driver worked! The Arduboy Manager is working perfectly now. Great job and thanks for the help!


#31

Is there any way to use this with Team ARG games? I’ve been having issues with the IDE.


(Holmes) #33

Team ARG has asked that their games not be hosted for my Arduboy Manager. :cry: HOWEVER, you can import any .hex file into Arduboy Manager using File > Import, then browse for the .hex file. Since your IDE is not working, you may not be able to compile the code into the .hex file. Maybe @JO3RI can help by including the .hex file in their downloads? :slight_smile:


#34

It’s understandable if they want to have control over how their games are distributed.

I don’t get errors when I compile the code in the IDE but when I upload the sketches. I’ll try to compile the code to a hex and see if I have more luck with the manager than the IDE for uploading.