PLEASE HELP - my Arduboy DIED ! ..... reset bricked Arduboy does NOT work :(

hi community,

my arduboy doesn’t work anymore. till yesterday uploading worked normal. then i was uploading a demo from team arg (i don’t know exactly which one) and after compiling and uploading it didn’t reboot and the screen stayed black!
i turned off and on the arduboy but the screen stayed black. the left green led is blinking fast when i connect it to the computer and arduino ide is running. if i close arduino ide the green led tuns off.
i tried to “reset arduboy if it is bricked” ( How to Reset Arduboy if it’s Bricked )
doesn’t work either !!!
i also installed arduino ide to another notebook there i get the following error:
**sketch\Arglib.cpp:142:6: warning: always_inline function might not be inlinable [-Wattributes]

void Arduboy::safeMode()


sketch\Arglib.cpp:92:6: warning: always_inline function might not be inlinable [-Wattributes]

void Arduboy::bootLCD()


on my own notebook there is NO error message.
the green led is still blinking after compiling and uploading and the screen stays black. in the left corner you can read “upload” for ever.

hope someone can help me on this problem because i am very disappointed about the arduboys’ quality. a brick or dying after 7 - 10 uploads is NOT acceptable

maybe someone knows how to do a full recovery.

p.s: i am on windows 10 the other one is win 7

thank you in advance for the helping

Try this:

  1. Make sure the Arduino IDE you’re using is V1.6.7 or higher. Look in the IDE window’s title bar to determine the version.
  • Install the Arduboy Library using the Library Manager, as instructed in the Quick Start Guide Step 2.
  • Load the Tunes demo sketch from the Arduboy library examples into the IDE:
    File > Examples > Arduboy > Tunes
  • Select Arduino Leonardo as the board type:
    Tools > Board: > Arduino Leonardo
  • Select the correct Port from the Tools menu and make sure it has a check mark beside it in the selection list.
  • Try to upload the Tunes sketch.
  • If the sketch doesn’t upload, try using the reset button. Note that the timing for pressing the reset button is fairly critical. You may have to try pressing it at different times before starting the upload to get it to work.
  • Let us know the result.

hi mate,

it W O R K E D already !!! i did NOT change anything and i proved everthing before posting.
and i wrote that i installed the arduino ide to another notebook BUT the same problem as on my notebook.

and i hope you do not misunderstand me but i think you didn’t really read my post - i tried to “reset” the arduboy MANY times. belive me - it does NOT work :cry:

short update: i followed your advice on pressing reset at different times and i got the arduboy back to life using the “tunes” example.
after getting arduboy back to life i tried all games & demo sketches and found the bad one. it is “do-nuts” from team arg. now i have the same problem again. no screen and no upload is working. i will try to reset till it comes back to life again.

does anyone else encounter this problem with “Do-Nuts” from team A.R.G. ???

Do-Nuts is only for the Arduboy DevKit. It hasn’t been updated with a version for the Arduboy Kickstarter production version.

ah okay i understand. too bad that the team arg doesn’t state this on their own site !!! it shows ALL demos are for arduboy…
very bad for beginners :dizzy_face:

last update:

@Scott, thanks for your help :thumbsup:

i found the right timing to reset the arduboy and upload another sketch again BUT this is really tricky and not suitable for the mass.
here is a list of demos and games that do NOT work for the arduboy at least for my arduboy:

##Do-Nuts; drawsprite; Tilesheet_Scrolling; Waving_Images and the game: TeenyTank

1 Like