PLS help, only sound works, no display output

I don’t know what to do, i have found that the display needs 3.3v in the schematic and it was wrong, i’ve looked more and it needs more than 7v so i connected it to 10v and it still doesn’t work

here are more photos

Hmm really tough to say without being able to test things. That is an incredible amount of what I am assuming is flux on those solder joints. It’s my guess that you may have some problems with the joints.

There is a joke that says you can’t use too much flux, but I think you might have found out. But also maybe are you using like rosin core solder meant for brazing pipes or something?

Or something that expired several decades ago?

1 Like

i checked every connection between the arduino and the screen, so it should be fine
also the voltage is supplied with no drop so it looks that it is sufficient

Maybe the OLED display itself requires such an voltage for the LED matrix but the modules usually have their own voltage booster to create that voltage and only require a VCC of 3.3V or 5V.

Also the Atmega32u4 on the Pro Micro can only handle 5.5V max.

Where did you connect the 10V too?

Your schematic is a bit hard to follow with all the crossing wires. I did not do a complete check but I noticed:

  1. OLED reset is connected to the down button besides D2?
  2. The common anode of the RGB LED is connected to GND instead of VCC?
  3. the flash chip is wired incorrectly

I think because of 3 the display doesn’t work. I recommend to desolder the flash chip and try again. If 1 is the case then pressing the down button would reset the display causing a black display.

  1. Sorry for that the crossing wiering it is not connected to the down button
  2. I didn’t connect the led so it should not cause any problems, but i probably made a mistake with the wiring, it was my first pcb
  3. i found some old video on youtube and tried conecting it how the guy sad, but it was quite hard to do, could you write me where co connect the chip?

I connected the 10v directly to the screen and removed the 5v line by scraping it, the arduino pro micro is getting only 5v

i did removed the flash chip and it still dosn’t work

What did you upload to test if it works?

Try this, with homemade package installed in Arduino IDE. select 8BitCADE XL as board, then from the file menu select examples > Arduboy2 > Hardware test and upload that to your board. See if you’ll see anything on your display. If not you can only check the wiring again and check for shorts bad connections. It may also be possible that you’ve fried your display by applying 10V.

I couldn’t find the hardware test, only the helloworld
This is the display, I tried running it at first with the 3.3v but it didn’t work, so i tried with 5v and then with 10v

Is it possible that 5v was also too much?
How to wire the memory correctly?

Over all thanx for your help

Then you’ve not installed the Homemade package or you have installed Arduboy2 library manually or through the library manager. Only use the Homemade package and remove the Arduboy2 library from your sketchbook libraries folder.

it only makes sounds when presing button(without the right button) and screen doesn’t show anything

Looks like it could but something with the OLED, but I’m sorry I cant help you there. I just wanted to know, where do you guys find those USB-C Pro Micros!!?

but you need to supply voltage on the input pin rather than with the usb C, i don’t know why but yeah

1 Like

Did you check your sketchbook library folder to see if the Arduboy2 library is instaled there?

To find your sketchbool location Go to preferences and at the top is your sketchbook location.

It’s probably because they just added the connector and not the required 5K1 resistors to make it USB C compliant.

I checked it now and there is nothing in this folder

I do heave found the arduboy2 hardwere test in the examples