Problem Compiling most games

Most games seem to have an issue :slightly_smiling:
Ardumod.h:25: error: ‘MUX4’ was not declared in this scope

#define ADC_VOLTAGE _BV(REFS0) | _BV(MUX4) | _BV(MUX3) | _BV(MUX2) | _BV(MUX1)

                                  ^

sketch\Ardumod.cpp:92:42: note: in expansion of macro ‘ADC_VOLTAGE’

randomSeed(~rawADC(ADC_TEMP) * ~rawADC(ADC_VOLTAGE) * ~micros() + micros());

                                      ^

sketch\Ardumod.cpp: In member function ‘uint16_t Arduboy::rawADC(byte)’:

Ardumod.cpp:101: error: ‘MUX5’ was not declared in this scope

 ADCSRB = _BV(MUX5);

              ^

exit status 1
’MUX4’ was not declared in this scope

Basically I tried to compile 3 different games and got the same error. Finally the snake game compiled with no issues ( I noticed it was only the games that have the Ardumod .h/cpp files.

I can actually code C++ so the code itself isn’t the problem. It keeps telling me that something that is blatently declared in the code isn’t actually declared. Which makes no sense. I played around with it for about a half hour but I’m not sure where the _BV reference comes from since the arduino IDE software is pretty poor and doesn’t let you trace references like VS does.

Also once I did get the snake game to compile I couldn’t actually load it onto my arduboy.
Are there any other settings I need to change in the IDE before attempting to upload?
I selected the Arduino Leonardo on COM3 but the Uploading part of the process just sits at a full bar and never returns a result until I press the verify button again.
Then it tells me it had problems uploading (which is pretty obvious).

Did you also make sure to set the Tools->Board setting to “Arduino Leonardo” as well, as described in the Quick Start Guide? It’s the option right above "Port: “COM3 (Arduino Leonardo)” in the screenshot below. If you skip that step I believe you will get compile errors.

Nope, the only reason you’d see this error is because the proper board was not selected. If you select Arduino Leonardo as the board or use the Arduboy specific board files you’ll get going in no time.

Ah ha! I had selected it the first time I installed the IDE, but part of the installer failed and the IDE was missing files.
So I reinstalled it and I forgot that step the second time.

Like I said I’m totally new to arduino’s really and only used some ancient version in 2008 to make a robot. But I only wrote the code part and my team handled the rest of the setup with the micro controller.

Got it all working here!

Also My Arduboy says 1 of 10000 on the back.

Did I literally get #1 or do all the Early bird ones say the same thing? Because I’m pretty hyped if I got the first one :slight_smile:

They all say that. We’re all just that cool/lucky! :slight_smile:

1 Like

Damn so many #1’s we are really that cool!!!

Well to be fair it says “1 of 10,000” not “#1 of 10,000”

That little punctuation makes a big difference :wink:

1 Like

Yep it does say 1 of 10000 but to be fair lots of art also says things like 3 of 300 without a #.

Haha, its just an unordered set. Take one element from 10 thousand, any element, regardless of order, and it is 1/40k. If you order the set of of 40k arduboys, and then pick the first one in that ordered set, it is also 1/40k.

The only games that I can get to work are the TEAMa.r.g. games. Anyone know of a fix? The games that come pre-loaded when I downloaded the Arduboy Library do not work. If they load it is just a black screen, most have a compiling error.

You get anywhere with this @stewa2jm? The search function in toolbar () is pretty handy.

You may also find the new classifieds section handy and open a “help wanted” post for your specific problem.

http://community.arduboy.com/c/classifieds

[QUOTE=ekem]The only games that I can get to work are the TEAMa.r.g. games. Anyone know of a fix?
The games that come pre-loaded when I downloaded the Arduboy Library do
not work. If they load it is just a black screen, most have a compiling
error.[/QUOTE]

I’ve done some searching, though not much recently. Haven’t tried any games recently either. What I did find was some of the problems are clearly due to some library coding issues between Kickstarter editions and developer boards. The other stuff I found I had figured out on my own (excluding -Master in file names for instance).

I still get compiling errors. And sometimes the compile but only get a black screen.

The ArduBreakout that come with the main ArduBoy library gets this error:
ArduBreakout.ino:12:21: fatal error: Arduboy.h: No such file or directory
Compilation Terminated

Other games get a long list of “declaration” and conflicts with declarations errors involving C and C++.

And various other erros. Since Arduino IDE won’t let me copy and paste the errors and some of them are 10’s of lines long, I’m not going to retype them here.

I’ll need to download some newer games to see if they’ve been fixed by the original developers and see what happens.

I also have no idea how to quote on this forum… every other forum I’m in there is a “quote” button. I had to actually type the code for this…

Do you have a Kickstarter Arduboy or a DevKit?

What version of the Arduino IDE are you trying to use (look in the window title bar)?

The latest version of the Arduino IDE gives you a Copy error messages button.

Just use the mouse to highlight the text you want to quote, then click on the
" quote reply box that pops up.

Thanks!

Just downloaded and installed the latest on my Ubuntu machine. I was on 1.0 something from the Software Center… Lame. I see the copy code now.

I have a Kickstarter edition.

@stewa2jm Did you get this resolved, I see we still have SOLVED in the title but that appears to be from another user. Let us know if we can help!

I’m having the same problem as stewa2jm.Team ARG games work with no fuss but any other game will not work. I’m using Windows 10 and the most recent Arduino 1.6.8. I do have it set to Arduino Leonardo board and the correct COM port it is connected to.

Example:

I download the Puzzle Pack zip file and extract it.

I then go into the folder and select the .ino file.

Then I get a message telling me:

The file “ArduboyLife.ino” needs to be inside a sketch folder named “ArduboyLife”. Create this folder, move the file, and continue?

I click okay and it brings me to the sketch. I then try to compile and it gives me this error message:

Arduino: 1.6.8 (Windows 10), Board: “Arduino Leonardo”

C:\Users\user\Downloads\puzzle_pack-master\puzzle_pack-master\puzzle_pack\puzzle_pack.ino:9:21: fatal error: Ardumod.h: No such file or directory

#include “Ardumod.h”

                 ^

compilation terminated.

exit status 1
Error compiling for board Arduino Leonardo.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

It happens with every game except Team ARG games. If I say no to creating a new sketch folder for the .ino file, it won’t work either.

Mmm there are a couple of things going on with your approach. Have you installed the library in the IDE per the guides?

In the case of github downloads, when you click the download zip button you get a zip file with a “GAMENAME_master” folder in it. Just delete the “_master” off the end of the extracted folder name. Out of curiosity, have you tried my game, Glove? I recently updated it but would like to know of there are any compilation issues that may have come up.

1 Like

Have you tried any of the example sketches included with the library?
File -> Examples -> Arduboy -> ...

1 Like