Problem uploading code

Hello, I am making a game to my arduboy. Everytime I try to upload though, the yelow and green lights blink, but it shows a message “avrdude:verification error; content mismatch”, and i can’t upload it.
I think this is a bootloader related issue. Is there any way I can solve it?

I am not sure what is going on there.

Are you using a genuine Arduboy or a homemade one? Traditional or FX?

What confiugrstion sttings are you using? Board, core, bootloader, etc?

It is a regular arduboy, tradicional. Bought 2 years ago, worked everytime, but yesterday it stopped uploading.
btw, i fixed the title, should have been content mismatch

What settings are you using in the Arduino IDE when uploading?


something like this

Can you screen shot the tools menu …

I know it shouldn’t be the problem but it could not hurt to update your IDE. There is a release 1.8.18 which is latest of the version you have thee. There is also a new version 2.0 which is built on a different technology.


yeah sure, i can update the IDE. I will do this.

What happens if you set the programmer to just AVR ISP? That is what I have set.

(You can tell I am guessing now!)

Same thing, it tries to upload, but then appears a mensage “avrdude: verification error; content mismatch”, and it doesnt upload.


Here’s a video I made. I don’t know if it helps

Sorry … I do not know what is happening here. Maybe someone can chime in and offer some more assistance.

1 Like

Could it be a faulty or damaged usb cable

2 Likes

I tried using a different cable. Still no improvement.

I have never seen this issue before.
May be an issue with the bootloader ?!.. :grimacing:

  • Have you tried putting the Arduboy into ‘flashlight’ mode first?
  • Are you able to try a different computer?
  • Have you tried uninstalling and reinstalling the Arduino IDE?

There’s quite a few things that could be the root of the problem.

I tried using flashlight mode. But at the end the arduboy just boots the last game that was booted before the issue started to happen.
I tried a different computer. Same thing, yellow and green lights flashes, but no boot.
I tried to uninstall the arduino ide. removed all libraries. Downloaded it back at arduino.cc, but still no success. The error mensage continues to appear.

The short error log in your image. Mentions the proper device signature. So your Arduboy enters bootloader mode and communication seems ok. So I thinkthe verification error is genuine. Meaning the code that was burned (or not burned) isn’t the same. Things that come to mind.

  1. instable power/ battery
  2. corrupted bootloader
  3. the Arduboy’s flash is wornout (not likely unless you’ve already programmed it 10000 times)

for 1 try turing your Arduboy off and charge it for a couple of ours
for 2 If you have an ISP programmer (or spare Arduino) try reflash the bootloader.

to confirm case 2 you can dump the flash contents using avr dude.

From your error log copy the line avrdude line that looks like below and paste it in command line window:

[path]/avrdude -C[path]/avrdude.conf -v -V -patmega32u4 -cavr109 -P[COM port] -b57600 -D -Uflash:w:[hex file].hex:i

and change the bold parts as below:

[path]/avrdude -C[path]/avrdude.conf -v -V -patmega32u4 -cavr109 -P[COM port] -b57600 -D -Uflash:r:dump.bin:r

note i have changed the paths to [path] just for clarity, You should not change them.

if you run that command it will backup the full 32K flash contents to a dump.bin file in the current working directory of your command line. Zip it up and post it here so I can have a look at it to see if your bootloader is corrupted.

You will also need to put your Arduboy in bootloader mode manually. You can do this by opening the serial monitor in Arduino ide and change the baudrate to 1200. If you then close the serial monitor. Arduboy will be triggered into bootloader mode and you can run above command.

1 Like

Thanks for the reply! I will try your instructions probably tomorrow because a lot of it is stuff I still dont know how to do. So I need to research a little bit. I will keep you up with what I found.

If you’re still having problems let me know, if you would like to send it in for repairs I can help with that you can write to Contact — Arduboy

Very strange indeed!

1 Like

Thanks for the support, i will let you know if I need to send it in for repairs