Problem uploading games

Hi

I have a game running on my arduboy. So the device is somewhat working. I can play this game etc. But I am not able to upload new games. So I need some help.

I have tried with the TEAM a.r.g. uploader and also https://arduboy.ried.cl

None of them seem to find my arduboy. I am using Windows 10. Where do I start? I need help.

And just like that it started working. I tried to push up (or was it down) during boot of arduboy and then it worked.

1 Like

Feels like this happens to me all the time when I’m using my colleague’s code :sweat_smile:. Best strategy I’ve found when I get issues like this is to reset it: using a paperclip at the base for a few secs and press up as it’s loading so it goes to flashlight mode. My next upload usually works like a charm!

Which game did you last upload?
Most likely it was one of the ones that removes the USB code to try to get a bit more memory.
The side effect of which is preventing the Arduboy from being auto-detected by any upload tools,
hence a manual button press is needed.


You might want to use something less pointy to avoid damaging the button.

Personally I tend to use either the thin tip of a mechanical pencil (with the lead retracted),
or a SIM card ejector tool:
SIMTool
You can sometimes find them cheap in phone or electronics shops.
(The one I have came from a screwdriver kit.)

Ultimately the point is to try to use something blunt if you want to keep your reset button undamaged.
A bent paperclip might also work if it’s not too sharp.

1 Like

Ye, make sure when you upload games, boot it into Flashlight Mode. (Up Arrow + Power On) But some games wont boot into Flashlight Mode, but don’t freak out, 9/10 times it’ll upload another game no problem. But if it doesn’t upload still, reset it then it should work, but if it still doesn’t, there is probably something wrong with your Arduboy.

1 Like

As someone who edits articles I should have read over what I posted (that’s a good habit overall). I do use a paperclip actually. And I’m not even sure why I capitalized pin, as if I really believed in it lol. Lost my SIM card ejector and keep forgetting to get a new one so the paperclip works quite well for now :slight_smile:

1 Like

You can also use my ArduManFX tool. Theres a video in the forum post on how to use it to recover an Arduboy. Works everytime and doesn’t require any timing or holding buttons down when pressing the reset button. Simply click the “Recover Corrupted Arduboy” button then press the reset button at anytime. The ArduManFX can also be used to browse the repo and upload games with binaries for Windows, Linux, and Mac.

3 Likes